Bug 80410 - FILESAVE: Embedded Open XML DOCX object inside DOCX converts to picture when opened in MSO
Summary: FILESAVE: Embedded Open XML DOCX object inside DOCX converts to picture when ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: Other All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: BSA interoperability target:4.4.0 tar...
Keywords:
: 80408 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-06-23 15:24 UTC by Mark Kaplan
Modified: 2014-07-16 13:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
A DOCX file which has an embedded DOCX object (Open XML Word 2010 document) (24.15 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-06-23 15:24 UTC, Mark Kaplan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Kaplan 2014-06-23 15:24:39 UTC
Created attachment 101597 [details]
A DOCX file which has an embedded DOCX object (Open XML Word 2010 document)

Problem description:
When loading a DOCX into Writer that has an embedded DOCX object, and saving it to a NEW.DOCX - the embedded DOCX is being converted to a picture (when opening the NEW.DOCX in Word 2010 and selecting the embedded object, the 'Picture Tools' contextual menu appears). 

Steps to reproduce:
1. Open attached DOCX in LO
2. Save as NEW.DOCX
3. Open NEW.DOCX in Word - the embedded DOCX had been converted to a picture

Current behavior:
Embedded DOCX object is converted to a picture when round tripped in LO

Expected behavior:
Embedded DOCX object should be preserved when round tripped in LO
              
Operating System: All
Version: 4.4.0.0.alpha0+ Master
Comment 1 Yousuf Philips (jay) (retired) 2014-06-24 23:14:36 UTC
Confirmed that the export from Linux Mint in 3.6 - 4.2, 4.3.0 and master, reopened in MSO 2013 shows as a picture.

Opening the saved .docx from 4.1 and 4.2 in MSO shows two pictures rather than one.

Reopening the saved .docx back in LibO doesnt show the OLE in version 3.6 - 4.2, including 4.2.6. Only reopening the saved .docx in 4.3 and master works.
Comment 2 Yousuf Philips (jay) (retired) 2014-06-25 02:13:54 UTC
*** Bug 80408 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2014-07-10 21:06:07 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3ffb06e76be9be7499f12973139949ddbf6297b9

fdo#80410: sw: DOCX export: support DOCX embedded objects



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Michael Stahl (CIB) 2014-07-10 21:06:52 UTC
this doesn't look like a regression to me, because this never worked:
the OLE was always either lost or degraded to a picture.

but since it was so easy i had a fix already before noticing that...
Comment 5 Yousuf Philips (jay) (retired) 2014-07-10 21:39:06 UTC
Well the regression was pointed at 4.1 & 4.2 shows two pictures rather than one, as it worked in 4.0, and hoped that a 4.2 fix might be possible. :)
Comment 6 Commit Notification 2014-07-11 14:37:07 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=46d9724369ba4f248eab0133d396bd8f6a4453c6

fdo#80410: let's add a unit test too...



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Michael Stahl (CIB) 2014-07-11 14:58:23 UTC
> Well the regression was pointed at 4.1 & 4.2 shows two pictures rather than one,
> as it worked in 4.0, and hoped that a 4.2 fix might be possible. :)

i've looked at relevant changes and there were a lot of commits
related to OLE export between 4.2 and 4.3, i don't think it's
a good idea to backport that much to the 4.2 branch now.

but i've backported a couple bugfixes to the 4.3 branch to get
various file types properly exported.
Comment 8 Commit Notification 2014-07-11 15:22:39 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=589b256452e729e05d9610f10fb2408810e56eb6&h=libreoffice-4-3

fdo#80410: sw: DOCX export: support DOCX embedded objects


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Yousuf Philips (jay) (retired) 2014-07-16 07:08:38 UTC
Hi Michael,

I had closed bug 80408 as it was exactly the same as this one, but instead had an embedded doc file. Was this also fixed for embedded doc files?
Comment 10 Michael Stahl (CIB) 2014-07-16 13:46:12 UTC
(In reply to comment #9)
> I had closed bug 80408 as it was exactly the same as this one, but instead
> had an embedded doc file. Was this also fixed for embedded doc files?

it was, but by a different commit; every file type needs to be explicitly recognized and the right mime-type set; i'll add some fixed bugs to see also