Bug Hunting Session
Bug 80461 - EDITING: context menu for formula bar input line
Summary: EDITING: context menu for formula bar input line
Status: RESOLVED DUPLICATE of bug 57000
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, topicUI
Depends on:
Blocks: Calc-Formula-Bar
  Show dependency treegraph
 
Reported: 2014-06-24 07:46 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-22 01:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example screenshot: MSO 2010 (73.17 KB, image/png)
2014-06-24 08:17 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-06-24 07:46:53 UTC
It would be nice to be able to right-click in the input line and be able to cut, copy, paste, and format cell, like in Kingsoft Spreadsheet and Excel.
Comment 1 Kevin Suo 2014-06-24 08:17:21 UTC
Created attachment 101645 [details]
Example screenshot: MSO 2010

This is what it look like in Microsoft Office 2010. When right click in the formula bar, it shows a dialog allowing you to copy, paste, format cells, etc.

Seems a good idea, set to NEW.
Comment 2 mingle 2015-07-05 09:36:54 UTC
Yes, this is something I really need too. No just due to the fact I'm a 15 year Excel user. It's just logical to have text-boxes like the Input Line right-clickable.
Comment 3 Yousuf Philips (jay) (retired) 2015-07-05 14:40:43 UTC
CCing ux-advise if they have any suggestions for this enhancement.
Comment 4 Regina Henschel 2015-07-05 15:21:43 UTC
Similar to bug 68500.

Such context menu exists for the input line for a formula in a Writer table. Such context menu should contain "insert special character" same as in Writer.

I second this request.
Comment 5 Yousuf Philips (jay) (retired) 2015-08-03 16:55:48 UTC
Closing this as a duplicate

*** This bug has been marked as a duplicate of bug 57000 ***
Comment 6 Robinson Tryon (qubit) 2015-12-16 05:30:50 UTC
Migrating Whiteboard tags to Keywords: (needsDevEval, topicUI)
[NinjaEdit]