Bug 80713 - Missing string reference keys [KeyID] in Writer
Summary: Missing string reference keys [KeyID] in Writer
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.0 target:4.3.0.2 target:6....
Keywords:
Depends on:
Blocks: Not-Localizable
  Show dependency treegraph
 
Reported: 2014-06-30 13:44 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-12-04 03:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-06-30 13:44:04 UTC
As i'm working on the arabic UI translation, i noticed the following strings that had no string reference id with the 'Key ID' language pack installed.

* File > Send > To MediaWiki
* View > Toolbars > Text Orientation
* Tools > Options > Load/Save > General > 'Always save as' has 5 entries in its drop down with no key
Comment 1 Yousuf Philips (jay) (retired) 2014-06-30 21:48:34 UTC
In the 'Compress Graphic...' option of right-clicking an image, Type is only in english. I have 'PNG image' displayed, but 'image' should be translatable.
Comment 2 Yousuf Philips (jay) (retired) 2014-07-01 00:24:46 UTC
In Tools > Options > LibreOffice Calc > Sort List, all the entries in Lists and Entries are in english.

In Area Dialog, Gradient tab, most of the colors.

In Area Dialog, Colors tab, the word 'standard' next to 'Table:'. I have seen this same one in all dialogs that allow color section.

In Tools > Options > Language Settings > Writing Aids, all the entries under 'available language modules'.
Comment 3 Commit Notification 2014-07-01 12:51:15 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=33e9d408aa2c0a9b86c5daaed0e15d86f6c599dc

Related: fdo#80713 make 'Gif image', etc. translatable



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Caolán McNamara 2014-07-01 13:02:38 UTC
The compress dialog problem should be fixed by the above commit.

The writing aids names are not translatable, see e.g. SpellChecker::getServiceDisplayName but probably should be alright.

And I don't know what the other problems are, a look at the .po files show they should be available for translation. So perhaps those are some problem with the Key ID package generation.
Comment 5 Yousuf Philips (jay) (retired) 2014-07-01 13:08:06 UTC
@Caolan: i think just the word 'image' needs to be translated and not the whole string. Having every variation as string keys, will just add extra burden on the translators for no real benefit.
Comment 6 Commit Notification 2014-07-01 16:39:04 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=acb1e71b48023f526d3ba9a6ff4d5f45600b48cc&h=libreoffice-4-3

Related: fdo#80713 make 'Gif image', etc. translatable


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Adolfo Jayme 2014-07-02 01:26:21 UTC
(In reply to comment #5)
> @Caolan: i think just the word 'image' needs to be translated and not the
> whole string. Having every variation as string keys, will just add extra
> burden on the translators for no real benefit.

No, I disagree. Most languages are not like English, where you can just translate a part of a string and let the software fill the other in and still be grammatically correct. But this never works with other languages.
Comment 8 Yousuf Philips (jay) (retired) 2014-07-19 08:56:23 UTC
So is there an updated 4.3 Key ID package i can test the other entries on. Setting this to NEW as Caolan already put in a commit for it.
Comment 9 Yousuf Philips (jay) (retired) 2014-08-24 21:32:32 UTC
Was doing some more arabic translation and noticed in the insert fields dialog, under the 'variables' tab, in the formula column there is the word 'General' that doesnt have a reference key.
Comment 10 Yousuf Philips (jay) (retired) 2014-11-12 21:59:54 UTC
Hi All,

I dont see string references for start center buttons for '~Recent Files' and 'He~lp'.
Comment 11 Yousuf Philips (jay) (retired) 2014-11-12 22:05:53 UTC
Also the statusbar page number string doesnt have a reference.
Comment 12 Yousuf Philips (jay) (retired) 2014-11-12 22:20:47 UTC
Right-click paste special as well as its submenu entries of unformatted text and more options.
Comment 13 QA Administrators 2015-12-20 16:09:04 UTC Comment hidden (obsolete)
Comment 14 QA Administrators 2017-01-03 19:47:01 UTC Comment hidden (obsolete)
Comment 15 Yousuf Philips (jay) (retired) 2017-10-22 19:12:33 UTC
The two thing that are remaining is

1. In Tools > Options > Language Settings > Writing Aids, all the entries under 'available language modules'.

https://opengrok.libreoffice.org/xref/core/lingucomponent/source/spellcheck/spell/sspellimp.cxx#584

https://opengrok.libreoffice.org/xref/core/lingucomponent/source/hyphenator/hyphen/hyphenimp.cxx#751

https://opengrok.libreoffice.org/xref/core/lingucomponent/source/thesaurus/libnth/nthesimp.cxx#522

wasnt able to find the location of the lightproof string.

2. Insert > Field > More Fields > Variables and in the formula column there is the word 'General' that doesnt have a reference key.
Comment 16 Caolán McNamara 2017-10-23 12:12:06 UTC
re "Insert > Field > More Fields > Variables and in the formula column there is the word 'General' that doesnt have a reference key." I believe this comes from the number format definitions in the xml files in i18npool/source/localedata/data/<LANGUAGE>.xml FixedFormatskey1
Comment 17 Commit Notification 2017-10-25 09:10:09 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=57f649dc9a72e043901582a6e3da916da18ca4ed

Related: tdf#80713 allow translation of linguistic service display names

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Yousuf Philips (jay) (retired) 2017-10-25 10:32:40 UTC
(In reply to Caolán McNamara from comment #16)
> I believe this
> comes from the number format definitions in the xml files in
> i18npool/source/localedata/data/<LANGUAGE>.xml FixedFormatskey1

I checked french, chinese, and arabic and all show up as 'General'.

Any thoughts on where the lightproof string is?
Comment 19 Xisco Faulí 2017-11-28 09:14:51 UTC
A polite ping to Caolán McNamara: is this bug fixed? if so, could you
please close it as RESOLVED FIXED ? Thanks
Comment 20 Gabor Kelemen 2017-11-29 22:22:05 UTC
(In reply to Yousuf Philips (jay) from comment #18)
> Any thoughts on where the lightproof string is?

Yes, those are hardcoded in the dictionaries module: 

$ git grep "Lightproof grammar checker" | grep name
en/pythonpath/lightproof_impl_en.py:name = "Lightproof grammar checker (English)"
hu_HU/pythonpath/lightproof_impl_hu_HU.py:name = "Lightproof grammar checker (magyar)"
pt_BR/pythonpath/lightproof_impl_pt_BR.py:name = "Lightproof grammar checker (Portuguese Brazilian)"
ru_RU/pythonpath/lightproof_impl_ru_RU.py:name = "Lightproof grammar checker (Russian)"

Not sure what could be a simple way to translate these.

Also, these:

* File > Send > To MediaWiki -> Already translated, yet it appears untranslated for me (on Ubuntu):
https://translations.documentfoundation.org/hu/libo_ui/translate/#search=v5nd2&sfields=source,target,notes,locations

* Tools > Options > Load/Save > General > 'Always save as' has 5 entries in its drop down with no key

I still see some such, mostly the "Flat XML ODF *" variants, also DocBook for text documents.
Comment 21 Andras Timar 2017-12-01 15:02:59 UTC
(In reply to Gabor Kelemen from comment #20)
> $ git grep "Lightproof grammar checker" | grep name
> en/pythonpath/lightproof_impl_en.py:name = "Lightproof grammar checker
> (English)"
> hu_HU/pythonpath/lightproof_impl_hu_HU.py:name = "Lightproof grammar checker
> (magyar)"
> pt_BR/pythonpath/lightproof_impl_pt_BR.py:name = "Lightproof grammar checker
> (Portuguese Brazilian)"
> ru_RU/pythonpath/lightproof_impl_ru_RU.py:name = "Lightproof grammar checker
> (Russian)"
> 
> Not sure what could be a simple way to translate these.
> 

Currently we have (in case of e.g. Hungarian)

   # XServiceDisplayName
    def getServiceDisplayName(self, aLocale):
        return lightproof_impl_hu_HU.name

which returns:
    name = "Lightproof grammar checker (magyar)"

Option 1: translate with .properties files, like we localize LibreLogo
Option 2: use gettext (and beware of Python 2 vs. Python 3)
Option 3: (hack) localize in cui/source/options/optlingu.cxx where we use this return value
Comment 22 Commit Notification 2017-12-01 20:57:07 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1764c0358d7de602d6efaca940bde9081f7a0b65

tdf#80713 Translate a few file format names

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2017-12-03 08:54:05 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2d9752d343d92041deec5eaf45da48453337a014&h=libreoffice-6-0

tdf#80713 Translate a few file format names

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Gabor Kelemen 2017-12-03 10:52:46 UTC
(In reply to Andras Timar from comment #21)
> Option 1: translate with .properties files, like we localize LibreLogo
> Option 2: use gettext (and beware of Python 2 vs. Python 3)
> Option 3: (hack) localize in cui/source/options/optlingu.cxx where we use
> this return value

I'd prefer to use gettext to mark the strings for extraction in place.

Keeping the strings in another file for localization and keeping up the sync is too fragile for my taste.
Comment 25 QA Administrators 2018-12-04 03:48:05 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug