Bug 80761 - Cells hidden with filters get deleted when dragging contents UPWARDS over hidden cells
Summary: Cells hidden with filters get deleted when dragging contents UPWARDS over hid...
Status: RESOLVED DUPLICATE of bug 81803
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-01 16:41 UTC by Matt Newham
Modified: 2018-01-06 14:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Newham 2014-07-01 16:41:45 UTC
Referring to bug 35345 - the same bug conditions are seen now, when dragging data UPWARDS over hidden cells:

Steps to reproduce: 
1. open spreadsheet
2. Filter column d  "<>b" (you can use special filter "filterdforb")
   rows 5:7 will beocme hidden
3. Click on 'A4' with the red "X"
   Cell cursor with little fill handle at the right bottom corner appears
4. Move mouse pointer to fill handle so that mouse pointer view changes
5. click and drag/drop fill handle to'A1'
   red border around fill area 'A1:A4' appears
6. release mouse button:
   Range within round border will be filled with red "X"
7. Menu 'Data > Filter > Remove Filter' to make hidden rows visible
   expected: hidden cells will not have been changed
   actual: cells are empty

This only occurs when dragging data upwards.

It appears that whatever change was made in 3.4.0 still exists but only in the unusual scenario of dragging data UPWARDS over hidden cells.
Comment 1 Joel Madero 2014-09-04 14:04:20 UTC
Confirmed:
Bodhi Linux 2.x
LibreOffice 4.3.1.2 release

Setting as:
New - confirmed
Minor - won't prevent high quality work but can slow you down (ie there is a relatively straight forward workaround to just not hide cells)
Medium - users might not be aware until they've done quite a bit of work.


If this is a regression please add "regression" to keyword field and tell us what version of LibreOffice did not display this problem. Thanks!
Comment 2 QA Administrators 2015-10-14 19:58:07 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2016-11-08 11:38:03 UTC Comment hidden (obsolete)
Comment 4 Regina Henschel 2018-01-06 14:15:49 UTC

*** This bug has been marked as a duplicate of bug 81803 ***