Bug Hunting Session
Bug 80788 - EDITING: Typing slow when typing in asian and RTL languages due to dictionary
Summary: EDITING: Typing slow when typing in asian and RTL languages due to dictionary
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
: 74248 (view as bug list)
Depends on:
Blocks: RTL-CTL CJK
  Show dependency treegraph
 
Reported: 2014-07-02 06:31 UTC by astyh83
Modified: 2016-09-17 05:23 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample of document on which problem occurs. The original document is 13 pages with 39 footnotes. (49.27 KB, application/vnd.oasis.opendocument.text)
2014-07-06 15:52 UTC, astyh83
Details

Note You need to log in before you can comment on or make changes to this bug.
Description astyh83 2014-07-02 06:31:39 UTC
Writer gets very slow when typing footnotes. I need to wait an average of one to two seconds for each letter to appear as I type. The situation gets worse when I type in Chinese and use Zotero to add citations. 

Typing in the main document section does not present the same problem.
Comment 1 Yousuf Philips (jay) (retired) 2014-07-06 03:11:25 UTC
Dear astyh83,

Can you please provide us with the version of libreoffice that you are running and possibly a sample document where you see this behaviour happening.
Comment 2 astyh83 2014-07-06 15:52:51 UTC
Created attachment 102329 [details]
Sample of document on which problem occurs. The original document is 13 pages with 39 footnotes.

I am using Liberoffice ver 4.2.4.2
Comment 3 Yousuf Philips (jay) (retired) 2014-07-06 20:24:00 UTC
Hi astyh83,

I didnt notice any problems typing english, but noticed some slowness typing arabic in the footnote. But then i opened a new document and typed in arabic there and also noticed the typing was slow. So is the typing slow even when not in the footnote?
Comment 4 astyh83 2014-07-06 21:13:37 UTC
Hi Jay, 

At was reasonably faster when typing on the main document. I would not ssay that was 'slow', but the lag was tolerable. 

Also, the full-width punctations in Chinese do not align properly, which makes the document look ugly. I don't know whether this is apparent in Arabic as well. 

Will be filing another bug report for this issue.
Comment 5 Yousuf Philips (jay) (retired) 2014-07-07 01:07:09 UTC
Did some more testing and i see that whenever i press space bar, there is a delay to show the next word's letters. Tested it on Windows as well and it has the same issue, as i thought it might only be Linux only. Also thought it might be font related but it was the same when i used Tahoma or Droid Arabic Nask. Also thought it was AutoSpellcheck related, but disabling that didnt change it.

Steps to reproduce:
1) open writer
2) switch to arabic or asian keyboards
3) type random words quickly

@suokunlong: can you check if this happens with you as well in chinese.
Comment 6 astyh83 2014-07-07 06:21:14 UTC
Yes, it does.
Comment 7 Yousuf Philips (jay) (retired) 2014-07-07 06:44:21 UTC
Forgot to mention that if i type in arabic on libreoffice which doesnt have the arabic dictionary, it will type quickly, but if the dictionary is available it is slow. But from what i can see, there is no chinese dictionary, so i dont know why this would be effecting CJK typing.
Comment 8 Yousuf Philips (jay) (retired) 2014-07-11 01:20:17 UTC
*** Bug 74248 has been marked as a duplicate of this bug. ***
Comment 9 Kevin Suo 2014-07-15 14:18:44 UTC
Added the font issue Bug 81272 as see also.
Comment 10 Kevin Suo 2014-07-15 14:21:53 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2015-12-20 16:21:14 UTC Comment hidden (obsolete)
Comment 12 Aron Budea 2016-09-17 05:23:33 UTC
I assume the report was closed because the issue is gone.
Adjusting status to WORKSFORME, since the commit fixing the issue is unknown.