Download it now!
Bug 80799 - FILEOPEN: svg import broken
Summary: FILEOPEN: svg import broken
Status: RESOLVED DUPLICATE of bug 78554
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-07-02 10:08 UTC by klaus.welch
Modified: 2015-12-15 10:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description klaus.welch 2014-07-02 10:08:26 UTC
Problem description:
In imported svg drawings all text is not shown.

Steps to reproduce:
1. create a drawing with LibreOfficeDraw that contains text
2. export drawing as test.svg
3. import test.svg into writer document (Insert->Image->from_file)

Current behavior:
Text contained in the drawing is not shown.

Expected behavior:
Drawing presented as in LibreOfficeDraw.

svg drawing exported with v4.2.1.1 is correctly displayed when imported with writer of same version.

Same svg drawing exported with v4.2.5.2 is binary identical to one exported with v4.2.1.1 (exporter unchanged).

svg drawing imported with v4.2.5.2 is broken (incorrectly displayed, missing text).
              
Operating System: Linux (Other)
Version: 4.2.5.2 release
Last worked in: 4.2.1.1 release
Comment 1 Yousuf Philips (jay) (retired) 2014-07-04 00:28:12 UTC
Hi Klaus,

Thank you for reporting this bug. It has been reported before and should will be fixed in due time. It is last known to be fine when using 4.2.3.

*** This bug has been marked as a duplicate of bug 78554 ***
Comment 2 Robinson Tryon (qubit) 2015-12-15 10:57:51 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]