Download it now!
Bug 80812 - FILEOPEN: Font problems with chinese XLS file
Summary: FILEOPEN: Font problems with chinese XLS file
Status: RESOLVED DUPLICATE of bug 107484
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability WW8
Keywords: filter:xls
Depends on:
Blocks: CJK Font-Substitution
  Show dependency treegraph
 
Reported: 2014-07-02 15:09 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-22 18:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
shows the font drop down field is empty when D4 is selected (77.22 KB, image/png)
2014-07-02 15:09 UTC, Yousuf Philips (jay) (retired)
Details
shows the font drop down field showing the font in chinese and in italics (77.22 KB, image/png)
2014-07-02 15:10 UTC, Yousuf Philips (jay) (retired)
Details
font-screenshots.org (works for me) (249.44 KB, application/vnd.oasis.opendocument.graphics)
2014-07-03 13:15 UTC, Kevin Suo
Details
shows the font drop down field showing the font in chinese and in italics (79.66 KB, image/png)
2014-07-16 14:23 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-07-02 15:09:07 UTC
Created attachment 102140 [details]
shows the font drop down field is empty when D4 is selected

When testing attachment 102136 [details] from bug 80604, i noticed two font issues. Firstly cell D4 according to excel has the font aharoni assigned to it but LibO has it with a blank entry in the font drop down (LibO 3.3 - 4.4). Secondly in 4.1 and above, the chinese font used in the other cells of the spreadsheet is shown in the font drop down in chinese as well as in italics, as if its not installed. Tested on Windows and Linux
Comment 1 Yousuf Philips (jay) (retired) 2014-07-02 15:10:07 UTC
Created attachment 102141 [details]
shows the font drop down field showing the font in chinese and in italics
Comment 2 Kevin Suo 2014-07-02 16:10:15 UTC
hi Jay,
For the first issue, it's not a bug. font drop down is showing back because the cell has both Chinese and westin chars in it. 
For the 2nd one, you attached a same image. I'll test again tomorrow, because im now using mobile phone.
Comment 3 Kevin Suo 2014-07-03 13:15:30 UTC
Created attachment 102197 [details]
font-screenshots.org (works for me)

Ubuntu 14.04 x86, libreoffice 4.3.0.1.

Cell D4 is not showing blank font in drop down.
Other cells are showing italic font names because I do not have that font installed.
Comment 4 Owen Genat (retired) 2014-07-16 13:03:47 UTC
(In reply to comment #2)
> For the first issue, it's not a bug. font drop down is showing back because
> the cell has both Chinese and westin chars in it. 

Confirmed. D3 contains WenQuanYi Zen Hei and Arial; D4 contains WenQuanYi Zen Hei and Aharoni.

(In reply to comment #3)
> Other cells are showing italic font names because I do not have that font
> installed.

Also confirmed. Font name is 微软雅黑 which appears to be Microsoft YaHei.
Comment 5 Yousuf Philips (jay) (retired) 2014-07-16 14:23:46 UTC
Created attachment 102924 [details]
shows the font drop down field showing the font in chinese and in italics

My bad Kevin, didnt notice i upload the same image twice. :)

Well i do have the font installed and its still showing in italics, because the font name is written in chinese characters, rather than english.
Comment 6 Kevin Suo 2014-07-16 15:34:52 UTC
(In reply to comment #4)
> Confirmed. D3 contains WenQuanYi Zen Hei and Arial; D4 contains WenQuanYi
> Zen Hei and Aharoni.
No, D3 contains "微软雅黑" and "Aharoni", while D4 is all formatted as "Aparajita".

> Also confirmed. Font name is 微软雅黑 which appears to be Microsoft YaHei.
微软雅黑 = Microsoft YaHei.
One is Chinese name, the other is english name, but it's the same font. I think if you have Microsoft YaHei installled already, it should not be italics in drop-down.
Wired.
Comment 7 Kevin Suo 2014-07-16 15:48:17 UTC
(In reply to comment #6)I
> I think if you have Microsoft YaHei installled already, it should not be
> italics in drop-down.

In my system, I have that font installed, and the font dropdown is showing "微软雅黑“ not in italics. 
However, if I set the font names as "Microsoft Yahei", it will show as italics.

Does this have some to do with locale settings or system language? 
Or, I think I is really a bug: If libreoffice can not find a font named "微软雅黑“, it should then lookup whether there is a font named "Microsoft Yahei" exists. (I mean, it should lookup both the english name and the local name. In linux, if you run fc-list, it will show Chinese fonts both in english and in Chinese)

Also, I see some people applying font settings as "SimSun;宋体" or "微软雅黑;Microsoft Yahei" (Chinese name and English name seperated by ;). LibreOffice accepts this kind of font list also. This may be a workaround to avoid font problems.
Comment 8 Yousuf Philips (jay) (retired) 2014-07-16 16:19:19 UTC
(In reply to comment #7)
> Also, I see some people applying font settings as "SimSun;宋体" or
> "微软雅黑;Microsoft Yahei" (Chinese name and English name seperated by ;).
> LibreOffice accepts this kind of font list also. This may be a workaround to
> avoid font problems.

Yes i've seen that in libreoffice as well, both english and chinese names next to each other.
Comment 9 Owen Genat (retired) 2014-07-18 05:26:36 UTC
(In reply to comment #6)
> No, D3 contains "微软雅黑" and "Aharoni", while D4 is all formatted as
> "Aparajita".

Sorry, I was getting font substitution. Thanks for the correction Kevin.

(In reply to comment #7)
> Does this have some to do with locale settings or system language? 

That would be my guess. The TTF Name table often has multiple versions of a field (e.g., Fullname) on a per-locale basis. For Microsoft YaHei font v5.00 I have "Microsoft YaHei" in the English (US) version of this field and "微软雅黑" in the Chinese (PRC) version of this field.
Comment 10 Buovjaga 2014-11-04 09:02:51 UTC
I confirm the blank on D4 and italics on others, but is LO to blame?

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: ad6d94009cf8ea526eb70bf1a07e5c6a21320f83
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-11-04_00:06:27
Comment 11 Yousuf Philips (jay) (retired) 2014-11-04 11:01:36 UTC
As beluga confirmed D4 was blank, i'm setting it to NEW.
Comment 12 Robinson Tryon (qubit) 2015-12-09 16:48:25 UTC Comment hidden (obsolete)
Comment 13 QA Administrators 2017-01-03 19:43:11 UTC Comment hidden (obsolete)
Comment 14 Yousuf Philips (jay) (retired) 2017-10-22 18:31:33 UTC

*** This bug has been marked as a duplicate of bug 107484 ***