Download it now!
Bug 80816 - FILEOPEN: xlsx file opens OK but graph format is altered
Summary: FILEOPEN: xlsx file opens OK but graph format is altered
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2014-07-02 15:59 UTC by bureautiquelibre
Modified: 2019-09-20 06:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (33.11 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-07-02 15:59 UTC, bureautiquelibre
Details
Excel display of the example document (85.33 KB, application/pdf)
2014-07-11 08:27 UTC, bureautiquelibre
Details
Result after saving in xlsx format and reloading the file in Excel ou LibreOffice (79.94 KB, application/pdf)
2014-07-11 08:48 UTC, bureautiquelibre
Details
Original file opened in 4.2.5.2 (51.58 KB, application/pdf)
2014-07-11 09:23 UTC, ign_christian
Details
Original file opened in 4.3.0.2 (43.06 KB, application/pdf)
2014-07-11 09:25 UTC, ign_christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bureautiquelibre 2014-07-02 15:59:05 UTC
Created attachment 102146 [details]
Example file

See attached document.

The document opens OK, everything displays fine.

Save as xlsx, close the file and reopen in LibreOffice.
Cells format is lost, figures are still there but cell format is not good.

Also, figures shown in graph show decimals and format is altered.

Same result when opening in Office form cells format + graphs appear empty.


Seems to be directly related to xlsx export: no issues at all when saving as .ods


Best Regards,
Eric Ficheux
Comment 1 ign_christian 2014-07-11 05:40:17 UTC
Hi Eric, could you attach sreenshot what it's look like within Excel? 

I saw different result in 4.3.0.2 and 4.2.5.2 (better) while opening your file.
Comment 2 ign_christian 2014-07-11 05:56:21 UTC
Looks like issues with format number in chart's axis & label
Comment 3 bureautiquelibre 2014-07-11 08:27:13 UTC
Created attachment 102601 [details]
Excel display of the example document
Comment 4 bureautiquelibre 2014-07-11 08:48:02 UTC
Hi Christian,

4.2.5.2 opens the file OK indeed (great job from the LibreOffice community BTW, compatibility has really improved a lot in the last versions)!
Didn't test yet in 4.3.0.2: we're qualifying 4.2.5.2 before upgrading our users.

I added the requested file in PDF format so you can see how the original document appears in Excel (as you'll see, it looks the same as in LibreOffice 4.2.5.2)

I also added the rendering I get after saving in xlsx format from LibreOffice and reloading it in Calc ou Excel.

Note that the rendering is consistent between Calc (4.2.5.2) and Excel 2010 in both cases, so I just uploaded one file for both.

Best Regards,
Eric Ficheux
Comment 5 bureautiquelibre 2014-07-11 08:48:54 UTC
Created attachment 102604 [details]
Result after saving in xlsx format and reloading the file in Excel ou LibreOffice
Comment 6 ign_christian 2014-07-11 09:23:04 UTC
Created attachment 102606 [details]
Original file opened in 4.2.5.2
Comment 7 ign_christian 2014-07-11 09:25:19 UTC
Created attachment 102607 [details]
Original file opened in 4.3.0.2
Comment 8 ign_christian 2014-07-11 09:36:07 UTC
Eric, please see 2 files I just attached. 

4.2.5.2 not opened your original file correctly nor 4.3.0.2. It's different from your original file that was created with Excel 2010 (I saw that in app.xml) :

In 4.2.5.2 differ in:
- Y-axis number format
- all chart label number format

In 4.3.0.2 differ in:
- some chart label number format

*) Indeed we also see another differences, but let we ignore it in this bug report.. :)

I don't know if we can confirm export problem if we see that import problem exist in the file ? Perhaps we better wait for others opinion.

Tested in Ubuntu 12.04 x86
Comment 9 ign_christian 2014-07-11 09:44:56 UTC
Or..may we just reporting the missing chart data label in 2nd chart while exporting and ignore the number format in this bug report ?

I can confirm the missing chart data label in 2nd (bottom) chart after saving & reopening file. Both with 4.2.5.2 and 4.3.0.2
Comment 10 bureautiquelibre 2014-07-11 10:24:06 UTC
You're right: there are 2 bugs in this report.

Let's keep this one open but just for the graph format problem.

I'm changing the summary to reflect the graph format problem only and I'm creating a new bug for the cell formats with a test file without graphs.

Best Regards,
Eric Ficheux
Comment 11 ign_christian 2014-07-11 15:05:27 UTC
Ok setting component Chart, change platform All, set status NEW.
(please be noted, according to my languange setting, my screenshots show "." as thousand separator) 

Export bug maybe similar to Bug 74112. 
I haven't found similar duplicate regarding wrong number format in chart import.
Comment 12 Markus Mohrhard 2015-05-02 19:32:50 UTC
Please retest with master/5.0 and check if that still does not work and add me into CC if that is the case.
Comment 13 QA Administrators 2016-09-20 09:36:53 UTC Comment hidden (obsolete)
Comment 14 Timur 2019-09-17 07:28:49 UTC
After reading this bug, I don't know what it's about. 
"Document not OK" and "graph format altered" and "some number format" are not precise descriptions. 
What I see it that was reported as Filesave but then converted to Fileopen. But for what exactly, not clear. 

Fileopen differences I see in 6.4+:
- Y-axis number format: MSO opens 4000, LO 4.000? I wouldn't count that a bug.
- all chart label number format: I guess this relates to "précision :..." subtitle part of the 1st chart title; looks like direct formatting not recognized by LO; looks like a (minor) bug here.
- some chart label number format: MSO shows 5292,567890 and LO 5293. Also not a bug to me.

Filesave is another bug. If you agree, I'll report separately.
Comment 15 Timur 2019-09-20 06:38:43 UTC
As noted in bug 127589 I opened for newer missing data regression, chart title is bug 78027.
Let's close this one and wait for bug 127589 after which we need to test filesave.
As I wrote, I don't find other 2 number format differences an issue. 
Should someone find something missing, feel free to explain and set back Unconfirmed.