Bug 80997 - FILESAVE: RT Text is missing around textbox because textbox has a wrap property
Summary: FILESAVE: RT Text is missing around textbox because textbox has a wrap property
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:docx
Depends on: 103987
Blocks: DOCX-Textbox DOCX-Anchor-and-Text-Wrap
  Show dependency treegraph
 
Reported: 2014-07-07 09:31 UTC by Rohit Deshmukh
Modified: 2020-01-26 14:26 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Original file (49.00 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-07-07 09:31 UTC, Rohit Deshmukh
Details
Sample without the custom properties (saved w Word 2013) (39.97 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-01-26 14:26 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rohit Deshmukh 2014-07-07 09:31:36 UTC
Created attachment 102363 [details]
Original file

Steps to reproduce :
1] Open attached DOCX in LibreOffice
2] Perform save_as DOCX
3] Open saved file in MS Office 2010

Current behavior :
Text is getting lost

Expected behavior :
Text should be preserved.
Operating System: All
Version: 4.4.0.0.alpha0+ Master
Comment 1 Jorendc 2014-07-07 19:59:30 UTC
Synerzip -> NEW
Comment 2 QA Administrators 2015-07-18 17:43:56 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-11-06 14:58:14 UTC
MSO says file is damaged after roundtrip. Thus putting severity to major.

Win 8.1 32-bit
MSO 2013
LibO Version: 5.1.0.0.alpha1+
Build ID: db6a928a420868b2a80ba11c8d46151d16c13624-GL
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-05_22:13:24
Locale: fi-FI (fi_FI)
Comment 4 Xisco Faulí 2016-09-14 22:44:25 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-12-08 08:06:01 UTC Comment hidden (obsolete)
Comment 6 Timur 2020-01-24 13:19:50 UTC
attachment 102363 [details] is MSO 2007 DOCX but regardless, same if resaved in MSO.
Comment 3 repro in LO 70+. RT opens in LO, cannot be open in MSO.
I retitle for current issue "MSO says file is damaged after roundtrip".
LO 4.0 doesn't open content. LO 4.3 saved DOCX opens in MSO. Regression from 4.4.
Comment 7 Aron Budea 2020-01-26 00:20:56 UTC
The corruption is reported in bug 103987, thus I am adding that bug as dependency.

For the record I didn't see missing text in Word 2013 when roundtripped the document with the 4.4 build preceding the regression in bug 103987.
Comment 8 Timur 2020-01-26 09:23:01 UTC
OK, I failed to check. Moral is: please always use See Also in a new bug to connect to the original file bug, so that other reported issues are clear.
Comment 9 Aron Budea 2020-01-26 14:26:28 UTC
Created attachment 157436 [details]
Sample without the custom properties (saved w Word 2013)

I removed the custom properties in Word 2013, and saved the document that way. I don't know if this fundamentally changes the file, as I mentioned the roundtripped document looked fine in Word even with a 4.4 build, and this one behaves the same. Perhaps it depends on MSO version.

It might be worth repeating the same with previous MSO versions starting from the original file.