Bug Hunting Session
Bug 81219 - START CENTER: thumbnail for files saved in "web layout" shows whole document not just first page
Summary: START CENTER: thumbnail for files saved in "web layout" shows whole document ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0
Keywords:
: 83347 (view as bug list)
Depends on:
Blocks: Start-Center Writer-Web-Layout
  Show dependency treegraph
 
Reported: 2014-07-11 09:47 UTC by Andrej
Modified: 2016-10-17 22:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
web layout -- comparing the -- print layout (118.91 KB, image/jpeg)
2014-07-11 09:47 UTC, Andrej
Details
test file saved in web layout mode (29.01 KB, application/vnd.oasis.opendocument.text)
2014-07-11 10:26 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrej 2014-07-11 09:47:38 UTC
Created attachment 102610 [details]
web layout -- comparing the -- print layout

If a document is saved as view -> "web layout", it looks very ugly on the new LibreOffice page, as shown on the picture in the right bellow. If I save similar document as the "Print layout", the first page is shown nicely as expected. That is not such a problem if the document is short, but it is for long document.

Can you make that also in "web layout" the first page would be shown nicely not so ugly. That new look is very practical, because someone can see from the picture what kind of document is clicking, no need to read the title, so it is faster :) 

Thank you for your time
Comment 1 tommy27 2014-07-11 10:26:44 UTC
Created attachment 102611 [details]
test file saved in web layout mode

tested under WinXP 32bit using LibO 4.2.5.2

I confirm the issue and I attach a test file.

basically it seems that if you save a long document in web layout mode, the start center thumbnail which is generated shows a preview of the document in the same modality not of the first page like when you save it in print mode.

edited summary notes
Comment 2 QA Administrators 2015-07-18 17:44:14 UTC Comment hidden (obsolete)
Comment 3 Andrej 2015-07-18 18:10:11 UTC
I am now using version 
4.4.3 on windows 7  and
4.4.4 on Linux mint

The bug is still present - not resolved.
Comment 4 Yousuf Philips (jay) (retired) 2015-07-21 14:25:27 UTC
*** Bug 83347 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2015-10-21 15:21:51 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f4294091b997d9118617f0bbb82b1cafe3cf993b

tdf#81219: Sanitize the thumbnail of web view.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Jan Holesovsky 2015-10-21 15:23:55 UTC
Fixed in master now.
Comment 7 steve -_- 2015-10-23 13:51:01 UTC
verified.

width differs to the usual DIN A4 writer documents. web layout is more narrow. not sure why. maybe intended?
Comment 8 Yousuf Philips (jay) (retired) 2015-10-23 16:42:05 UTC
Would be good to backport to 5.0 and 4.4 if possible.