Bug 81416 - FILESAVE - writing to external storage corrupts ODF file
Summary: FILESAVE - writing to external storage corrupts ODF file
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: highest blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2014-07-16 08:06 UTC by Alex Thurgood
Modified: 2014-12-08 14:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2014-07-16 08:06:39 UTC
I can only reproduce this on OSX and LO 4.2.5.2

1) Open a simple ODT file (text only, no images or other objects, just a page footer with inserted page number field) from an external FAT USB connected drive.
2) Make some changes to the file.
3) Save As...with a new file name to the external storage.
4) Make some more changes
5) Attempt to save changes, random failure to save, provoking error message about IO.
6) Close file, ignore message to resave file.
7) Attempt to re-open file in LO - fails to open, General IO error message.


File is corrupt, it can neither be opened in any version of LO, nor inspected by zip/unzip. 

Attempting to copy file via Finder from external storage to Desktop provokes an error (-36) that the file is incomplete.
Comment 1 Alex Thurgood 2014-07-16 08:10:11 UTC
This is a regression over 4.1.6.2. So far, I did not see the problem on 4.2.3.3 either.

The file is currently a privileged attorney work product, so it won't be posted here.
Comment 2 Alex Thurgood 2014-07-16 08:12:19 UTC
Note that the problem never occurs when the file is read/written to internal hard disk storage.
Comment 3 Emir Sarı (away) 2014-07-27 21:05:29 UTC
This sounds horrible.
Comment 4 Alex Thurgood 2014-07-30 13:01:13 UTC
(In reply to comment #3)
> This sounds horrible.

Yes, it is so bad, I have gone back to 4.1.6, where this doesn't happen.

Alex
Comment 5 tommy27 2014-11-18 20:56:59 UTC
@Alex Thurgood
are you still reproducing this bug with LibO 4.2.7.2 or 4.3.4.1?
Comment 6 Robinson Tryon (qubit) 2014-12-08 14:11:43 UTC
(In reply to Alex Thurgood from comment #1)
> This is a regression over 4.1.6.2. So far, I did not see the problem on
> 4.2.3.3 either.

Can you reproduce this on a different machine and/or different USB drive? It would be helpful to eliminate hardware problems.

> 1) Open a simple ODT file (text only, no images or other objects, just a
> page footer with inserted page number field) 
> ...
> The file is currently a privileged attorney work product, so it won't be
> posted here.

If the test case is a 'simple ODT file', can you reproduce the behavior by creating a new (non-privileged) file?
Comment 7 Alex Thurgood 2014-12-08 14:39:18 UTC
wfm in LO 4341, closing as resolved wfm