Bug 81523 - Installation on OS X confusing: downloads missing instructions/complete readme
Summary: Installation on OS X confusing: downloads missing instructions/complete readme
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Mac OS X (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 59669 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-07-19 07:31 UTC by Christopher Chavez
Modified: 2015-11-26 22:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Chavez 2014-07-19 07:31:30 UTC
(Unsure which component this belongs under.)

Bug 81243 (and likely others) are reported by users not familiar with the process (for a lack of a better word) of installing/upgrading LibreOffice on OS X using the .dmg download (dragging binary onto /Applications alias). While the proper instructions (http://www.libreoffice.org/get-help/install-howto/os-x/) are indicated from the download page, they are not included in the download itself. The READMEs directory includes a plain-text file but it does not describe the installation process sufficiently. The only relevant section is System Requirements:

| * MacOSX 10.5 (Leopard) or higher, Intel or PowerPC processor
|
| Please make sure you have enough free memory in the temporary
| directory on your system, and please ensure that read, write
| and run access rights have been granted. Close all other
| programs before starting the installation process.

"Starting the installation process" is probably misleading.
The rest of the instructions in the readme are specific to Linux and should be removed/replaced. The readme should also come with a .txt extension; if it were copied, there is likelihood that it doesn't get opened by TextEdit and is instead mistaken for a shell script.
Comment 1 Alex Thurgood 2014-10-14 12:42:41 UTC
Confirming, but am unsure whether we have a separate file for OSX packaging or whether this can actually be done at present ?
Comment 2 Alex Thurgood 2014-10-14 12:46:17 UTC
I believe that the baseline is wrong in the system requirements too, as OSX 10.5 is no longer officially supported, and 10.6 is the minimum. PPC is no longer officially supported either.
Comment 3 Alex Thurgood 2014-10-14 12:47:35 UTC
@Norbert, what do you think, worth changing ?
Comment 4 Andras Timar 2015-11-26 22:25:48 UTC
*** Bug 59669 has been marked as a duplicate of this bug. ***
Comment 5 Andras Timar 2015-11-26 22:27:00 UTC
commit 8a1679e47e681e01f91091d45889f672e6722eb1
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Tue Oct 14 08:04:10 2014 -0500

    fdo#81523 Bump the requirement for Mac in the Readme to 10.8