Bug 81616 - EDITING: Spell Checker not working in Writer 4.3.0.3 (Win8) - Underlines everything!
Summary: EDITING: Spell Checker not working in Writer 4.3.0.3 (Win8) - Underlines ever...
Status: RESOLVED DUPLICATE of bug 80363
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.3 rc
Hardware: All Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-21 17:49 UTC by James Buton
Modified: 2014-07-23 03:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Buton 2014-07-21 17:49:58 UTC
Problem description: Open up a document in LibreOffice Writer and every word is underlined by the spell checker. It doesn't recognise any words (even legitimately spelt)

Steps to reproduce:
1. .... Open up a current word document (.doc) in LO Writer that has text in it.
2. .... Turn on the Spell Checker (for UK English, but maybe any language)
3. .... See all the words underlined no matter whether they are correctly spelt or not.

Current behavior: All words are underlined with red squiggly lines.

Expected behavior: Only words tat are not on the ignore list and are not correctly spelt should be underlined.

              
Operating System: Windows 8
Version: 4.3.0.3 rc
Comment 1 Yousuf Philips (jay) (retired) 2014-07-21 18:00:22 UTC
Hello James,

Thank you for filing the bug. Please check which spell check dictionaries you have installed by clicking the menu item Format > Character and then on the Font tab, look through the Language drop down menu to see which languages have a check mark next to it.
Comment 2 Urmas 2014-07-21 18:40:45 UTC
Was that a brand new installation or upgrade over the previous version?
What directory had LO been installed into?
Could you temporarily rename your user profile and see whether the issue persists?
Comment 3 manj_k 2014-07-21 18:59:25 UTC
That's a regression in LO 4.3.0.3 rc (works fine in LO 4.3.0.2 rc), see the comments in Bug 80363 - VIEWING EDITING: spellchecker works wrong if there are Cyrillic symbols in the path to Libre folder .

A workaround (for install-paths with Latin characters): 
replace spelllo.dll from LO 4.3.0.3 (RC3) with spelllo.dll from LO 4.3.0.2 (RC2).

( See also: http://ask.libreoffice.org/en/question/37251/why-wont-spell-check-work-on-a-text-doc-in-your-newest-release/?answer=37273#post-id-37273 )

*** This bug has been marked as a duplicate of bug 80363 ***
Comment 4 OfficeUser 2014-07-21 19:52:02 UTC
I just wanted to file a new issue but than found this one.

LO 4.3.0.3 rc should never be  released with this bug. Is there a 4.3.0.4 rc planed?