Bug 81511 - CONFIGURATION: dictionary is missing as all words are suspect when checking
Summary: CONFIGURATION: dictionary is missing as all words are suspect when checking
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
4.3.0.3 rc
Hardware: All Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: BSA target 4.3.1
Keywords:
: 81738 (view as bug list)
Depends on:
Blocks: mab4.3
  Show dependency treegraph
 
Reported: 2014-07-18 20:40 UTC by Chuck Chur
Modified: 2014-07-27 16:12 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chuck Chur 2014-07-18 20:40:41 UTC
Problem description: 

Steps to reproduce:
1. download 4.3.0.3 and install 
2. open spreadsheet 
3. test spelling

Current behavior:all words marked as suspect and needed to be added to dictionary

Expected behavior:

              
Operating System: Windows (other)
Version: 4.3.0.2 rc
Comment 1 Joel Madero 2014-07-23 02:48:21 UTC
Confirmed:
Windows 7
LibreOffice 4.3.0.3 rc, default English language install

Note: Works fine in 4.3.0 beta1

Critical - major feature not working at all
Highest

MAB
Comment 2 manj_k 2014-07-23 03:21:01 UTC
See also:

Bug 80363 - VIEWING EDITING: spellchecker works wrong if there are Cyrillic symbols in the path to Libre folder


and duplicates

Bug 81619 - SPELL: Spelling dictionaries not working

Bug 81616 - EDITING: Spell Checker not working in Writer 4.3.0.3 (Win8) - Underlines everything!
Comment 3 tommy27 2014-07-23 04:23:30 UTC
this looks like a stopper issue.
IMHO we cannot release 4.3.0 with this bug unfixed
Comment 4 V Stuart Foote 2014-07-23 04:27:23 UTC
Wait, this looks to have been caused with http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-3-0&id=012bdc381f1ee36a1ee1157c1821fdeb49066078 just before 4.3.0.3 was buttoned up.

And, looks to have been corrected already with http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-3-0&id=24e9950f68ca57c454dbb35cf8562d82e76a42e7

@László, could you confirm that please.

On Windows 7 sp1, 64-bit, en-US with
Version: 4.3.1.0.0+
Build ID: 0ad283adb51b3a1bb777e6341e61541d4bffaa44
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-07-21_07:26:59

it seems OK without all words highlighted, but no dictionary's to work against with this TB build.

So, with a 4.3.0.4 re-roll, should be good.
Comment 5 tommy27 2014-07-24 01:01:04 UTC
(In reply to comment #4)
> ...
> 
> So, with a 4.3.0.4 re-roll, should be good.

I think an RC4 is needed... are developers aware of this?
Comment 6 Andras Timar 2014-07-24 04:56:32 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > ...
> > 
> > So, with a 4.3.0.4 re-roll, should be good.
> 
> I think an RC4 is needed... are developers aware of this?

Yes, it's fixed now but I don't see the fix on libreoffice-4-3-0 branch, only on libreoffice-4-3. I don't think it's a show stopper, in fact there may be quite a few MABs in a .0 release. Nobody expects a perfect release. It is worth mentioning in the release notes that LibreOffice will not find its spellchecker dictionaries on Windows, and 4.3.1 will have a fix a month later. 

FYI on libreoffice-4-3 branch, it went wrong with 5536b127a105123de6f64dcf8f53dfa277faef3c.
Fixes are: 24e9950f68ca57c454dbb35cf8562d82e76a42e7 and 0ad283adb51b3a1bb777e6341e61541d4bffaa44
Comment 7 tommy27 2014-07-24 05:40:21 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > ...
> Nobody expects a perfect release.

Ok, but the lack of a dictionary is a quite striking flaw that every user will notice as soon as it starts typing... it's a major feature lije Joel pointed out.

> It is worth mentioning in the release notes that LibreOffice will not find
> its spellchecker dictionaries on Windows, and 4.3.1 will have a fix a month
> later. 

unfortunately a lot of people do not read release notes.
prepare to see a lot of complains and critics about this.

I still think that we should post-pone the 4.3.0 release of a few days and integrate that fix of the 4.3.1 inside the 4.3.0

for the reputation of LibO it would be better to wait one week more for 4.3.0 instead of releasing a version that will look so uncomplete and unprofessional.

just my 2 cents. please discuss these with other devs and QA guys.
Comment 8 David Clayton 2014-07-25 07:29:26 UTC
I have to agree with Tommy and suggest that this is a major blocker, normally .1 release will fix trivial issues and improvements to the (new) feature set, whereas a broken spell check (element that was working well before) will affect all users and in my opinion represents a significant application failure. As a fix exists, surely this is worth putting into an RC4 before public release.
Comment 9 tommy27 2014-07-25 07:47:07 UTC
always think about first time users... people who's using LibO for the very first time... the first impact with a non functioning spellchecker which is a basic feature of any word processor could be detrimental for LibO reputation.
Comment 10 manj_k 2014-07-25 13:56:18 UTC
*** Bug 81738 has been marked as a duplicate of this bug. ***
Comment 11 Andras Timar 2014-07-26 16:32:49 UTC
For 4.3.0 see:
https://gerrit.libreoffice.org/10556
https://gerrit.libreoffice.org/10557
ESC decided that there will be RC4 (at least on Windows, which is affected by the bug).
Comment 12 manj_k 2014-07-27 16:12:37 UTC
Verified (on Windows 7 64-bit) with
LibreOffice 4.3.0.4
Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0.