Bug 81619 - SPELL: Spelling dictionaries not working
Summary: SPELL: Spelling dictionaries not working
Status: RESOLVED DUPLICATE of bug 80363
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
4.3.0.3 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-07-21 19:47 UTC by Robert Gonzalez MX
Modified: 2015-12-15 10:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
images of text in different languages (206.08 KB, application/vnd.oasis.opendocument.text)
2014-07-21 20:27 UTC, Robert Gonzalez MX
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Gonzalez MX 2014-07-21 19:47:27 UTC
Problem description: 
When opening a writer document in spanish or english, the whole text is marked as spelling error and if you right click the word it doesn't show spelling alternatives. if you activate the thesaurus with ctrl F7, it doesn't work either. I have opened previous documents and created new ones that in LO 4.3.0.2 worked ok.
I have rewieved the default paragraph style and it has the correct language setting.

Steps to reproduce:
1. create a new document
2. edit the paragraph default style to set the language to english or spanish
2. write some text in english or spanish without error
3. see how Writer marks the words with red as if was wrong.
4. try with the context menu to obtain alternatives and see that there aren't.

Current behavior:
all the words are marked as mispelled

Expected behavior:
It should only mark the wrong words and give alternatives to correct. This feature was working well in 4.3.0.2

              
Operating System: Windows 8
Version: 4.3.0.3 rc
Last worked in: 4.2.5.2 release
Comment 1 Robert Gonzalez MX 2014-07-21 20:27:33 UTC
Created attachment 103222 [details]
images of text in different languages
Comment 2 Robert Gonzalez MX 2014-07-21 20:30:07 UTC
i have attached a file with images of text in english, spanish and french, that demostrates the marking of the text. The original text file has the default paragrph style set to the correct language.
Comment 3 Urmas 2014-07-21 20:42:52 UTC
What folder is LO installed into on your system?
What is your username?
Is that a built-it or 3rd party dictionary?
Comment 4 manj_k 2014-07-21 22:05:57 UTC
@ Robert Gonzalez MX 

Please have a look at Bug 81616 - EDITING: Spell Checker not working in Writer 4.3.0.3 (Win8) - Underlines everything!

Apparently a duplicate of Bug 80363, 
caused by commit https://bugs.freedesktop.org/show_bug.cgi?id=80363#c9 .
Comment 5 Robert Gonzalez MX 2014-07-22 01:22:28 UTC
hello. I installed in a test folder called test43 at root of C:\, the dictionaries are the ones bundled with the instalation, the user profile is in the same folder according to the instructions on the wiki. I have done the same with the previous betas and RC.
Comment 6 manj_k 2014-07-22 06:36:44 UTC

*** This bug has been marked as a duplicate of bug 80363 ***
Comment 7 Robinson Tryon (qubit) 2015-12-15 10:57:50 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]