Bug 81650 - FILEOPEN: LibO exported DOCX crashes on reopen
Summary: FILEOPEN: LibO exported DOCX crashes on reopen
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2014-07-22 20:28 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-22 21:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
linux backtrace (20.71 KB, text/plain)
2014-07-22 20:28 UTC, Yousuf Philips (jay) (retired)
Details
LibO 4.1 saved docx (2.52 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-07-25 03:48 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-07-22 20:28:55 UTC
Created attachment 103301 [details]
linux backtrace

When testing bug 81345, I noticed that exporting attachment 102770 [details] into docx in 4.1.6 and 4.2.5 will not crash on reopening. This doesnt effect 3.6.7m 4.0.6, 4.3.1 or master. Test done on Linux Mint. This is a fileopen issue as opening the 4.2.5 file in LibO 4.3.1 works.
Comment 1 Joel Madero 2014-07-23 01:58:19 UTC
I can open the attachment fine in 4.2.5.2 - again, always nice to have clear and succinct enumerated steps instead of a paragraph.

Steps:
1. Download attachment 102770 [details] using LibreOffice 4.2.5.2 release

Observed: Opens fine.

Ubuntu 14.04 x64
Comment 2 Yousuf Philips (jay) (retired) 2014-07-23 19:19:07 UTC
Steps:

1) Open attachment 103301 [details] in LibO 4.2.5
2) export it as docx
3) reopen the exported docx it

Expected: it not to crash
Comment 3 retired 2014-07-24 00:48:40 UTC
os x 10.9.4 LO4.3RC3

 attachment 102770 [details] from bug description does open fine. I cannot export but save again to docx with different filename.

and again opens fine. cannot reproduce.

Jay, could you try with 4.3RC3? Also, what linux are you using?
Comment 4 Yousuf Philips (jay) (retired) 2014-07-24 02:28:02 UTC
Foss, i already mentioned this bug only effects 4.1 and 4.2, so i'm hoping a fix would atleast get into the 4.2.7 branch. :)
Comment 5 Joel Madero 2014-07-24 02:31:33 UTC
@Jay - 

So attachment 103301 [details] is your gdb log so not sure if that's the attachment you meant to refer to.

I did: (Using LibreOffice 4.2.5.2 on Ubuntu 14.04 x64)

Opened attachment 102770 [details]
Saved as a new docx file
Closed file
Opened new file

No crash but the formatting was all messed up (separate issue which should probably be reported :) )
Comment 6 Yousuf Philips (jay) (retired) 2014-07-25 03:48:13 UTC
Created attachment 103419 [details]
LibO 4.1 saved docx

@Joel: Yes i used the wrong attachment number. :)

I've attached the .docx file that 4.1.6 produces that crashes in 4.2.5. Wanted to attach the 4.2.5 produced docx, but its 4.2mb.
Comment 7 Florian Reisinger 2014-09-04 09:35:46 UTC
Windows SP 1 x64 Version: 4.4.0.0.alpha0+
Build ID: 5ef4bdc7b15686e55fa19f2e98a828763a0cfae6
TinderBox: Win-x86@42, Branch:master, Time: 2014-09-03_10:10:14
No crash
Comment 8 Yousuf Philips (jay) (retired) 2014-09-04 11:11:18 UTC
@Florian: this is a 4.2 bug only, which still crashes 4.2.6 when you open it with attachment 103419 [details].
Comment 9 Maxim Monastirsky 2014-09-04 11:42:39 UTC
No crash for me with attachment 103419 [details] using 4.2.6.3 under Fedora 20.

@Jay: The backtrace from attachment 103301 [details] points to ImplDevFontListData::~ImplDevFontListData which was patched in Bug 78598 towards 4.2.7. Could you try with a 4.2.7 daily?
Comment 10 Florian Reisinger 2014-09-04 14:09:21 UTC
Resolved -> WFM #c9
Comment 11 Yousuf Philips (jay) (retired) 2014-09-04 20:07:16 UTC
Yes it doesnt crash in 4.2.7 daily, but does with 4.2.6.2 (Build ID: 185f2ce4dcc34af9bd97dec29e6d42c39557298f).