Bug Hunting Session
Bug 81849 - LibreOffice is slow with linked or embedded media (sound, video) files on linux
Summary: LibreOffice is slow with linked or embedded media (sound, video) files on linux
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.2.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 94077 98977 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-07-28 19:29 UTC by Richard Riley Gress
Modified: 2016-05-10 16:19 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Example .odp file (337.01 KB, application/vnd.oasis.opendocument.presentation)
2014-07-28 19:30 UTC, Richard Riley Gress
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Riley Gress 2014-07-28 19:29:41 UTC
If I try to Insert > Movie and Sound... any sound file, regardless of file size or format, LibreOffice will hang for 10+ seconds while it embeds the file. Undoing this action takes a long time, too. When playing the presentation, the audio file will play, but it will take 10+ seconds for the slide to appear. The program is overall very slow; selecting a new slide and scrolling up and down also lags enough to almost make the program unusable.

An example file is attached. The audio is of fuzz.
Comment 1 Richard Riley Gress 2014-07-28 19:30:16 UTC
Created attachment 103610 [details]
Example .odp file
Comment 2 Richard Riley Gress 2014-07-28 21:02:19 UTC
Also:

 - Resizing the picture that represents the sound file also causes major lag.
 - Moving it does not.
 - The CPU usage meter does not overreact.
Comment 3 chrisb2244 2014-08-08 00:54:31 UTC
This also effects me - running Ubuntu 14.04, LibreOffice (Impress)
Version: 4.2.4.2
Build ID: 420m0(Build:2)
Comment 4 Joshua O'Leary 2014-09-06 19:39:42 UTC
I can also confirm this. Embedded files also make Impress really slow when viewing the presentation in slideshow mode.
Comment 5 Joshua O'Leary 2014-09-06 19:42:12 UTC
^Ubuntu 14.04.1, Libreoffice 1:4.2.6.3-0ubuntu1
Comment 6 Andrew Pam 2014-09-10 05:29:08 UTC
I have the same problem with LibreOffice 4.2.6 and 4.3.1 on Ubuntu 14.04 x86_64.  This makes Impress unusable.
Comment 7 Richard Riley Gress 2014-09-10 14:57:00 UTC
Affects multiple users.
Comment 8 Pjotr 2014-10-02 21:07:10 UTC
I can confirm that this bug does not occur in 12.02 (Precise) either 32 or 64bit. It is clearly a problem related to 14.04. The same issue happens with Mint 17 Qiana, which is of course largely also Ubuntu 14.04. The issue does not appear in Windows. Tried this both in Vista and 7 with various LO versions like 4.0, 4.1 4.2 and 4.3. Also tested Ubuntu 12.04 with kernel 3.13: Does not show the problem.
btw: It affects me too...:-( Had to revert to 12.04 on my laptop to have my presentation run as it should. I now have set LTS updates to: Never just because of this issue

Cheers,
Peter
Comment 9 ed_hub 2014-10-04 01:47:37 UTC
Same issue here since a long time (one year on Arch Gnome).
I've tried with lot of distro and kernels and even desktop environments...
That i've noted : on distros with relative old pakages (Debian 7, Ubuntu 12.04) or light DE (like openbox), the bug doesn't happen. So, after newb investigation, I think the issue is releationned with the new GStreamer version 1.x, but i'm not very sure.
Comment 10 ign_christian 2014-10-04 02:58:32 UTC
Updating summary since most users using Ubuntu 14.04.

Set back Version to 4.2.4.2 -> reflects the oldest version where bug appears.

About new Gstreamer, perhaps anyone can confirm if it's related?

Anyone with Ubuntu 14.04 can also confirm Bug 84626 ? Duplicate to this bug?

@Björn, sorry to ping you. Hope that you're the right man :) 
Maybe you could have a quick look. This problem seems only affecting Ubuntu 14.04
Comment 11 Richard Riley Gress 2014-11-27 00:41:14 UTC
Affects me in 14.10. 
LO v. 4.3.3.2 430m0(Build:2)
Comment 12 Petr Pisar 2015-01-04 11:21:22 UTC
This is not specific to Ubuntu. I experience it on my Gentoo desktop too (LibreOffice 4.2.8.2, amd64 platform, Java support disabled, gstreamer-1.2.4). There is something wrong with the GUI as it spuriously steals a focus from other X11 windows when it hiccups.
Comment 13 Björn Michaelsen 2015-01-05 11:13:06 UTC
updating summary per comment 12
Comment 14 Pjotr 2015-02-28 16:03:39 UTC
I tried this now with the newest LibreOffice 4.4.1.2 on Mint-Mate Rebecca (17.1) 64bit and I can confirm that the issue starts with adding the necessary GStreamer backend for LibreOffice. Strange enough it does not affect an embedded .OGA (Therora) video but on .OGG (Vorbis) it does... The size of the audio fragment is not the issue. After installing the GStreamer backend for LibreOffice the file concerned opens very slowly, showing no thumbnail-slides in the editor at first and switching from a slide thumbnail that either preceeds or succeeds the one with the audo fragment temporarily freezes the editor eg. the whole program. This happens as well in a completely new document while adding an audio fragment in the first slide I made whether using a 16b PCM .WAV, MP3 or Vorbis file.
It takes Impress 10 seconds every time to start the fragment. I cannot observe uncommon processing time for that too is inaccessibe at the time LO waits to start. 
I hope this might ring a bell to the developers. 
Cheers,
Peter
Comment 15 Eric Hameleers 2015-08-30 18:25:16 UTC
Same here on the Slackware platform,
My LibreOffice 4.x packages are compiled against gstreamer-0.x and show no lag when adding media files to an Impress presentation.
My LibreOffice 5.x packages are compiled against gstreamer-1.x and these show a 10 second lag when selecting a media file to be embedded into an Impress file, and later on when starting the actual presentation, another several seconds of lag before the presentation is shown full-screen.
This only happens when a media file is added. In "normal" Impress files, no lag anywhere.

Eric Hameleers
Comment 16 Ronny Standtke 2015-11-05 16:36:57 UTC
I can confirm the issue on Debian 8 with a backported LibreOffice 5.0.2.2. Deinstalling the package libreoffice-avmedia-backend-gstreamer and installing the package libreoffice-avmedia-backend-vlc fixes the speed issue but then importing or playing sound files in LibreOffice unfortunately just fails.
Comment 17 Pjotr 2015-11-07 21:55:48 UTC
Reading all this: Is this the place to report bugs and if so, is anyone considering to spend time to do some research, preferably with Linux so that it can actually be seen by a developer?

I just tried this again on a fresh installed LibreOffice 5.0.3.2 with the same result. I's a quad-core machine with 8 GB ram and a dedicated video-adaptor.

Same issue still exists...

On running a two-screen set-up, using the second screen as "beamer" I notice that the text in the slide containing the audio file shows up 10 seconds AFTER the audio started playing, which preceded a 10 second pause to play the audio in the first place. In the console view on the laptop screen, the view remained empty, just the background image shows but no text-overlay. It does show, however, on the second screen acting as beamer. 

The bottom line is in this case 2x a 10 second wait for any response. The presentation timer freezes and jumps 20 seconds forward. 

This really starts to be annoying. Developers take action and start researching this please!

Best regards 

Peter
Comment 18 Yan Pas 2016-01-15 20:50:10 UTC
*** Bug 94077 has been marked as a duplicate of this bug. ***
Comment 19 Mikhail Novosyolov 2016-03-30 09:53:52 UTC
*** Bug 98977 has been marked as a duplicate of this bug. ***
Comment 20 Mikhail Novosyolov 2016-03-30 09:56:54 UTC
I confirm the bug ob Ubuntu 16.04 (xubuntu) with LibreOffice 5.1.
OpenOffice does not have this bug.
Comment 21 Mikhail Novosyolov 2016-03-30 10:14:55 UTC
I also tried both OpenJDK 8 and Oracle Java 8, that makes no difference.
Comment 22 GSmith 2016-03-30 10:59:39 UTC
Confirm this bug
LibreOffice 4.4.6.3
ubuntu w/ gnome-shell 3.14.4
Comment 23 Mikhail Novosyolov 2016-03-30 18:12:53 UTC
I installed Libreoffice 5.1 from RPM on the LO website into ROSA Dektop Fresh R7 distribution and there WAS NO such problem. While LO from ROSA's repositories does have this problem.

As far as I know, downloadable RPMs and DEBS are statically compiled and take all necessary libraries with them...
Comment 24 Ronny Standtke 2016-04-20 13:36:18 UTC
I just tested with the backport of v5.1.2 provided for Debian stable (see https://packages.debian.org/source/stable-backports/libreoffice) and could no longer reproduce the issue. So, this issue is fixed for me.
Comment 25 Mikhail Novosyolov 2016-04-20 13:46:35 UTC
I just tried again on Libreoffice 5.1.2.2 from Ubuntu PPA and also could not reproduce the issue.
Comment 26 Mikhail Novosyolov 2016-04-20 13:56:03 UTC
The problem is also solved with the newest LibreOffice in ROSA distribution.
Comment 27 Mikhail Novosyolov 2016-04-20 13:56:37 UTC
I think it can be merked as resolved.
Comment 28 Pjotr 2016-05-10 16:19:10 UTC
I too have now LibreOffice 5.1.2.2 installed on my Linux Mint 17.3 (Rosa) PC and I confirm that the problem is gone completely!!

Whatever/whoever: a BIG thanks for resolving this long standing problem for us.

Cheers!
Pjotr