Download it now!
Bug 81869 - PDF: pdf-export shows template's file name in the title bar and not the file name
Summary: PDF: pdf-export shows template's file name in the title bar and not the file ...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2014-07-29 10:03 UTC by bugquestcontri
Modified: 2017-11-23 13:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing the bug. (3.75 KB, application/unknown)
2014-07-29 10:03 UTC, bugquestcontri
Details
Screenshot showing the bug 2 (3.75 KB, image/png)
2014-07-29 10:12 UTC, bugquestcontri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2014-07-29 10:03:29 UTC
Created attachment 103636 [details]
Screenshot showing the bug.

Problem description: 

Whenever I export a Writer file into pdf and open the pdf-file with Adobe Reader, the file name of my Writer template appears in the title bar of the Adobe Reader and not the file name of the pdf-export file which is by default the same as my odt-file name.

In the odt-file, the file name of the used template is stored in the properties.
(Writer) File > Properties > tab Description > Title field. 

It is just an annoying bug as the template's file name always needs to be removed.

The same is valid for Calc, Impress and Draw. pdf-exports from Base I cannot comment; I don't use it (yet).  

I did not test other pdf-readers

Steps to reproduce:
1. Start a new file in any of above listed application from a template
2. Export to pdf
3. Open the pdf-export with Adobe Reader


Expected behavior:
The title bar of the Adobe Reader should show the file name of the pdf-export 
(= by default the file name of the odt-file) and not the template's file name.

              
Operating System: Windows XP
Version: 4.2.5.2 release
Comment 1 bugquestcontri 2014-07-29 10:12:39 UTC
Created attachment 103638 [details]
Screenshot showing the bug 2
Comment 2 A (Andy) 2014-07-31 19:13:12 UTC
reproducible with LO 4.3.0.4 (Win 8.1)
Comment 3 QA Administrators 2015-09-04 02:49:05 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-11-30 12:52:23 UTC
Repro.

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: a7c3a2a9be83686657c06f37d521f9f6d2004ddd
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2015-11-28_04:39:18
Locale: fi-FI (fi_FI)
Comment 5 Robinson Tryon (qubit) 2015-12-14 06:08:43 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2017-10-30 08:33:34 UTC Comment hidden (obsolete)
Comment 7 Cor Nouws 2017-11-23 13:41:34 UTC
It is by design that the title (meta data) of a document is shown in the tile bar :)
This is not a bug. sorry.
You (and many more) need to adapt work flow :)