Bug Hunting Session
Bug 82060 - FILTER: Problem with sorting
Summary: FILTER: Problem with sorting
Status: RESOLVED DUPLICATE of bug 81696
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-02 20:01 UTC by Henk Lodewijk
Modified: 2014-10-11 10:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henk Lodewijk 2014-08-02 20:01:36 UTC
Problem description: I'm sorting two seperate sheets in a spreadsheet, and 8-9 out of 10 times it crashes. In some occasion the data is partly corrupted after recovery.

Steps to reproduce:
1.Select the area to be sorted.
2. Select Data, Sort, select 2 keys.
3. After OK the sheet crashes and recovers.

Current behavior:
I find it very abnormal that the sheet crashes. The dataset is not very large, no specifics as far as I can see. The sheet has hidden colums though, however, I assume that shouldn't be a problem. The sheet contains conditional formatiing, which is functionally very important. I read another bug report about this issue, so I hope there will be a resolution soon!

Expected behavior:
Succesfull sorting.
              
Operating System: Windows (other)
Version: 4.2.5.2 release
Comment 1 raal 2014-08-04 18:14:16 UTC
Seems to be duplicate of the bug 81696
Please attach your document. I can not reproduce crash when sorting in LO 4.3
Comment 2 Jean-Baptiste Faure 2014-10-11 10:59:51 UTC
Closing as duplicate of bug 81696.

@Henk Lodewijk: please feel free to reopen if you still encounter the same crash with current stable "Fresh" version (currently 4.3.2). In such a case, attach your test document as asked in comment #1.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 81696 ***