Bug 81696 - CRASH while sorting cells with conditional formatting
Summary: CRASH while sorting cells with conditional formatting
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All All
: medium critical
Assignee: Deena Francis (ldcs.co.in)
URL:
Whiteboard: target:4.4.0 target:4.3.2 target:4.2....
Keywords: bibisected, regression
: 82060 82386 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-07-24 02:44 UTC by Alexander Urban
Modified: 2018-07-26 18:56 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Warning: Before sorting by Column A, save AND CLOSE all other open LibreOffice documents! (13.51 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-07-24 02:44 UTC, Alexander Urban
Details
Win debug report (7.53 KB, text/plain)
2014-07-25 12:03 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Urban 2014-07-24 02:44:57 UTC
Created attachment 103371 [details]
Warning: Before sorting by Column A, save AND CLOSE all other open LibreOffice documents!

Since 4.2.5.2 release was installed on my PC by Auto-Update, sorting fails in conditionally formatted columns, resulting in crash to desktop.

I created and attached a small sample document. Just sort it by Column A, ascending.

The biggest problem is that the "auto-saved and restored" document only has some columns sorted, leading to massive, but possibly overlooked, data corruption.
Comment 1 ign_christian 2014-07-24 14:47:20 UTC
Confirm crash with LO 4.2.5.2 - Ubuntu 12.04 x86

Maybe same cause with Bug 81084 and/or Bug 80874 since those bugs had heavy conditional format.
Comment 2 m.a.riosv 2014-07-25 12:03:24 UTC
Created attachment 103443 [details]
Win debug report

Attached win debug with 4.4 Win-x86@39

Reproducible:
Win7x64Ultimate
Version: 4.2.5.2 Build ID: 6ff819b65674ae6c83f3cbab9e4a4c2b292a7a94
Versión: 4.2.6.1 Id. de compilación: 5fdddf655fba363e34f755715238d0943a44857e
Version: 4.3.1.0.0+ Build ID: 0ad283adb51b3a1bb777e6341e61541d4bffaa44
   TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-07-21_07:26:59
Version: 4.4.0.0.alpha0+ Build ID: 9e970303ddcccd9e33641f8f00bbc4c739a58cd7
   TinderBox: Win-x86@39, Branch:master, Time: 2014-07-22_00:31:57

Last working for me:
Version: 4.2.4.2 Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8
Comment 3 raal 2014-07-28 17:36:08 UTC
6d8b2818a069e151a49fdba573f0db45face1651 is the first bad commit
commit 6d8b2818a069e151a49fdba573f0db45face1651
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Tue May 20 09:28:30 2014 +0000

    source-hash-da1425650b0c3e0921d2c9d51d461aca99038650
    
    commit da1425650b0c3e0921d2c9d51d461aca99038650
    Author:     Thomas Arnhold <thomas@arnhold.org>
    AuthorDate: Thu Apr 24 04:18:55 2014 +0200
    Commit:     Thomas Arnhold <thomas@arnhold.org>
    CommitDate: Thu Apr 24 11:58:14 2014 +0200
    
        add missing modelines to idl files
    
        Change-Id: If52651c70ee659c83ef127da4fe5e266cfe7eec2

:100644 100644 4a8d5565ecefcfdd4078edd5700de0efc8132c02 62b086808cceca8afd3b1840ff28b7dcab3cfc8e M	autogen.log
:100644 100644 bd53ed3cc9847c47658266fa59383ff0e60ebe43 2d692f932ea7b5bdddcc39a7685106a170201f94 M	ccache.log
:100644 100644 80d9656c29aca4e90745e26552bda0bbf7f7cabf c7777ae6f94f5f6034bd795f1da86043f00352c4 M	commitmsg
:100644 100644 b465c495534db58c79ef3d68275b63fb7351e6bf 874c9489bd7a796783a09051c1f2bdf41bc1613e M	make.log
:040000 040000 21b874fef5ab6f9a92e4d5db990b06c510018458 d7045a9a32ad3b402f21dfced13cbd12dcd9592d M	opt

 git bisect log
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect good 4850941efe43ae800be5c76e1102ab80ac2c085d
# skip: [a900e72b6357882284c5955bdf939bf14269f5fb] source-hash-dd1050b182260a26a1d0ba6d0ef3a6fecc3f4e07
git bisect skip a900e72b6357882284c5955bdf939bf14269f5fb
# skip: [3dda83fc3a43afc6af7f5c0ffd029e610ec1b9a3] source-hash-c59b3d6c5c8096486730007d9b9b053793b90b1e
git bisect skip 3dda83fc3a43afc6af7f5c0ffd029e610ec1b9a3
# good: [4f705a8cfb1998b09f2062510b207d35a33647d8] source-hash-1eeb20f3958666ec6ba6e0fcf52e92e5eb447a14
git bisect good 4f705a8cfb1998b09f2062510b207d35a33647d8
# good: [465e2be02951f9645beb3024506a5212907caf5f] source-hash-674801eb4af21c9ae83c122499f15fa4f4785b0f
git bisect good 465e2be02951f9645beb3024506a5212907caf5f
# bad: [1de992ed60dad1fd65ff0383a8610b0468d9d772] source-hash-8bf0b9536cb33dfcce8a811b70c2ead285300f3f
git bisect bad 1de992ed60dad1fd65ff0383a8610b0468d9d772
# good: [ce3d21bc00b0756f1e7dbb4974db30e6d51b913b] source-hash-8485a276022e05bd34afb2321e72ecfad4589f7e
git bisect good ce3d21bc00b0756f1e7dbb4974db30e6d51b913b
# bad: [89894d82385af13d5393f07abeb76a2c309b1828] source-hash-062e69f40b749aa8a6058c3e6ca328af86aeb45b
git bisect bad 89894d82385af13d5393f07abeb76a2c309b1828
# bad: [c567bb961271596a852b55742a65e04f0b92ecbb] source-hash-2e41702ed4f224f195d33054e2e714f546b4442c
git bisect bad c567bb961271596a852b55742a65e04f0b92ecbb
# bad: [6d8b2818a069e151a49fdba573f0db45face1651] source-hash-da1425650b0c3e0921d2c9d51d461aca99038650
git bisect bad 6d8b2818a069e151a49fdba573f0db45face1651
# first bad commit: [6d8b2818a069e151a49fdba573f0db45face1651] source-hash-da1425650b0c3e0921d2c9d51d461aca99038650
Comment 4 Deena Francis (ldcs.co.in) 2014-08-24 20:17:25 UTC
I have submitted a patch to gerrit for review that seems to resolve this bug.
https://gerrit.libreoffice.org/#/c/11102/
Comment 5 Eike Rathke 2014-08-27 11:29:41 UTC
For completeness:

Deena Francis committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c25ac84688b596b9990d382d550f0514161b78c2

Resolves fdo#81084 fdo#81696 fdo#80874 fdo#81010 : sort causes crash



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Eike Rathke 2014-08-27 11:48:18 UTC
Deena Francis committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=719dd447ec1ab5ed0085b4f41cfd8e76fa835106&h=libreoffice-4-3

Resolves fdo#81084 fdo#81696 fdo#80874 fdo#81010 : sort causes crash


It will be available in LibreOffice 4.3.2.


It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3a04813fbf9824ae6cf651bab0c3f55cf36ea8fa&h=libreoffice-4-2

Resolves fdo#81084 fdo#81696 fdo#80874 fdo#81010 : sort causes crash


It will be available in LibreOffice 4.2.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Terrence Enger 2014-08-29 20:50:59 UTC
*** Bug 82386 has been marked as a duplicate of this bug. ***
Comment 8 Ken Biondi 2014-09-07 00:15:44 UTC
I verified this fix in the versions below:

Version: 4.4.0.0.alpha0+
Build ID: 040a59e513b6435fb39bfecad9a54b3283216d0e
TinderBox: Win-x86@42, Branch:master, Time: 2014-09-04_23:21:24

Version: 4.2.7.0.0+
Build ID: fef72d750ea29dd3368f2e5f3099bb81e22ab07c
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-09-05_17:30:54

Version: 4.3.2.0.0+
Build ID: 233e6a62d12d2d67089f1934777ac41c9fc88238
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-09-05_11:10:36

I tested using WIN 8 x86_64.
Comment 9 Jean-Baptiste Faure 2014-10-11 10:59:51 UTC
*** Bug 82060 has been marked as a duplicate of this bug. ***
Comment 10 Robinson Tryon (qubit) 2015-12-17 08:27:17 UTC Comment hidden (obsolete)
Comment 11 Commit Notification 2018-07-26 18:56:41 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6b728b6eb89a848a7c7aaadf246311f7fcebed03

uitest for bug tdf#81696

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.