Bug Hunting Session
Bug 82386 - Try to sort on 2 columns. Windows 8.1
Summary: Try to sort on 2 columns. Windows 8.1
Status: RESOLVED DUPLICATE of bug 81696
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All All
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2014-08-09 11:21 UTC by jf
Modified: 2014-08-29 20:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The whole spreadsheet. (72.64 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-08-09 11:21 UTC, jf
Details
gdb on the core file (9.09 KB, text/plain)
2014-08-29 20:52 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jf 2014-08-09 11:21:25 UTC
Created attachment 104339 [details]
The whole spreadsheet.

Here is the spreadsheet.
Try to sort on column B then A.
Columns on the right (mostly empty) should also be sorted.
Comment 1 Julien Nabet 2014-08-09 13:06:35 UTC
On pc Debian x86-64 with 4.2.6 LO Debian package, I don't reproduce this.
Could you give a try to brand new 4.2.6 and tell us if you still reproduce this?
Comment 2 penttila 2014-08-09 16:18:02 UTC
I tried to reproduce this bug although there were no exact steps to execute.

First I selected Column B and than clicked the 'increasing sort' icon. I got a question whether to extend the scope of sorting to A1:D300, which I excepted. I got a sorted A1:D300 table, while columns on the right G1:AJ300 were not touched. I think the values in column D were the ones which seemed to be problematic.

I feel so, that here is the root of the problem. The values in column D are defined as the sum of I:AJ fields of the same line but the lines of the left part of table are moved to another place because of sorting while the originally referred values on the right remained on their original place. This means that now these sums are not calculating the intended values. (It can be interpreted that the columns on the right are not sorted.)

I also tried to verify my theory by the following test. Select the entire table: click first A4 than shift click AJ300. On Data → Sorting dialogue for 'sorting key 1' choose 'column B'. Leave sorting key 2 and 3 empty. Click OK. I expected this will solve the original problem but unfortunately LO crashed (and always crashes)!

 I am not an expert of Calc but may be this helps.

My test system:
Windows XP SP2
LO 4.2.6.2 Build id.: 185f2ce4dcc34af9bd97dec29e6d42c39557298f
Comment 3 jf 2014-08-09 16:24:02 UTC
J'ai installé 4.2.6. mais j'ai le même problème. 

Merci pour la rapidité de votre réponse 

Le 09.08.2014 15:06, bugzilla-daemon@freedesktop.org a écrit : 

> Julien Nabet [1] changed bug 82386 [2] 
> 
> WHAT
> REMOVED
> ADDED
> 
> Status
> UNCONFIRMED
> NEEDINFO
> 
> CC
> 
> serval2412@yahoo.fr
> 
> Ever confirmed
> 
> 1
> 
> COMMENT # 1 [3] ON BUG 82386 [2] FROM JULIEN NABET [1] 
> 
> On pc Debian x86-64 with 4.2.6 LO Debian package, I don't reproduce this.
> Could you give a try to brand new 4.2.6 and tell us if you still reproduce
> this?
> 
> -------------------------
> You are receiving this mail because: 
> 
> * You reported the bug.
Comment 4 Julien Nabet 2014-08-11 06:15:20 UTC
(translation from previous comment: same problem on 4.2.6)
I put it at NEW since confirmed by penttila.
Comment 5 GerardF 2014-08-11 07:40:18 UTC
(In reply to comment #2)

> 
> I also tried to verify my theory by the following test. Select the entire
> table: click first A4 than shift click AJ300. On Data → Sorting dialogue for
> 'sorting key 1' choose 'column B'. Leave sorting key 2 and 3 empty. Click
> OK. I expected this will solve the original problem but unfortunately LO
> crashed (and always crashes)!

May be due to Conditional formatting.
Within same steps and uncheck "Include formats" in sort dialog (2nd tab), data are sorted without crash.
Comment 6 penttila 2014-08-11 09:52:31 UTC
(In reply to comment #4)
> (translation from previous comment: same problem on 4.2.6)
> I put it at NEW since confirmed by penttila.

Sorry, but I have NOT confirmed this bug! I only tried to clerify it as the problem description was not clear. So I change it's status to NEEDINFO as long as we donn't get exact, reproducible problem description what can be confirmed.

It is another thing that I was able to crash LO. If it is reproducable by someone else - I think - we should rise another bug for it. What is your opinion?
Comment 7 Julien Nabet 2014-08-15 12:23:13 UTC
bfoman: would you have some time to give it a try and, if you've got a crash, retrieve a bt?
Comment 8 Terrence Enger 2014-08-29 20:50:59 UTC
I have made a segfault in the attached .ods in master commit f74a633,
fetched 2014-08-23, configured:
    --enable-option-checking=fatal --enable-dbgutil --enable-crashdump
    --without-system-postgresql --without-myspell-dicts
    --with-extra-buildid --without-doxygen
    --with-external-tar=/home/terry/lo_hacking/git/src
    --enable-online-update
built and running of debian-wheezy 64-bit.

STR
---
(1) Open the .ods from the list of recently used files in the Start
    Center.
(2) Click in the intersection of the column headings row and the row
    headings column to select the whole worksheet.
(3) Take menu options Data > "Sort...".
(4) Select Sort Key 1 = "Column B" Ascending, Sort Key 2 = "Column A" Ascending.
(5) Click <OK>.  Program sends the progress bar across the bottom of
    the screen and then segfaults.

The backtrace from the segfault has the same function names in frames
0 through 19 as frames 1 through 20 of the backtrace attached to bug
81696 "CRASH while sorting cells with conditional formatting".  I am
tentatively closing this as a dup of that bug.

@jf:

When you see that a build newer than 2014-08-24 sorts your spreadsheet
without crashing, please set status VERIFIED.  If crash persists,
please set status REOPENED.

*** This bug has been marked as a duplicate of bug 81696 ***
Comment 9 Terrence Enger 2014-08-29 20:52:33 UTC
Created attachment 105443 [details]
gdb on the core file