Download it now!
Bug 82079 - FILEOPEN: RTF - Text in bold which shouldn't be
Summary: FILEOPEN: RTF - Text in bold which shouldn't be
Status: RESOLVED DUPLICATE of bug 82078
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords: bibisected, filter:rtf, regression
Depends on:
Blocks: RTF-Character
  Show dependency treegraph
 
Reported: 2014-08-03 01:30 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-31 05:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Word 2013 VS LibO 4.3.1 (217.69 KB, image/png)
2014-08-03 01:30 UTC, Yousuf Philips (jay) (retired)
Details
sample file (1.43 MB, application/msword)
2014-08-23 14:03 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-08-03 01:30:39 UTC
Created attachment 103890 [details]
Word 2013 VS LibO 4.3.1

Steps:
1) Open attachment 103815 [details] in Word 2013 and convert to RTF, else open < https://drive.google.com/file/d/0B6qJrVIa0SAlbHNZaDRsYlVpQkU/edit?usp=sharing >
2) Scroll down to page 42
3) Notice that 'eo-redundant storage (GRS),' is in bold

Tested in 4.3.1, 4.2.5, 3.3.0.
Comment 1 retired 2014-08-03 11:34:31 UTC
Hi Jay, on which OS are you testing?

While LO 4.3.0.4 manages to do flakey stuff on OS X 10.9.4 opening this example doc, the passage shown in bold in your screenshot does correctly display non-bold here. (it is page 41 here, since something is off here with paragraphs and or pages). But that's another story.

Unconfirmed:osx:4.3.0.4, NEEDINFO and please back to UNCONFIRMED after you add more info. Thanks, jay :)
Comment 2 retired 2014-08-03 11:40:36 UTC
Also works fine in 4.4 nightly from aug 3rd.
Comment 3 Yousuf Philips (jay) (retired) 2014-08-03 14:04:06 UTC
All my tests are on Linux and as you said it didnt happen on Mac, i tested it on Windows with 4.3.1 and it also shows up there.
Comment 4 Owen Genat (retired) 2014-08-23 11:53:05 UTC
(In reply to comment #0)
> 2) Scroll down to page 42

Can I search for "geo-redundant" instead? :-)

> 3) Notice that 'eo-redundant storage (GRS),' is in bold

Confirmed under GNU/Linux using:

- v4.1.6.2 Build ID: 40ff705089295be5be0aae9b15123f687c05b0a
- v4.2.5.2 Build ID: 61cb170a04bb1f12e77c884eab9192be736ec5f5
- v4.4.0.0.alpha0+ Build ID: e379401618268ed7f7f5885a36b90e1f4f6cd4af TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-08-18_05:51:03

File fails to open under v4.3.0.4 (even with a new profile it quits about a 1/4 the way through the loading bar with a General Error). Status set to NEW.
Comment 5 Owen Genat (retired) 2014-08-23 11:56:39 UTC
Also interesting to note that rendering under GNU/Linux using v3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b is the same as that shown in attachment 103890 [details] for Word 2013 i.e., only the trailing comma is set in bold.
Comment 6 Yousuf Philips (jay) (retired) 2014-08-23 14:03:33 UTC
Created attachment 105157 [details]
sample file
Comment 7 Yousuf Philips (jay) (retired) 2014-08-23 14:06:49 UTC
Seems this bug might be linked to bug 82078 as they both are bold-related 3.6.7 regressions that are fine in 3.5.7.
Comment 8 raal 2014-09-05 18:03:48 UTC
d65a58c31c8da044ef66ae4517fa2fe74cec0019 is the first bad commit
commit d65a58c31c8da044ef66ae4517fa2fe74cec0019
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Tue Dec 11 10:20:39 2012 +0000

    source-hash-2e053cf5ea4d93a2e1845e795a9c7fe1e08c84af
    
    commit 2e053cf5ea4d93a2e1845e795a9c7fe1e08c84af
    Author:     Takeshi Abe <tabe@fixedpoint.jp>
    AuthorDate: Wed Dec 5 08:33:07 2012 +0900
    Commit:     Takeshi Abe <tabe@fixedpoint.jp>
    CommitDate: Wed Dec 5 10:42:17 2012 +0900
    
        sal_Bool to bool
    
        Change-Id: Ic1cc3312e61e602c33be7444f8d4bbad9268ae77

:100644 100644 42f18f15fb3370ca3f85d6a637b17ae05b10996f 4e4564a1257d79f9fd86b264270d348bf06d23e3 M	autogen.log
:100644 100644 b4973c1d86cfd5c0d550e84e7e483802d979829e 1224d320eac5e10b39e8481456547368fe09c748 M	ccache.log
:100644 100644 a0e5b02e554537a0bed70a3203ca3995bb6972bd ab62cc407b67c0ca8a1a96f877dc86a92f01e1ef M	commitmsg
:100644 100644 6ba1538977f3fb5b8f0ee54bbd04be28afdd85e3 575f5b911fb36490ff12ae85452ce424b34a3382 M	dev-install.log
:100644 100644 dc4842a6e74513bbe562bb0d78a1ed545ead53e7 3f76084c0057251a1332a9be8b51e31a06e5590e M	make.log
:040000 040000 e70233c1668fc1da017a420ac2ed5ee366e253ad 9457873d1fe1b1108dc20777c8f0180cefe48cdd M	opt

vgit bisect log
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect good 8f4aeaad2f65d656328a451154142bb82efa4327
# bad: [9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02] source-hash-8600bc24bbc9029e92bea6102bff2921bc10b33e
git bisect bad 9995fae0d8a24ce31bcb5e9cd0459b69cfbf7a02
# good: [51b63dca7427db64929ae1885d7cf1cc7eb0ba28] source-hash-806d18ae7b8c241fe90e49d3d370306769c50a10
git bisect good 51b63dca7427db64929ae1885d7cf1cc7eb0ba28
# bad: [d65a58c31c8da044ef66ae4517fa2fe74cec0019] source-hash-2e053cf5ea4d93a2e1845e795a9c7fe1e08c84af
git bisect bad d65a58c31c8da044ef66ae4517fa2fe74cec0019
# good: [79e02001f27d33b3b478324ab6fba5683413b4d9] source-hash-b6c016da23d309b4ac7d154bc33a22397974ed73
git bisect good 79e02001f27d33b3b478324ab6fba5683413b4d9
# good: [1e04c3b7ef40994ada3236fa8f90fbd1cdcea47e] source-hash-11e776023c89b3de690b37ffaed18ec996b9c207
git bisect good 1e04c3b7ef40994ada3236fa8f90fbd1cdcea47e
# good: [c3482ad95176ec6762ef03e95d3287ebd5e84905] source-hash-3d4288c1c0b593421c7f6619c88584bdb7c53337
git bisect good c3482ad95176ec6762ef03e95d3287ebd5e84905
# good: [2e0fa432485d1db6abd355dad8ccb06f0b97e4fb] source-hash-ce90f99a2d66c2b998ad3f9f028e2ea623a757f5
git bisect good 2e0fa432485d1db6abd355dad8ccb06f0b97e4fb
# first bad commit: [d65a58c31c8da044ef66ae4517fa2fe74cec0019] source-hash-2e053cf5ea4d93a2e1845e795a9c7fe1e08c84af
Comment 9 Miklos Vajna 2014-09-11 14:22:01 UTC
(In reply to comment #7)
> Seems this bug might be linked to bug 82078 as they both are bold-related
> 3.6.7 regressions that are fine in 3.5.7.

Indeed, I just bisected that this got fixed with commit 321d7ec2071472b3765a00806715e7ad9f8a306f (fdo#82078 RTF import: fix bold text spilling over to non-bold text, 2014-09-06).

*** This bug has been marked as a duplicate of bug 82078 ***
Comment 10 Robinson Tryon (qubit) 2015-12-17 11:05:03 UTC Comment hidden (obsolete)