Bug 82217 - FILEOPEN: DOCX - Chart missing border
Summary: FILEOPEN: DOCX - Chart missing border
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: All All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: OOXML-Chart OOXML-Transitional-2010vs2013
  Show dependency treegraph
 
Reported: 2014-08-06 00:54 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-03-19 07:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-08-06 00:54:57 UTC
Steps:
1) Open attachment 104062 [details]
2) Notice that there isnt a border around the chart

Tested in 4.4, 4.3.1, and 4.2.6 on Linux.

Word 2010 VS 4.4 - attachment 104114 [details]
Comment 1 Joel Madero 2014-08-06 02:04:48 UTC
Bodhi Linux 2.4 - E17
LibreOffice 4.4 Built August 7, 2014

Confirmed:
New
Normal - while it might seem like "loss of data" really it's just a formatting thing (border) which doesn't per say ruin the document or lose data but instead just prevents a user from creating professional quality presentations (or at least viewing them with LibreOffice).
Medium - default seems fine
Comment 2 Jorendc 2015-05-17 20:13:53 UTC
Still repro Version: 5.0.0.0.alpha1+ (x64)
Build ID: 9d0c51daea67104349cac26de9839afa8baeb099
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-05-15_23:59:35
Locale: nl-BE (nl_BE)
Comment 3 Robinson Tryon (qubit) 2015-12-09 18:44:59 UTC Comment hidden (obsolete)
Comment 4 Telesto 2016-12-03 18:04:23 UTC
Still repro 
Version: 5.4.0.0.alpha0+
Build ID: 33f5bc54aaa7fe7aa9335726e30f9c349155e04d
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-12-01_23:21:05
Locale: nl-NL (nl_NL); Calc: CL
Comment 5 Yousuf Philips (jay) (retired) 2017-10-31 09:27:50 UTC
If <a:ln> isnt defined in <c:spPr> in chart*.xml, then the default behaviour is that the border is on. Also when the 'w' attribute of <a:ln> isnt defined, it defaults to 0.75pt border width. If the border is turned off, the xml looks like so.

<c:spPr>
  <a:ln>
    <a:noFill />
  </a:ln>
</c:spPr>

XML of a set outline color and set border width

<c:spPr>
 <a:ln w="12700">
   <a:solidFill>
     <a:schemeClr val="accent2" />
   </a:solidFill>
 </a:ln>
</c:spPr>

Tested this issue in both Word 2007 and 2010, and it isnt limited to the MSO 2007 dialect.
Comment 6 QA Administrators 2018-11-01 03:52:43 UTC Comment hidden (obsolete)
Comment 7 Adam Kovacs 2019-01-16 14:33:59 UTC
If you make a copy in Excel 2016 from the Excel 2010 file with save as, the result will be same. There will be no changes in chart1.xml file.

If you create a new chart in Excel 2016, this will be the default result in chart1.xml:

</c:chart>
<c:spPr>
<a:solidFill>
<a:schemeClr val="bg1"/>
</a:solidFill>
<a:ln algn="ctr" cmpd="sng" cap="flat" w="9525">
<a:solidFill>
<a:schemeClr val="tx1">
<a:lumMod val="15000"/>
<a:lumOff val="85000"/>
</a:schemeClr>
</a:solidFill>
<a:round/>
</a:ln>
<a:effectLst/>
</c:spPr>

If you remove the outline from the chart (still in Excel 2016), then this will be in chart1.xml:

</c:chart>
<c:spPr>
<a:solidFill>
<a:schemeClr val="bg1"/>
</a:solidFill>
<a:ln algn="ctr" cmpd="sng" cap="flat" w="9525">
<a:noFill/>
<a:round/>
</a:ln>
<a:effectLst/>
</c:spPr>

In the Excel 2010 file, there are no such information after </c:chart> tag, but if I unzip both files and overwrite chart1.xml file in the Excel 2016 file with the Excel 2010 file, it will be still working in Excel, but wont work with Calc (so the result will be same).

If I set a red outline in the Excel 2010 file, this will be the result in chart1.xml:

</c:chart>
<c:spPr>
<a:ln>
<a:solidFill>
<a:srgbClr val="C00000"/>
</a:solidFill>
</a:ln>
</c:spPr>

So maybe Excel is checking the file version, and if it is Excel 2010, and there are no settings for outline, it will automatically show it (even in later versions of Excel).
Comment 8 Balázs Varga 2019-03-18 15:44:13 UTC
This patch probably could help here too.

Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/0dac43445b35da7e554dd4d7574c59611a0d0be1%5E%21

tdf#81437 XLSX import: fix missing chart border

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.