Bug Hunting Session
Bug 82616 - Sidebar: "Position and Size" display 0.0 for negative offsets
Summary: Sidebar: "Position and Size" display 0.0 for negative offsets
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other All
: medium normal
Assignee: Katarina Behrens
URL:
Whiteboard: target:4.5.0
Keywords:
Depends on:
Blocks: Sidebar-Properties
  Show dependency treegraph
 
Reported: 2014-08-14 12:44 UTC by freddi34
Modified: 2018-10-28 05:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description freddi34 2014-08-14 12:44:12 UTC
The right sidebar in Impress has a section "Position and Size". When selecting an image or rectangle and moving it partly out of the bounds of a slide, the "Horizontal" and "Vertical" fields display still 0.0 as position of that object, as if the object's origin would at the upper left corner of the slide.

This is inconsistent, since an object can (not) have different positions with same horizontal/vertical offset.

LibreOffice: Version: 4.3.1.0.0+
Build ID: 764fdb983d2fd0e24f56db987eba307ae5ae6eea
Ubuntu 14.04 AMD64
Comment 1 ign_christian 2014-08-14 15:19:47 UTC
Confirmed with LO 4.3.1.1 and 4.2.6.2 under Ubuntu 12.04 x86

AOO 4.1.0 behaves as expected: shows negative values.
Comment 2 Commit Notification 2014-11-29 08:18:48 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1386c348f81738a9966d1217db89d1f603466317

fdo#82616: set limits on spinboxes according to size of workarea

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Petr Hudeček 2015-03-01 16:04:41 UTC
The "Position and Size" values now indeed show negative horizontal and vertical values when the shape is put out of the page. (Windows 8.1, 4.5.0.0.alpha0+)