Bug 82679 - Add shortcut keys / hotkeys to set zoom level?
Summary: Add shortcut keys / hotkeys to set zoom level?
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 122414 (view as bug list)
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2014-08-15 20:40 UTC by Jeff
Modified: 2019-03-26 23:50 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff 2014-08-15 20:40:23 UTC
I discovered that I can easily zoom in and out of a document by pressing the Ctrl key and rolling my mouse wheel.  However, when using a laptop, I don't always have access to a wheel mouse.  In any case, it'd be nice to have some hot key presets for the most commonly used zoom levels (fit width, fit whole page, "optimal", and actual size/100%).  

I don't believe that MS Word has any such hotkeys either, so there's no precedent there.  However, one other document-related program that many people use and are familiar with is Adobe Reader.  Perhaps you could follow their lead?  They have their zoom keys set up as follows:

  Ctrl+1  Actual Size / 100%
  Ctrl+0  Zoom to Page Level / Entire Page
  Ctrl+2  Fit Width / Page Width
  Ctrl+3  Fit Visible / Optimal View

Thank you for consideration, and thank you to the LibreOffice developers for all your time and efforts.

   --Jeff
Comment 1 Jean-Baptiste Faure 2014-08-18 04:53:25 UTC
You can define these shortkeys yourself as you want: menu Tools > Customize... -> tab Keyboard > Function category View.

NB: ctrl+0, ctrl+1, ..., are already set to assign styles Body text, Title 1, Title 2, etc. But you are free to change them in your own configuration.

Closing as wontfix.
Best regards. JBF
Comment 2 andreas_k 2019-01-23 17:40:54 UTC
I'd like to open the discussion again to find a usefull shortcut for the different Zoom options which are available in the different LibreOffice apps.

Entire Page
Page Width
Optimal View
Object
50
75
100
150
200
Zoom Dialogue

I would suggest a new shortcut not an already use one cause Ctrl + 0, Ctrl + 1, ... is common in Adobe and drawing product, but Inkscape eg. use only 1, 2, ... 

So from my point of view there are two options:

1. Use Ctrl + 1, Ctrl + 2, ... for SD apps (Draw and Impress) only
2. Find another Shortcut combination which isn't used now
Comment 3 Heiko Tietze 2019-01-24 09:39:41 UTC Comment hidden (off-topic)
Comment 4 Heiko Tietze 2019-01-24 09:41:36 UTC
(In reply to andreas_k from comment #2)
> I would suggest a new shortcut not an already use one cause Ctrl + 0...

Ctrl+1..5 is used to set the heading level H1..H5. It's a well known shortcut.
Comment 5 andreas_k 2019-01-24 10:54:09 UTC
In impress and draw there is no shortcut for header 1, 2, ...
Comment 6 Roman Kuznetsov 2019-01-29 08:54:02 UTC
(In reply to andreas_k from comment #5)
> In impress and draw there is no shortcut for header 1, 2, ...

Don't need to change Ctrl+0,1,2,3,4,5 anyway in all modules of LO

I can suggest may be follow:

Z+P - Entire Page
Z+W - Page Width
Z+V - Optimal View
Z+O - Object
Z+5 - 50%
Z+7 - 75%
Z+1 - 100%
Z+2 - 200%
Z+Enter - Zoom Dialog
Comment 7 Roman Kuznetsov 2019-01-29 08:56:31 UTC
(In reply to Roman Kuznetsov from comment #6)
> (In reply to andreas_k from comment #5)
> > In impress and draw there is no shortcut for header 1, 2, ...
> 
> Don't need to change Ctrl+0,1,2,3,4,5 anyway in all modules of LO
> 
> I can suggest may be follow:
> 
> Z+P - Entire Page
> Z+W - Page Width
> Z+V - Optimal View
> Z+O - Object
> Z+5 - 50%
> Z+7 - 75%
> Z+1 - 100%
> Z+2 - 200%
> Z+Enter - Zoom Dialog

Sorry, I mean follow with Shift:

Shift+Z+P - Entire Page
Shift+Z+W - Page Width
Shift+Z+V - Optimal View
Shift+Z+O - Object
Shift+Z+5 - 50%
Shift+Z+7 - 75%
Shift+Z+1 - 100%
Shift+Z+2 - 200%
Shift+Z+Enter - Zoom Dialog
Comment 8 Heiko Tietze 2019-01-29 09:50:23 UTC
Why not Alt+<key>+<key>... How often do you need to change the zoom level to something special (not talking about in/out). I'd use shortcuts very sparingly and would rather let the user customize it.
Comment 9 andreas_k 2019-01-29 10:14:44 UTC
In DRAW zoom level can be very importend that's the reason I also asked for sd specific shortcuts. In general I'm pro app specific shortcuts.
Comment 10 Roman Kuznetsov 2019-01-29 11:11:26 UTC
(In reply to Heiko Tietze from comment #8)
> Why not Alt+<key>+<key>... How often do you need to change the zoom level to
> something special (not talking about in/out). I'd use shortcuts very
> sparingly and would rather let the user customize it.

Because <Shift> near <Z> and will be just simple push both in one time
Comment 11 Heiko Tietze 2019-01-30 13:22:27 UTC
(In reply to Roman Kuznetsov from comment #10)
> Because <Shift> near <Z> and will be just simple push both in one time

Not on all keyboard layouts (see QWERTZ vs QWERTY)
Comment 12 Thomas Lendo 2019-02-05 19:27:13 UTC
I only support the idea of shortcuts for the 4 zoom levels mentioned in the bug opening comment. If they're not short and handy, then they're useless, therefore I'm not a fan of Alt+<key>+<key> or Shift+z+<key>.
Comment 13 Heiko Tietze 2019-02-06 19:22:55 UTC
There seems to be a general agreement on a few shortcuts. I'm totally against ctrl/cmd+1 ..5 as those might now be assigned in Draw but are in Writer. And a shortcut in one module must not have a different function in another. We also cannot use <mod>+<key>+<key>, only what is offered in Customization can be used.
So what remains is ctrl/cmd + +/- (as known from browsers), both are currently used for bring forward/backward (Draw/Impress), calculate/soft hyphen (Writer), and insert/delete cells (Calc). Wouldn't reassign these shortcuts without an easy way to revert (see bug 83467, c7 and c8). The same is true for ctrl/cmd + arrow keys, which are available in Draw but not in Writer (next/prev paragraph). And in case of ctrl/cmd+1..9 we would have to find something for line spacing that currently occupies those in Draw/Impress (havent checked the other modules).

So unless we find a working shortcut I would close this issue as WF. Please reopen in case of a working proposal.
Comment 14 Heiko Tietze 2019-02-10 13:39:07 UTC
*** Bug 122414 has been marked as a duplicate of this bug. ***