Bug 82700 - EDITING: Unable to select part of a hyperlink
Summary: EDITING: Unable to select part of a hyperlink
Status: RESOLVED DUPLICATE of bug 72266
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-16 10:12 UTC by bowlins
Modified: 2015-01-20 10:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example ODT with link illustrating problem with click-n-drag selection. (28.43 KB, application/vnd.oasis.opendocument.text)
2014-08-23 14:41 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bowlins 2014-08-16 10:12:44 UTC
I'm unable to select just a part of a hyperlink. Selecting the text of a hyperlink is incredibly complicated. Why can't LibreOffice consider hyperlinks like text for editing purposes

              
Operating System: Ubuntu
Version: 4.3.0.4 release
Comment 1 Adolfo Jayme 2014-08-16 14:02:57 UTC
I certainly can, by using my keyboard, in the same way as every other text editor: Shift + ← or →; and by dragging my mouse pointer over the part I want to select. Aren’t those methods working for you?
Comment 2 bowlins 2014-08-17 08:57:17 UTC
Thanks for answering to my query. I've tried again and I've discovered what's happening. 

If I cut and paste a link I can certainly select any part of the text. LibreOffice is treating the link as pure text so no differences here. 

However, if I please the return key, it becomes a proper hyperlink. In this case, I can't select part of the link with the mouse. The cursor becomes a special cursor with a small square. This messes up the link because it may move letters to other parts of the link making the  link unusable.
Comment 3 sophie 2014-08-20 12:27:42 UTC
Hi, this is an option you have to set under Tools > Autocorrect options > Options > uncheck Detect URLs. If you want your links to become URLs formatted again, at the end of your work, check the options again and go to Format > Autocorrect > Apply.
If you have further questions, please don't hesitate to ask for help on our users list or the Ask site. Thanks
Closing as worksforme - Sophie
Comment 4 bowlins 2014-08-20 16:18:42 UTC
This sounds like a painful workaround. I'm migrating from Microsoft Office and this is the sort of thing that puts off new users. 

In Word you don't need to deactivate a function to do a quick selection and then activate again. This sounds like a bug to me. 

Being able to do something simple with 10 clicks doesn't mean it's ok. How could I at least request this as a possible feature to add?
Comment 5 sophie 2014-08-20 16:29:33 UTC
Hi, the feature is here. If you want a shorter way, just uncheck Format > Autcorrect > while typing, it's only two clicks (or none with alt key), or as Adolfo suggested it, the keyboard. What you see an issue for you may be a convenient way for others, so having the choice to activate an option or not give you the liberty to use it or not. Sophie
Comment 6 bowlins 2014-08-20 21:28:08 UTC
I totally get you're saying but I disagree. This is a workaround not a solution. In Word there's no need to deselect autocorrect options to select just part of a hyperlink. This is not about autocorrect options but about LibreOffice treating hyperlinks as a unselectable blocks, whereas Word treats hyperlinks as links AND text. In a text document there's no reason why hyperlinks should be treating as an object instead of editable text
Comment 7 Owen Genat (retired) 2014-08-23 14:41:17 UTC
Created attachment 105162 [details]
Example ODT with link illustrating problem with click-n-drag selection.

(In reply to comment #3)
> Hi, this is an option you have to set under Tools > Autocorrect options >
> Options > uncheck Detect URLs.

I don't think this option affects the ability to select part of a hyperlink using the mouse as indicated:

(In reply to comment #2)
> However, if I please the return key, it becomes a proper hyperlink. In this
> case, I can't select part of the link with the mouse. The cursor becomes a
> special cursor with a small square.

I'm attaching an example document containing a hyperlink. Regardless of whether the indicated option is turned on or off, click-n-drag over part of the hyperlink (e.g., try selecting "username:password@domain:port/") results in one or more characters being dragged to a new location. Basic text selection should never be impaired in this manner.
Comment 8 Owen Genat (retired) 2014-08-23 14:45:10 UTC
I am happy to confirm this report, although it would be good if someone else could double-check my attachment / description. This report is likely an enhancement request as the current behaviour has been this way since at least v3.5.7.2.
Comment 9 Jean-Baptiste Faure 2014-08-24 20:04:01 UTC
(In reply to comment #8)
> I am happy to confirm this report, although it would be good if someone else
> could double-check my attachment / description. This report is likely an
> enhancement request as the current behaviour has been this way since at
> least v3.5.7.2.

I can confirm this behavior with version 4.3.2.0.0+ (Build ID: c8964193051a9ef543a50c7d87c78da99f253fbd) build at home under Ubuntu 14.04 x86-64
I observe it with LibreOffice 4.1.6 (TDF build) too.

Best regards. JBF
Comment 10 Matthew Francis 2015-01-20 10:26:25 UTC

*** This bug has been marked as a duplicate of bug 72266 ***