Download it now!
Bug 82746 - EDITING: In-place editing of input fields - don't work "Backspace"
Summary: EDITING: In-place editing of input fields - don't work "Backspace"
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-18 06:23 UTC by gruzin
Modified: 2016-01-17 21:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gruzin 2014-08-18 06:23:36 UTC
To reproduce:

1. Create any input field.
2. Type any text.
3. Click on the input field.
4. Try to use "backspace" to delete text.

Is's impossible becouse its "read only"?
Comment 1 gruzin 2014-09-17 13:55:45 UTC
Anyone going to fix this bug in version 4.3? Working with this error is very stressful.
Comment 2 tobia 2014-09-23 22:55:13 UTC
I'm also bitten by this bug. Forward delete key works ok, but backspace triggers the dreadful Read Only dialog.
Comment 3 Owen Genat (retired) 2014-10-05 12:13:08 UTC
I cannot reproduce this issue for attachment 107357 [details] from bug 80806 under GNU/Linux using:

v4.1.6.2 Build ID: 40ff705089295be5be0aae9b15123f687c05b0a
v4.2.6.3 Build ID: 3fd416d4c6db7d3204c17ce57a1d70f6e531ee21
v4.3.2.2 Build ID: edfb5295ba211bd31ad47d0bad0118690f76407d

In all cases, backspace works as expected. Can others test the behaviour using this attachment? Thanks. Possibly only affects the Windows build. Version set back 4.3.0.4 (this field indicates the earliest version affected). Importance set to medium. Severity to normal.
Comment 4 tobia 2014-10-06 08:48:01 UTC
I can confirm the bug on Mac OS X 10.9.3, using the linked attachment, but only on 4.3.2:

OK	4.2.4.2 Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8
OK	4.2.6.3 Build ID: 3fd416d4c6db7d3204c17ce57a1d70f6e531ee21
OK	4.3.1.2 Build ID: 3fd416d4c6db7d3204c17ce57a1d70f6e531ee21
FAIL	4.3.2.2 Build ID: edfb5295ba211bd31ad47d0bad0118690f76407d

Set version to 4.3.2.2 and OS to All, because it's not just Windows, even though GNU/Linux is apparently unaffected.
Comment 5 tobia 2014-10-06 09:20:14 UTC
I don't know what's happening, now it fails on 4.3.1.2 too. Maybe I made a mistake the first time, or maybe it's intermittent.

Right now I double checked it and 4.3.1.2 is giving me "Readonly content" for backspace on the unprotected field.
Comment 6 tobia 2014-10-06 10:59:31 UTC
Confirmed broken on OS X with
4.3.0.4 Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0
Comment 7 Josef Motyčka 2014-11-03 13:58:20 UTC
In version 4.3.3.2 Win7_x64, Linux (Ubuntu 14.04/x86) this bug happens only if the section with input fields is protected. BACKSPACE is not working, DELETE is not working. It's quite big problem when editing fields that spans over several lines. Workaround is to select part of the text in field and then write new text over it.
Comment 8 tobia 2014-11-04 08:18:12 UTC
I'm not sure we're talking about the same bug.

The original bug reported the backspace key being blocked inside input fields, in a regular, non-protected section. Delete key works ok. I confirmed this bug on OS X in all 4.3.x versions.
Comment 9 QA Administrators 2016-01-17 20:05:43 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT:

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-01-17
Comment 10 Larsen 2016-01-17 21:27:39 UTC
Works for me
LO 5.0.4, Win 7 SP1