Bug Hunting Session
Bug 82857 - FORMATTING: Formatted text in cell contents not replicated when another cell "targets" those contents
Summary: FORMATTING: Formatted text in cell contents not replicated when another cell ...
Status: CLOSED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 96437 97202 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-20 10:32 UTC by Colin
Modified: 2018-03-29 10:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple spreadsheet where the contents of cells L8,10 & 11 contain individually formatted characters (72.70 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-08-20 10:32 UTC, Colin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Colin 2014-08-20 10:32:25 UTC
Created attachment 104970 [details]
Simple spreadsheet where the contents of cells L8,10 & 11 contain individually formatted characters

If text is entered into a cell and individual characters are formatted on the text line then that formatting is not reproduced if the input text is then reproduced by being targeted from another cell
We are not talking about formatting an entire cell by selecting it and re-formatting
Steps to reproduce:
1. Enter text into a cell, say  A1, and embolden/italicise a few characters of the input text
2. in another cell simply target the original cell with "=A1"
3. ....There is no third step

Current behavior:  Doesn't reproduce text formatting

Expected behavior: Would expect it to reproduce text formatting

As can be seen from the enclosed sample, the contents of Cells L8, 10 & 11 have been subjected to discrete formatting but this has not been reproduced in the referred complements of those cells in the three replicated groups

              
Operating System: Windows 8
Version: 4.2.5.2 release
Comment 1 ign_christian 2014-08-20 13:41:36 UTC
Looks like notabug. It also doesn't work if whole source cell bold/italic. Wondering if any office suite behaves like what is described.

But it's interesting..could be an enhancement request.. :)
Lets wait someone opinion if this could be a valid enhancement.
Comment 2 Colin 2014-08-20 14:01:13 UTC
I agree that a formatted cell does not/should not carry its formatting into another referring cell because cells are their own discrete entities and should carry their own discrete attributes.
Additionally, I would expect a copied cell to carry the attributes with it, but, the content's attributes are just as valid as any cell with a numerical basis and I wouldn't expect to refer to a numeric cell with 12345 in it and get 54321. Would you disagree?
Also, is it significant whether other office suites are also flawed - surely the objective is to build a superior product not just an "also ran". However, I do accept that if the original spec was flawed then this particular facet may well be System Normal.....
Comment 3 raal 2014-09-17 12:02:46 UTC
Hello,
How to proceed when A1 is Bold, B1 is Italic? C1 = A1&B1 -> format  should be bold, italic or bold italic?
In simple case C1 = A1 maybe relevant, but in complex case the results can be weird (intersection or unification)
Comment 4 Colin 2014-09-17 18:36:05 UTC
The original report was concerned with text strings where A1+B1 is a concatenation not a mathematical summation. Therefore, one might imagine that if something bold is concatenated with something italic then you end up with a text string where the first (A1) characters are bold and then the last (B1) characters are italic. Therefore, C1 characters would be copies of the data and their formatting.
Source numerical cells with formatting would have a result cell that would need further formatting/highlighting to reflect its own unique status.
Comment 5 Joel Madero 2014-11-20 05:03:24 UTC
The bar for enhancement requests is quite low - this is a fine suggestion. As to if anyone will ever implement it....we shall see :)

Marking as NEW.
Comment 6 m.a.riosv 2015-12-12 15:21:53 UTC
*** Bug 96437 has been marked as a duplicate of this bug. ***
Comment 7 m.a.riosv 2016-01-17 14:26:14 UTC
*** Bug 97202 has been marked as a duplicate of this bug. ***
Comment 8 Eike Rathke 2018-03-29 10:26:46 UTC
Cell formulas never transport character formatting attributions. Won't implement.