Bug 82907 - Fcitx only over-the-top input with KDE integration
Summary: Fcitx only over-the-top input with KDE integration
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevAdvice
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2014-08-21 12:25 UTC by hans.schmidt.5
Modified: 2018-12-13 11:48 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hans.schmidt.5 2014-08-21 12:25:25 UTC
When using Libreoffice KDE integration on Arch (other distributions have the same problem), Fcitx (an input method for East Asian scripts) only displays over-the-top input. This makes it very hard to write longer sentences because the pre-commit string does not fit into the actual written text. Especially in a word processor this is extremely hard to use.

Here is a OpenSUSE forum entry which describes the problem with screenshots:
http://forums.opensuse.org/showthread.php/485635-fcitx-mozc-and-Libreoffice

A workaround is to use libreoffice-gnome integration, but this does not integrate so well into KDE.

Is there any hope that this will be fixed? From what I understand from the OpenSUSE thread, Libreoffice should use QT_IM_MODULE when using the KDE integration. Or at least GTK_IM_MODULE, even if KDE integration is used. But _not_ XIM. Maybe Libreoffice should even use that without the gnome/kde integration.

I think this problem is also apparant with Ibus, Scim and other frameworks, because the problem does not seem to lie with Fcitx.
Comment 1 Robinson Tryon (qubit) 2015-02-26 22:09:29 UTC
cc'lubos for KDE advice.
Comment 2 Carlos Rodriguez 2015-06-23 18:47:37 UTC
Firstly I'd like to apologize myself because it's my first time working with different input methods :-)

What I guess is what the original poster detected. LibO KDE integration is not fully working with "fcitx" and "mozc" while KDE apps like "kwriter" is working fine.

Steps to reproduce on Debian 8 (jessie):

1.- Install "fcitx-mozc fcitx-ui-classic" and its dependencies.
2.- Create a file named ~/.kde/env/fcitx.sh with this content:

#!/bin/bash
export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS=@im=fcitx

3.- Restart KDE session
4.- You'll see an icon on panel for Input Method selection
5.- Start "kwriter" and press Ctrl+Space and you'll get into MOZC Input Method typing asian characters and representing what the original poster says.
6.- Trying the same on LibO does not work.
7.- As a workaround you can change the ~/.kde/env/fcitx.sh file and replace the lines with:

#!/bin/bash
export GTK_IM_MODULE=xim
export QT_IM_MODULE=xim
export XMODIFIERS=@im=xim

8.- Now you can get the MOZC Input Method but as mention in SuSE (I can't confirm) this is not the best option.
Comment 3 Carlos Rodriguez 2015-06-26 11:20:55 UTC
To the original poster: Can you verify if the Comment #2 is what you get?
Comment 4 Robinson Tryon (qubit) 2015-12-10 10:13:23 UTC Comment hidden (obsolete)
Comment 5 farcus 2016-03-13 04:53:39 UTC
this issue continues to drag on
currently in Libreoffice 5.0.4.2 and fcitx 4.2.9-8.1(with mozc) openSUSE leap 42.1
Not sure if the issue is with libreoffice or KDE
suggestion in comment #2 doesn't seem to work in plasma 5 (or at least I can't work out how to get it to work).
Comment 6 farcus 2016-03-13 05:00:10 UTC
removing libreoffice-kde4 and replacing it with libreoffice-gnome & libreoffice-gtk3 and over the top input becomes available.
Plasma 5 still seems to be using libreoffice-kde4 for KDE integration.
Comment 7 Buovjaga 2016-03-13 16:11:46 UTC
(In reply to farcus from comment #6)
> removing libreoffice-kde4 and replacing it with libreoffice-gnome &
> libreoffice-gtk3 and over the top input becomes available.
> Plasma 5 still seems to be using libreoffice-kde4 for KDE integration.

Yes, there is nothing newer. Hopefully this GSoC task will get done: https://wiki.documentfoundation.org/Development/GSoC/Ideas#KDE5:_port_KDE4_plugin_to_KF5
Comment 8 tommy27 2016-12-11 23:05:21 UTC
is this bug still present with LibO 5.2.3.3

if yes set status to UNCONFIRMED or NEW (if it's an independent confirmation) or RESOLVED WORKSFORME if bug is gone
Comment 9 alicef 2016-12-21 06:44:23 UTC
This problem is still present in app-office/libreoffice-5.2.3.3-r1
Comment 10 alicef 2016-12-21 06:47:39 UTC
USE flag: bluetooth branding cups dbus gtk gtk3 kde Python 3.4

Enviroment:
XMODIFIERS=@im=imsettings
GTK_IM_MODULE=fcitx
QT_IM_MODULE=fcitx
Comment 11 QA Administrators 2017-12-22 03:35:20 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug