Bug 83174 - PDF: CRASH when send email as PDF
Summary: PDF: CRASH when send email as PDF
Status: RESOLVED DUPLICATE of bug 82777
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks: mab4.4
  Show dependency treegraph
 
Reported: 2014-08-28 05:06 UTC by Bugcruncher
Modified: 2014-11-10 22:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (17.74 KB, application/vnd.oasis.opendocument.text)
2014-08-28 05:06 UTC, Bugcruncher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bugcruncher 2014-08-28 05:06:18 UTC
Created attachment 105368 [details]
Sample Document

Problem description: 
Many of my documents crash when I try to send the document as PDF. 
No Crash with PDF export.
Crash vanishes with Rightclick ► Update TOC
Might be related to Bug 82777 - EDITING: CRASH when "select all" on page with picture or object anchored to page 
I did not test other 4.4 versions

Steps to reproduce:
1. Open Sample Document (attachment)
2. Menu {File ► Send ► E+mail as PDF ► only page 1 ► Send}
   » CRASH

              
Operating System: Windows 7
Version: 4.4.0.0.alpha0+ Master
Last worked in: 4.2.6.2 release
Comment 1 Florian Reisinger 2014-09-04 13:09:44 UTC
Tested with Windows 7 x64 with Version: 4.4.0.0.alpha0+ Build ID: 5ef4bdc7b15686e55fa19f2e98a828763a0cfae6 TinderBox: Win-x86@42, Branch:master, Time: 2014-09-03_10:10:14. Could reproduce the bug

If you remove the section it will work
Comment 2 Joel Madero 2014-09-04 13:11:07 UTC
Confirmed regression - marking as
Major - crasher but kind of a corner case (not going to affect the vast majority of users)
Highest - regression + crasher
Comment 3 DavidO 2014-10-11 20:52:24 UTC
I cannot reproduce this failure. Tried on both Linux and Windows, on debug build, on: 9aad656156fbf76288e8a281760e60f1eccc6622 .
Comment 4 Julien Nabet 2014-11-01 23:58:22 UTC
On pc Debian x86-64 with master sources updated yesterday, I don't reproduce the crash but noticed these console logs:
warn:sfx.dialog:4061:1:sfx2/source/dialog/tabdlg.cxx:852: CreateInputItemSet not implemented
warn:sfx.dialog:4061:1:sfx2/source/dialog/tabdlg.cxx:852: CreateInputItemSet not implemented
warn:sfx.dialog:4061:1:sfx2/source/dialog/tabdlg.cxx:852: CreateInputItemSet not implemented
warn:sfx.dialog:4061:1:sfx2/source/dialog/tabdlg.cxx:852: CreateInputItemSet not implemented
warn:sfx.dialog:4061:1:sfx2/source/dialog/tabdlg.cxx:852: CreateInputItemSet not implemented

(process:4136): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Comment 5 Michael Stahl (CIB) 2014-11-10 22:53:07 UTC
crash was fixed by commit 99cd15fa238886d23bdc429dc1133157d799487a

*** This bug has been marked as a duplicate of bug 82777 ***