Bug 83376 - Dictionaries for custom languages are not activated
Summary: Dictionaries for custom languages are not activated
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Eike Rathke
QA Contact:
URL:
Whiteboard: target:5.3.0 target:5.2.2 target:5.1.6
Keywords:
: 100194 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-09-01 22:20 UTC by Urmas
Modified: 2016-08-31 08:36 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example files to reproduce (9.75 KB, application/x-7z-compressed)
2014-09-02 07:03 UTC, Urmas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2014-09-01 22:20:20 UTC
I have two custom dictionaries: one with proper lang code (missing from LO) and the same dictionary using the other language code. Both are installed via extensions.

Spellchecking for the text with the custom language code is not triggered automatically. I need to go to the Options dialog each time to activate it.

The same dictionary with the built-in language is activated immediately.
Comment 1 Urmas 2014-09-02 07:03:21 UTC
Created attachment 105585 [details]
Example files to reproduce
Comment 2 Joel Madero 2014-09-03 07:34:27 UTC
Hey Urmas - 

Can we get links to the extensions? Also is this new to 4.4 (ie. a regression)?
Comment 3 Urmas 2014-09-03 09:55:50 UTC
Everything is in the archive. There was no way to test this feature until version 4.3.
Comment 4 Buovjaga 2014-11-13 12:56:07 UTC
Reproduced. I had to go through options to see any spell checking redness.

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08
Comment 5 Urmas 2015-12-25 15:33:27 UTC Comment hidden (no-value)
Comment 6 Urmas 2016-06-20 13:37:10 UTC
*** Bug 100194 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2016-08-30 18:26:33 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=04311182b6fadcbdeef7aec15c7eea0240ee628c

Resolves: tdf#83376 do not let linguistic tools fall back to known languages

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Eike Rathke 2016-08-30 18:32:18 UTC
Pending review
https://gerrit.libreoffice.org/28504 for 5-2
https://gerrit.libreoffice.org/28505 for 5-1
Comment 9 Commit Notification 2016-08-30 18:47:48 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9a2d6e7e77a660560af9d5b1bbe3a5171176f8d6

Related: tdf#83376 fallback to known in linguistic context is wrong, always.

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-08-31 08:35:03 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f6c109dc0d5ceee29143de038b230732f78e8ee6&h=libreoffice-5-2

Resolves: tdf#83376 do not let linguistic tools fall back to known languages

It will be available in 5.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-08-31 08:36:36 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8eec33146af3bd4ffaf9b3a1fb9d2c72f19b6fb3&h=libreoffice-5-2

Related: tdf#83376 fallback to known in linguistic context is wrong, always.

It will be available in 5.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2016-08-31 08:36:54 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=76538731fb60c8563c5538101bdafe5434b681b8&h=libreoffice-5-1

Resolves: tdf#83376 do not let linguistic tools fall back to known languages

It will be available in 5.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.