Bug Hunting Session
Bug 83417 - FORMULAEDITOR: Formula editor symbols catalog has a lot of important greek letters missing
Summary: FORMULAEDITOR: Formula editor symbols catalog has a lot of important greek le...
Status: RESOLVED DUPLICATE of bug 80650
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: Other Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-02 21:26 UTC by Andy
Modified: 2014-09-03 00:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
A presentation showning formula corruption in three comparative examples on page 1, and comparing the lists of Greek lowercase letters in LO 4.3.2 (wrong) and OO 4.01 (correct) (102.16 KB, application/vnd.oasis.opendocument.presentation)
2014-09-02 21:26 UTC, Andy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy 2014-09-02 21:26:39 UTC
Created attachment 105642 [details]
A presentation showning formula corruption in three comparative examples on page 1, and comparing the lists of Greek lowercase letters in LO 4.3.2  (wrong) and OO 4.01 (correct)

Problem description:
In the formula editor, the "Catalog" allowed you to insert easily any greek letter into your formula, as well as other symbols. In 4.3.1 most lowercase Greek letter are gone, among them some of the most important ones. The lowercase sigma, for example, the symbol universally used for standard deviation, is no more. You can add it manually to the catalog, just as you could do with a dozen other lowercase Greek letters missing. This is no real solution, however; if you insert your newly created symbol, e.g. "sigma", when you reopen the formula "sigma" in the code will be automatically turned into "SIGMA" and in the formula output you will have the capital sigma Greek letter instead of the lowercase.
Non of this happened before, tough I am not able to tell exactly which release was the first to have this problem.
This is a really huge problem: if you write a lot of formulas Libreoffice is basically unusable at present. Moreover, another danger lies in the fact that any old document in which you reopen existing formulas for editing will have them corrupted.

Steps to reproduce:
1. open the attached presentation file. the first formula was written with an old well behaving version, and is correct.
2. the second formula was a copy of the first, which was opened with 4.3.2. As you can see the sigma e rho lowercase symbols were turned into capital letter, fully inappropriate here.
3. open the catalog, choose "edit" button and add two "new symbols named "sigma" and "rho". Then n the third formula, which was a copy of the second one, rewriting manually "sigma" and "rho" in lowercase replacing the capital letter codes gives you the correct symbols in the output. BUT: if you edit the formula again, they will automatically be turned into uppercase again!

Current behavior:
At present it is practically impossible to do any math editing if you make large use of greek letters (i.e. very often)
Expected behavior:
symbols catalog should take 

              
Operating System: Windows 7
Version: 4.3.1.2 release
Comment 1 Andy 2014-09-02 21:33:37 UTC
I raised the priority since:
- any editing of existing formulas in old documents would lead to dataloss, in the sense that the document contents would contain wrong and unwanted formulas.
- it is actually impossible to write formulas now, if you need greek symbols.
I have to start my course in statistics using LO in three weeks now, and I will have to revert to older releases, or it would be impossible.
Comment 2 Andy 2014-09-02 21:42:04 UTC
Some further comparative analysis of LO 4.0.1 and LO 4.3.2 symbols catalogs showed that symbols names for the few remaining lowercase Greek letters in LO 4.3.2 are all those that have a "var" prefix preceding the original name (just six in all actually, I counted them wrong before when I said 8). All the lowercase Greek symbols without "var" have disappeared.
Comment 3 Andy 2014-09-02 22:16:37 UTC
After some further fiddling I can say that the automatic turning of lower case code into uppercase is not so automatic: If a I copy the first formula of the attachment and paste it into another documents file, the lowercase code gets converted into uppercase.
However, further editing to return to lowercase code afterwords will be stabilize the formula.
Comment 4 Jacques Guilleron 2014-09-03 00:35:03 UTC
Hi Andy,

Yes. This is really annoying and was previously reported in 
Bug 80650 - lower case greek alphabet missing in localized Math symbol table.

A workaround exists. Take "smfr.res" in a previous working version at:
"..program\resource\smfr.res"
for me who is french,
and replace it at the same location in the non-working version.
This file is locale dépendent. I find mine in LO 4.2.1.1 and this work.

I set status to Duplicate,

Regards,

Jacques

*** This bug has been marked as a duplicate of bug 80650 ***