Bug 80650 - lower case greek alphabet missing in localized Math symbol table
Summary: lower case greek alphabet missing in localized Math symbol table
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All All
: highest critical
Assignee: David Tardon
URL:
Whiteboard: target:4.4.0 target:4.3.2
Keywords: regression
: 82040 83161 83265 83385 83417 83462 83845 84010 84319 84865 (view as bug list)
Depends on: 67862 64945
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2014-06-28 21:39 UTC by Dominik
Modified: 2014-10-21 19:34 UTC (History)
34 users (show)

See Also:
Crash report or crash signature:


Attachments
broken symbol table (47.04 KB, image/png)
2014-06-28 21:39 UTC, Dominik
Details
missing symbols in chinese UI (65.33 KB, image/png)
2014-06-28 22:08 UTC, Yousuf Philips (jay) (retired)
Details
3.6.7.2 screenshot (works OK) (51.20 KB, image/png)
2014-06-29 07:54 UTC, Kevin Suo
Details
4.2.5.2 screenshot (does not work) (52.60 KB, image/png)
2014-06-29 07:54 UTC, Kevin Suo
Details
4.3.0.1 screeshot (does not work) (45.87 KB, image/png)
2014-06-29 07:56 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dominik 2014-06-28 21:39:19 UTC
Created attachment 101939 [details]
broken symbol table

as summarized, in some localized LO editions some of the symbols are missing (at least de and zh_CN).
it seems to be platform independent as it has been verified on windows 7 / 8 and ubuntu 14.04.

even the examples at the elements dock are lacking of the original greek signs.

maybe a re-occurrence of #37869, but i guess 64945 is the interesting one to look at.
Comment 1 Yousuf Philips (jay) (retired) 2014-06-28 22:07:20 UTC
Confirmed that it shows in 4.1.6 and 4.2.5 with zh_cn but not in arabic UI. Confirmed it doesnt show in 4.3.0 with zh_cn, japanese, arabic, and even KeyID (qtz) UIs.
Comment 2 Yousuf Philips (jay) (retired) 2014-06-28 22:08:38 UTC
Created attachment 101940 [details]
missing symbols in chinese UI
Comment 3 Florian Reisinger 2014-06-29 06:34:51 UTC
Working in DE Version: 4.2.1.1
Build-ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b
Version: 4.3.0.0.beta1 [en of course]
Build-ID: b7cfa1eab1cb1e94f71d6df6612b73f231d0bf92

NOT Working in Version: 4.3.0.1 DE
Build-ID: 67f5430184326974072b65403ef1d9d934fc4481

So a nasty regression between 4.2 and 4.3 affecting all Math users
Adding it to MAB
Comment 4 Kevin Suo 2014-06-29 07:18:22 UTC
Also reproduce with 4.2.5.2, Fedora 20 x86, zh_CN UI. Changing version accordingly.
Switching to en_US UI do not resolve the problem.
Comment 5 Kevin Suo 2014-06-29 07:54:04 UTC
Created attachment 101963 [details]
3.6.7.2 screenshot (works OK)

It works OK in 3.6.7.2 release.
Comment 6 Kevin Suo 2014-06-29 07:54:45 UTC
Created attachment 101964 [details]
4.2.5.2 screenshot (does not work)

It does not work in 4.2.5.2
Comment 7 Kevin Suo 2014-06-29 07:56:41 UTC
Created attachment 101965 [details]
4.3.0.1 screeshot (does not work)

It does not work in 4.3.0.1.

I also tried to remove all the "libobasis4.3-[lang]", but still do not work.
Comment 8 Thomas Bigler 2014-07-31 21:01:49 UTC
Confirmed in  4.3.0.4 (Windows 8.1), german GUI; Workaround

I've found the following workaround quirk:

Replacing the "..program\resource\smde.res" resp. "smfr.res", "smes.res" etc. by
the english version *smen.res* will do the trick: lower case greek symbols à la "%pi" are working again.

Problem: I can live with a partial untranslated GUI, but not with a non functional formula editor. So I can still use all my 15 year old math documents...
Comment 9 Karel Hruska 2014-08-07 11:42:31 UTC
Confirming the bug on x86_64 build of LibreOffice 4.3.0.4 on GNU/Linux, CS locale. 

Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0
Comment 10 Karel Hruska 2014-08-07 12:03:32 UTC
(In reply to comment #8)
> Confirmed in  4.3.0.4 (Windows 8.1), german GUI; Workaround
> 
> I've found the following workaround quirk:
> 
> Replacing the "..program\resource\smde.res" resp. "smfr.res", "smes.res"
> etc. by
> the english version *smen.res* will do the trick: lower case greek symbols à
> la "%pi" are working again.
> 
> Problem: I can live with a partial untranslated GUI, but not with a non
> functional formula editor. So I can still use all my 15 year old math
> documents...

Thank you,
this workaround works also on GNU/Linux. The appropriate file is located in package libobasis<version>-<lang>-math_*. For me the smcs.res from libobasis4.2-cs-math_4.2.5.2-2_amd64.deb works fine.

Btw.: it seems, that the libobasis4.3-en-gb-math_4.3.0.4-4_amd64.deb file also includes broken symbol definition, since it did not help me.

Thaks once again.
Comment 11 Thomas Bigler 2014-08-07 14:24:37 UTC
Still not fixed in 4.3.1.1 (Windows 8.1), german GUI; Workaround

Had to adapt the workaround quirk:
I've found the following workaround quirk:

Replacing the "..program\resource\smde.res" resp. "smfr.res", "smes.res" etc. by
the english version *smen-US.res* (was smen.res in older vesion) will do the trick: lower case greek symbols à la "%pi" are working again.
Comment 12 2014-08-13 19:11:34 UTC
Another workaround:

Replacing the smde.res (or others) by an old version from 4.2 works too, and it has the advantage using the correct spelling (by replacing with the smen_US.res one must then use the english spelling of variables).
Comment 13 sg 2014-08-18 10:05:08 UTC
(In reply to comment #12)

Workaround works for me (Win 8.1). Thanx.

Just to let you know: The bug occurs only when updating. A fresh installation (done on a new tablet pc with no LibreOffice installed) works as expected.
Comment 14 Bernard SIAUD 2014-08-21 06:29:16 UTC
With Mageia 5 ( Build ID: 4.3.1.1-1.mga5 ), I have this problem.
Comment 15 Jean-Baptiste Faure 2014-08-21 07:42:27 UTC
Not reproducible for me under Ubuntu 14.04 x86-64:
- Version: 4.3.2.0.0+ (Build ID: b2d54aa61607e477cb4b81f1a70e555ee3adb0af)
- Version: 4.4.0.0.alpha0+ (Build ID: e6369973702286d92bfc34ab8305d4a9bcf5c27e)
both versions build at home.

Best regards. JBF
Comment 16 Pierre C 2014-08-21 08:44:24 UTC
Same problem with LO 4.3.1.1 french/Win Seven 64
Comment 17 Pierre C 2014-08-24 11:09:59 UTC
Dataloss : with french LO 4.3.1.1
1 - create a doc including a formula with a working version of LO or AOO
2 - in the formula just add %pi, close the formula editor (you can see π)
3 - with LO 4.3.1.1 open the doc (you still can see π), open the formula. you can see %PI has replaced %pi. Close the editor then you will see that Π has replaced π
4 - make any change to the doc, save and close
5 - Open the doc with a working LO or AOO the Π is definitively in the formula
Comment 18 Pierre C 2014-08-24 12:42:24 UTC
As this bug seems to be in 4.2.5.2 shouldn't it be a MAB 4.2, not a MAB 4.3 ?

And, as there is an unusable function and data loss, shouldn't it be a blocker ?
Comment 19 Damiano 2014-08-24 22:13:44 UTC
I have the same problem in LO 4.3.1.1 and 4.3.0.4.
Comment 20 Joel Madero 2014-08-24 22:21:32 UTC
A bibisect would be fantastic here in helping us resolve the problem: https://wiki.documentfoundation.org/QA/HowToBibisect
Comment 21 Laurent BP 2014-08-25 07:25:32 UTC
(In reply to comment #20)
> A bibisect would be fantastic here in helping us resolve the problem:
> https://wiki.documentfoundation.org/QA/HowToBibisect

@Joel: I don't know how we can do a bibisect on this bug: it appears *only* with locales, and intermediate builds are only English US (if I'm not wrong).
Comment 22 Pierre C 2014-08-26 14:25:46 UTC
No problem in 4.2.6.2 french LO/7x64
Comment 23 Thomas Bigler 2014-08-27 05:36:28 UTC
Still broke in version 4.3.1.2 Windows 8, x64, german locale
Comment 24 Jacques Guilleron 2014-08-27 19:51:23 UTC
*** Bug 83161 has been marked as a duplicate of this bug. ***
Comment 25 Jacques Guilleron 2014-08-27 20:05:24 UTC
*** Bug 82040 has been marked as a duplicate of this bug. ***
Comment 26 Fernando 2014-08-29 01:35:48 UTC
All suggestions below don't work with LO for MAC OS X in pt-Br.
Comment 27 Jacques Guilleron 2014-08-30 14:28:56 UTC
*** Bug 83265 has been marked as a duplicate of this bug. ***
Comment 28 Karel Hruska 2014-09-01 05:48:33 UTC
Yes, still buggy, also on Debian GNU/Linux x86_64, version 4.3.1.2...

(In reply to comment #23)
> Still broke in version 4.3.1.2 Windows 8, x64, german locale
Comment 29 Joel Madero 2014-09-02 16:47:39 UTC
*** Bug 83385 has been marked as a duplicate of this bug. ***
Comment 30 Joel Madero 2014-09-02 16:48:51 UTC
Can't be bibisected.
Comment 31 Jacques Guilleron 2014-09-03 00:35:03 UTC
*** Bug 83417 has been marked as a duplicate of this bug. ***
Comment 32 Andy 2014-09-03 10:50:22 UTC
Hi, I tried all workarounds in the Italian locale with no success: any substitution of smit.res with the US version from the same install or the italian version from Openoffice 4.0.1 did not get the symbols back.

I have now painstakingly readded manually all missing Greek letters one by one, I am still not sure this works with already existing formulas since in some experiments when re-editing old formulas lowercase names of symbols added manually when turned into uppercase.
Comment 33 Andy 2014-09-03 11:04:56 UTC
I have experimented a little bit  more and tragically my manual effort to recreate missing symbols in the formula catalog does NOT work 100%:

- when I create a formula I can insert lowercase Greek letters and they appear correctly;

- upon re-editing such formulas, all Greek letters that have an UPPERCASE equivalent (for example sigma and SIGMA) are automatically turned into uppercase, corrupting your formula completely.

You are then forced to reconvert manually to lower case all symbols that are actually so; but this works only until the next editing, when the devilish automatic uppercase conversion will take place again....

Any workaround to this would be greatly welcome.
Comment 34 Andy 2014-09-03 11:25:38 UTC
Further, complicated,  news:
the problem described in the previous comment (unwanted automatic uppercase conversion) seems to appear not always but in only some instances:

- when you edit the formula for the first time after opening the file where it is contained, but not in further editing instances in the same session. If you close the file and reopen it, the first editing will induce it again.

- when you copy and paste the formula between two different document types: for example, if you have a formula in a Writer doc and copy and paste it into a new calc sheet, wrong uppercase conversion will take place; if you instead copy and paste it into another Writer doc, it will not. The same will happen in the opposite direction (from a calc sheet to a writer doc), and also when copying it to an Impress file etc from a different file type.

For anybody needing to create and edit many formula, this a complete nightmare.

Thus, creating manually the lowercase symbols is not a practically useful workaround.

Thanks for your attention
Comment 35 Andy 2014-09-03 12:29:40 UTC
I am sorry, but all efforts to clarify a defined mechanism for the problem is failing. Now I am experiencing unwanted uppercase conversion even in the same document when I copy and paste a second instance of a formula.
What is happening seems to be somehow changing from time to time.
Comment 36 Pierre C 2014-09-03 12:44:16 UTC
As told in comment 18, this bug should be considered as a blocker

Unusable function and data loss 

In one week 6 bugs has been marked as a duplicate of this one, 16 users are following this bug

LO 4.3.2.1 should be for this week, and the bug isn't solved (is anyone working on it ?)

The only workaround is to go back to 4.2.6
Comment 37 Jean-Baptiste Faure 2014-09-03 18:33:23 UTC
Do you have the problem with a fresh installation (uninstall first the current version) and a clean new user profile?

Still no problem for me with LO 4.3.2.0.0+ build at home under Ubuntu 14.04 x86-64 with en-US and FR langpacks.

Best regards. JBF
Comment 38 Andy 2014-09-03 21:05:35 UTC
What do you mean by a "fresh" install? If you simply uninstall the previous version before installing the new one, all your personalized settings will be maintained, and this is probably not what you mean by a "clean new user profile".
However, the problem is that I have literally dozens if not hundreds of personalised settings, and I would have to ponder carefully if this trial is worth wiping them all and restart personalizing the program again from scratch. A hell of a waste of time to be sure.
I could do this experiment on an old PC in my office, maybe tomorrow I'll give it a try.

In any case, to be clear all my posts refer exclusively to LibreOffice Italian localization. I have never tried any other.
Comment 39 Joel Madero 2014-09-03 21:10:55 UTC
No need to delete - just back up the folder and delete the original. Then you can at least see if it's profile related: 

https://wiki.documentfoundation.org/UserProfile
Comment 40 Andy 2014-09-03 22:06:59 UTC
I have now uninstalled 4.3.1 and installed again 4.3.0.4, the missing symbols in the catalog problems - as well as the uppercase unwanted conversion - seems to be there as well.
Comment 41 Andy 2014-09-03 22:23:50 UTC
Downgrading to 4.2.6.3 the uppercase automatic conversion is NOT present.
I had re-aded lowercase Greek letters manually, so I cannot tell if they would automatically be here now - however, the iGreek category that exhibited the same problem is now restored, so probably everything is Ok here with 4.2.6
Comment 42 Jacques Guilleron 2014-09-04 08:59:53 UTC
*** Bug 83462 has been marked as a duplicate of this bug. ***
Comment 43 Jacques Guilleron 2014-09-04 09:35:27 UTC
@Andy Comment 32

You said to have added all missing Greek letters. Did you add also their lowercase names? Else, they will not be recognized in your formulas.

regards,

Jacques
Comment 44 Karel Hruska 2014-09-04 12:33:18 UTC
Actually I don't think there should be any difference between fresh install and update/reinstall, at least on GNU/Linux. Since the bug is caused by broken symbol table for Math (e.g. smcs.res in CS locale), included in package libobasisX.Y-cs-math_X.Y.A.B-C_amd64.deb and installed in /opt/libreoffice4.3/program/resource, which is not a directory changeable by user, the behaviour should be the same in both cases (unless a user-defined symbol table exists in user's profile folder).

Another proof of guilt of this file is its filesize. In version 4.2.5.2, which works good for me, its filesize is 63152 bytes (in package libobasis4.2-cs-math_4.2.5.2-2_amd64.deb). In version 4.3.0.4, which is the first broken, the filesize of smcs.res shrunk to 60716 bytes, and in 4.3.1.2 the filesize is the same.

A funny thing is, that the conversion from lowercase greek letters to uppercase greek letters appears ONLY with broken symbol table. When I use older smcs.res file from LO 4.2.5.2, it does not appear.

My suggestion is simply to compare smXX.res files from older locales of LO and if they are larger than current ones, there is a large probability, that this locale is currently buggy.

Regards,
Karel Hruska

(In reply to comment #37)
> Do you have the problem with a fresh installation (uninstall first the
> current version) and a clean new user profile?
> 
> Still no problem for me with LO 4.3.2.0.0+ build at home under Ubuntu 14.04
> x86-64 with en-US and FR langpacks.
> 
> Best regards. JBF
Comment 45 Andy 2014-09-04 13:03:51 UTC
In response to Jacques comment 43:

You said to have added all missing Greek letters. Did you add also their lowercase names? Else, they will not be recognized in your formulas.

Yes, I have added them in the sense that I:
- clicked the "edit..." button in the Catalog window;
- in the editing window I clicked on the lowercase Greek letter I wanted in the matrix showing all symbols;
- then I modified its name in the first field in the lower half of the window, giving it the name it had in older releases;
- for example, when you choose the lowercase sigma this fields shows "Ux03C3", I replaced this text with "sigma", then clicked on "add" the buttons on the lower right side of the window

The same procedure was repeated manually for all other lowercase Greek letter missing, i.e. all those whose name does not begin with the prefix "var" (these are the only ones left in 4.3.1).
 This would have been annoying but doable if it resolved the issue while waiting for a fix; however the problem is that this manually created symbols caused the "unwanted uppercase conversion" when using the manually created symbols that I described. 
It looks as if there were an auto-check of formula code correctness, and this could not take into account symbols added by the user...
Comment 46 Fernando 2014-09-05 00:57:23 UTC
I have partially solved the problem after I removed the LO user config files, in MAC [~/Library/Application/LibreOffice] after that the lowercase Greek letters works in default user interface. However, if I change the user interface to PT-BR the problem returns.
To me, the Greek letters is more important that the user interface.
Comment 47 Andy 2014-09-05 09:13:03 UTC
Please let me for once add a comment which is "political" rather than "technical": to me, the difficulties caused by bugs such as this are not only due to my own production work with LO. If it were just for this (which is of course important) any workaround, even a difficult to implement one, would do.

The problem is that I am a teacher and use LO in lectures continuously, and do this both because it a free software and to spread its usage and appreciation.

So how can I go in class to teach statistics and tell students that the app is so buggy that you cannot write math formulas anymore, or that you must apply arcane procedures to be able to do that again, or that you must change locale?

So I agree, to ME personally, locale is quite unimportant, but for the context where I use LO with the public, switching locale to a foreign one is simply unthinkable, unless you do not care making LO the object of blatant complaints, people not wanting to use it, etc.

Unfortunately this is at present the case also with another bug, n. 83461, related to a significant bug in the "frequency" function, something that I use everyday in class. If you have a look at it and would like to express interest, it would be nice. 
Thanks for your attention,
Comment 48 Valdas 2014-09-08 10:11:41 UTC
Confirmed in 4.3.1.2, locale LT (Lithuanian), system Kubuntu 14.04 (64b): lower-case "beta" is missing.
Comment 49 Julien Nabet 2014-09-08 19:50:35 UTC
On pc Debian x86-64 with LO Debian package 4.3.0.4, I could reproduce this.
However, I don't reproduce this with master sources updated yesterday.

Could someone give a try to a daily build (master sources)? (see http://dev-builds.libreoffice.org/daily/master/)
Comment 50 Jacques Guilleron 2014-09-08 20:53:02 UTC
Hi Julien,

There's no issue with master. Problems come with locale helppack installation, and errors in "smxx.res". There, uppercase letters wording only is the visible difference.

Jacques
Comment 51 Phitherek_ 2014-09-08 21:12:02 UTC
Another workaround I found with Arch Linux' s Fresh package of 4.3.1.2. If you add the symbols manually in your locale and then change the interface language to English, the lower-to-upper conversion stops somehow and even reverts. Not sure why though.
Comment 52 Phitherek_ 2014-09-08 21:12:27 UTC
Another workaround I found with Arch Linux' s Fresh package of 4.3.1.2. If you add the symbols manually in your locale and then change the interface language to English, the lower-to-upper conversion stops somehow and even reverts. Not sure why though.
Comment 53 Matthew Francis 2014-09-11 06:09:17 UTC
I can reproduce this issue on 4.3.1.2/OSX with the "de" language pack.

However, if I take a fresh build from master and add the contents of the "de" language pack from 4.3.1.2*, it works as expected - e.g. a lower case %sigma is now shown correctly.

Although mixing and matching versions and langpacks is probably not recommended in general, if the problem is in fact already fixed in master this might provide a path for finding where through bisection?


(* Language packs don't seem to be built for the dailies and I'm not sure of the procedure for building them from source)
Comment 54 Pierre C 2014-09-12 16:09:36 UTC
Functionality is still broken in 4.3.2.1 French Seven/x64
Comment 55 F. Toulmay 2014-09-13 13:39:10 UTC
broken symbol table

I confirmed same problem with version 4.3.1.2 French, installed on Windows 7 (built).
Uncontrolled lower to upper case modifications. Tried to uninstall, delete all personal settings  in "Roaming", then re-install same built. No way, still the same mess. Old files created with with version V4.1 and read-only protected (were not modified with v4.3)  are immediately contaminated when opened with v 4.3.1.2.
This is a plain disaster, due to the high number of formulae that need now to be restored.
I will try replace my French locale version by a US one, but hope it will support the French keyboard and already written text with accents and special character set.
I hope someone will be able to fix that bug, otherwise the efforts of all non-English LO communities that need Math will become a bit vain...
   regards,
 FT
Comment 56 David Tardon 2014-09-14 08:34:54 UTC
found the problem
Comment 57 Commit Notification 2014-09-14 11:42:31 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=03626d7940d5e2fc2abf65ef1b49a7a89623f08f

fdo#80650 src transl. merge must be case sensitive



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 58 David Tardon 2014-09-14 14:22:02 UTC
*** Bug 83845 has been marked as a duplicate of this bug. ***
Comment 59 Commit Notification 2014-09-14 20:14:06 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=40716a03b60e4d5014a2ddf194f02a474b122a18&h=libreoffice-4-3

fdo#80650 src transl. merge must be case sensitive


It will be available in LibreOffice 4.3.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 60 Commit Notification 2014-09-15 16:52:38 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-3-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=82b6e98494792f7b38ce19f4b0664648de48a997&h=libreoffice-4-3-2

fdo#80650 src transl. merge must be case sensitive


It will be available already in LibreOffice 4.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 61 Andy 2014-09-16 09:31:41 UTC
This is truly good news.
BUT is there any date for the 4.3.2 release? I checked the official release planning and it seems that 4.3.2 should already be out as an RC, but there is no trace of it on the web site.

This is extremely important to me because I have to install LO in our laboratories at the university for the forthcoming semester, and I have to decide which version to use.
At the moment I could use 4.2.6 to avoid math formula problems, but that release has another relevant problem for us (text objects in Calc graphs disappear after saving and reopening files; this has been solved in 4.3.x).
Comment 62 vulcain 2014-09-16 12:25:59 UTC
Need a backport to LibreOffice 4.2.7, please
https://wiki.documentfoundation.org/ReleasePlan/4.2#4.2.7_release
Comment 63 David Tardon 2014-09-17 16:56:20 UTC
*** Bug 84010 has been marked as a duplicate of this bug. ***
Comment 64 David Tardon 2014-09-18 06:45:34 UTC
(In reply to comment #62)
> Need a backport to LibreOffice 4.2.7, please
> https://wiki.documentfoundation.org/ReleasePlan/4.2#4.2.7_release

I do not see this problem in 4.2.6.3.
Comment 65 Kevin Suo 2014-09-19 06:51:27 UTC
(In reply to comment #61)
> This is truly good news.
> BUT is there any date for the 4.3.2 release? 

4.3.2 RC2 is released today. You can download it via dev-build server:
 http://dev-builds.libreoffice.org/pre-releases/

It shows in the release notes that this bug is fixed in RC2.
 http://dev-builds.libreoffice.org/pre-releases/src/bugs-libreoffice-4-3-2-release-4.3.2.2.log
Comment 66 Karel Hruska 2014-09-19 07:29:01 UTC
I am sorry, but I don't think, that the bug will be fixed at least in Czech localization of LO 4.3.2.2. I have downloaded the Czech translation and the filesize of smcs.res is still 60716 bytes, which is the wrong one (see comment #44). I am afraid, that the bug will be reopened...

If my impressions are wrong, please apologize me...
Karel Hruska

(In reply to comment #65)
> (In reply to comment #61)
> > This is truly good news.
> > BUT is there any date for the 4.3.2 release? 
> 
> 4.3.2 RC2 is released today. You can download it via dev-build server:
>  http://dev-builds.libreoffice.org/pre-releases/
> 
> It shows in the release notes that this bug is fixed in RC2.
>  http://dev-builds.libreoffice.org/pre-releases/src/bugs-libreoffice-4-3-2-
> release-4.3.2.2.log
Comment 67 Laurent BP 2014-09-19 07:57:17 UTC
Bug is fixed for me with fr UI:
- Win 7, LibO 4.3.2.2 (Build ID: edfb5295ba211bd31ad47d0bad0118690f76407d) parallel install with si-gui
- examples in left tab are fine
- old documents containing formula with lower Greek letters are fine
- create a new document with formula with lower Greek letters, save, close LibO; reopened document is fine
Comment 68 Karel Hruska 2014-09-19 10:22:00 UTC
Sorry, I tried LO 4.3.2.2 in Wine and the symbol set is full.

My apologies and thank you for fixing the bug!
Karel Hruska

(In reply to comment #66)
> I am sorry, but I don't think, that the bug will be fixed at least in Czech
> localization of LO 4.3.2.2. I have downloaded the Czech translation and the
> filesize of smcs.res is still 60716 bytes, which is the wrong one (see
> comment #44). I am afraid, that the bug will be reopened...
> 
> If my impressions are wrong, please apologize me...
> Karel Hruska
> 
> (In reply to comment #65)
> > (In reply to comment #61)
> > > This is truly good news.
> > > BUT is there any date for the 4.3.2 release? 
> > 
> > 4.3.2 RC2 is released today. You can download it via dev-build server:
> >  http://dev-builds.libreoffice.org/pre-releases/
> > 
> > It shows in the release notes that this bug is fixed in RC2.
> >  http://dev-builds.libreoffice.org/pre-releases/src/bugs-libreoffice-4-3-2-
> > release-4.3.2.2.log
Comment 69 Kevin Suo 2014-09-26 07:33:55 UTC
*** Bug 84319 has been marked as a duplicate of this bug. ***
Comment 70 Matthew Francis 2014-10-10 10:56:27 UTC
*** Bug 84865 has been marked as a duplicate of this bug. ***
Comment 71 Harry 2014-10-21 15:58:55 UTC
Sorry guys,

on Mac OsX 10.10 with LO 4.3.2.2 and German language pack the bug is NOT fixed.

Perhaps the symptoms have changed slightly. Now small greek letters won't become large ones, but they simply don't exist anymore:

E.g. a %pi in a math formula will be shown as %pi even after closing the formula editor.

As professor in electrical engineering using LO for all lectures this is a severe show stopper.

Please fix this ASAP!!!!!!
Comment 72 tommy27 2014-10-21 16:16:30 UTC
please open a new clean report with the current new status of the bug and put this bug link under See Also
Comment 73 V Stuart Foote 2014-10-21 16:23:50 UTC
(In reply to Harry from comment #71)
> Sorry guys,
> 
> on Mac OsX 10.10 with LO 4.3.2.2 and German language pack the bug is NOT
> fixed.
> 
> Perhaps the symptoms have changed slightly. Now small greek letters won't
> become large ones, but they simply don't exist anymore:
> 
> E.g. a %pi in a math formula will be shown as %pi even after closing the
> formula editor.
> 
> As professor in electrical engineering using LO for all lectures this is a
> severe show stopper.
> 
> Please fix this ASAP!!!!!!
Comment 74 V Stuart Foote 2014-10-21 16:26:45 UTC
@Harry,

Please test a build of 4.4.0 alpha1+ for OSX as well and report result against that on a new bug. http://dev-builds.libreoffice.org/daily/master/MacOSX-10.10@61/

Thanks.
Comment 75 Matthew Francis 2014-10-21 16:27:37 UTC
Please also note: As discussed on bug 84865, it may be necessary to reset your user profile before the fix is effective
Comment 76 Harry 2014-10-21 19:34:22 UTC
OK guys,

removing the profile and reinstalling LO afterwards worked out alright.

Thank you very much for your quick response!

I still having some issues with a varphi now being a phi and the varphi being something really weird but since that has changed a while ago I will check if a correspond has already been reported.