Bug Hunting Session
Bug 84319 - Outline Numbering - Capitalized "A,B,C", "I,II,III", "A,AA,AAA"... are in lower case in non-english UI
Summary: Outline Numbering - Capitalized "A,B,C", "I,II,III", "A,AA,AAA"... are in low...
Status: RESOLVED DUPLICATE of bug 80650
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-09-25 08:55 UTC by Kevin Suo
Modified: 2015-12-15 22:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot showing the problem (107.81 KB, image/png)
2014-09-25 09:02 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-09-25 08:55:26 UTC
Steps to observe the issue:

1. Switch to non-english UI.
2. Tools - Outline Numbering, click the "Numbering" drop down list.

---> "A,B,C", "I,II,III", "A,AA,AAA"... are in lower case. They should be capitalized.

Reproduced at least in Simplified Chinese, Tranditional Chinese and German UI.

Version: 4.3.2.1
Build ID: f9b3ad49d92181b0a1fe7e76f785a2c2cd0847d3

This is a possible regression.
Comment 1 Kevin Suo 2014-09-25 09:02:19 UTC
Created attachment 106843 [details]
screenshot showing the problem
Comment 2 Kevin Suo 2014-09-25 09:04:29 UTC
It works OK in en-US UI.

I confirm that this is not a translation issue. All these strings are properly translated in Pootle, for example:
https://translations.documentfoundation.org/zh_CN/libo_ui/translate/cui/uiconfig/ui.po#unit=40206133
Comment 3 Jacques Guilleron 2014-09-25 14:03:44 UTC
Hi Kevin,

I don't reproduce with 
LO 4.3.2.1 Build ID: f9b3ad49d92181b0a1fe7e76f785a2c2cd0847d3
and Windows 7 Home Premium on French locale.

Jacques
Comment 4 Robinson Tryon (qubit) 2014-09-25 23:04:57 UTC
(In reply to comment #3)
> I don't reproduce with 
> LO 4.3.2.1 Build ID: f9b3ad49d92181b0a1fe7e76f785a2c2cd0847d3
> and Windows 7 Home Premium on French locale.

Kevin:
1) What's the last build that worked (i.e. didn't have lower-case numbering)?
2) Can you reproduce the problem with a Daily build of the Master branch?
http://dev-builds.libreoffice.org/daily/master/
Comment 5 Kevin Suo 2014-09-26 04:18:42 UTC
I do not reproduce in Fedora 20.
I reproduce in WinXP with version 4.3.1.2 also.
May be a windows only (WinXP only?) issue.
Comment 6 Kevin Suo 2014-09-26 04:22:36 UTC
Works OK in
Version 4.2.3.3
Build ID: 6c3586f855673fa6a1576797f575b31ac6fa0ba3

So somewhere between 4.2.3 and 4.3.0
Comment 7 Kevin Suo 2014-09-26 04:27:07 UTC
(In reply to comment #4)
> 2) Can you reproduce the problem with a Daily build of the Master branch?

Daily builds do not have lang packs included, so I can not test this in daily builds. (As I stated, this bug do not reproduce with english UI)
Comment 8 Kevin Suo 2014-09-26 05:27:18 UTC
Works OK in
Version: 4.3.2.2
Build ID: edfb5295ba211bd31ad47d0bad0118690f76407d

Close this as WORKSFORME.
Comment 9 Kevin Suo 2014-09-26 07:33:55 UTC
mjayfrancis told me that this issue may have been collateral from fdo#80650.
I think it really is.
Mark as duplicate of bug 80650.

*** This bug has been marked as a duplicate of bug 80650 ***
Comment 10 Jacques Guilleron 2014-09-26 08:25:36 UTC
That's right. David's commit begin with:

fdo#80650 src transl. merge must be case sensitive
This makes the desired changes in workdir/SrsPartMergeTarget/starmath/source/symbol.src. The only other merged file that is changed is workdir/SrsPartMergeTarget/sw/source/ui/misc/numberingtypelistbox.src, with changes like < "1, 2, 3, ..." ; 4/*SVX_NUM_ARABIC - < "a, b, c, ..." ; 0/*SVX_NUM_CHARS_UPPER_LETTER */; > ; + < "A, B, C, ..." ; 0/*SVX_NUM_CHARS_UPPER_LETTER */; > ; < "a, b, c, ..." ; 1/*SVX_NUM_CHARS_LOWER_LETTER */; > ; This looks okay to me too :-)

Jacques
Comment 11 Robinson Tryon (qubit) 2015-12-15 22:05:13 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]