Bug Hunting Session
Bug 83526 - SIDEBAR: Deck not adjusted for content panel size when switching content panels
Summary: SIDEBAR: Deck not adjusted for content panel size when switching content panels
Status: RESOLVED DUPLICATE of bug 90374
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 104112 (view as bug list)
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2014-09-05 12:31 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-03-02 00:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
how it looks after step 5 (90.32 KB, image/png)
2014-09-05 12:31 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-09-05 12:31:58 UTC
Created attachment 105797 [details]
how it looks after step 5

Steps:
1) Open writer
2) Open sidebar
3) Open styles & formatting
4) Shrink sidebar width
5) Switch to properties
6) icons & controls are cut off
Comment 1 Yousuf Philips (jay) (retired) 2014-09-05 12:35:06 UTC
Tested in 4.2.6, 4.3.2 and master.
Comment 2 retired 2014-09-05 12:44:55 UTC
and confirmed. when then moving the width of the properties it instantaniously switches back to min. width. it should be at min. width right away when switching back to properties from another setting which was set to being below min width of properties.
Comment 3 V Stuart Foote 2014-09-05 14:28:20 UTC
Comment on attachment 105797 [details]
how it looks after step 5

reset mime type
Comment 4 V Stuart Foote 2014-09-05 14:42:23 UTC
@Jay, *,

Works as designed.

The Deck of the docked Sidebar can be dragged down to some minimum width of the active Content panel(s) using the vertical handle, or hidden if handle is clicked, but the width of the Deck remains as set. No change, when a different Tab is selected to change the active Content panel(s) contained in the Deck.

Are you suggesting that the Deck dynamically resize for each active Content Panel set?  IMHO that would be bad UI/UX

If so, setting enhancement.

--ref--
https://wiki.openoffice.org/wiki/File:SidebarNames.png
Comment 5 Yousuf Philips (jay) (retired) 2014-09-05 18:18:02 UTC
@V Stuart Foote,

When a pane (deck + title bar) has a minimum size, like for properties, then the sidebar should be expanded to fit its contents, because if i begin adjusting its size, it will automatically jump to its minimum size. It is pretty much no different then it not allowing me to shrink the pane size less than its minimum size. We should have consistency with its behaviour.
Comment 6 Luke 2015-10-11 20:43:00 UTC
There needs to be either a global minimum width or a per pane minimum width. If we go with the latter, under no circumstances should the user be able get around this minimum. Doing so results in a broken UI. 

The properties pane was designed with a minimum width necessary for it to function. Allowing the user to circumvent this is clearly a bug. 


> Are you suggesting that the Deck dynamically resize for each active Content Panel set?  IMHO that would be bad UI/UX


Of course not. The only time the sidebar will ever be dynamically resized is when the user switches from a panel with a smaller minimum to a larger minimum. Is this ideal? No. But is it better than the alternative of allowing the user to break the UI? Absolutely! 

A global minimum width would mean that the sidebar would never have to be  dynamically resized.  At, the same time, it could result in some sidebars taking up more space than necessary. But this is really a topic for another discussion.
Comment 7 Telesto 2016-11-22 15:45:46 UTC
*** Bug 104112 has been marked as a duplicate of this bug. ***
Comment 8 V Stuart Foote 2018-03-02 00:37:02 UTC

*** This bug has been marked as a duplicate of bug 90374 ***