Download it now!
Bug 92317 - Sidebar size is not constrained by its content
Summary: Sidebar size is not constrained by its content
Status: RESOLVED DUPLICATE of bug 90374
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2015-06-24 18:22 UTC by Heiko Tietze
Modified: 2020-10-01 11:28 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Too small sidebar in Calc (6.97 KB, image/png)
2015-06-24 18:22 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2015-06-24 18:22:06 UTC
Created attachment 116812 [details]
Too small sidebar in Calc

Tested with Version: 5.1.0.0.alpha1+ and 4.4.3.2: Starting with the function list pane I can resize it to a useless minimum. Switching to other panes does not resize then to a proper width.
Comment 1 Laurent Godard 2015-06-25 09:51:50 UTC
if a user resizes the sidebar it is mainly to gain area regarding its document and work

is it something wanted to force him to resize the sidebar every time he switches decks or panels ?
Comment 2 Heiko Tietze 2015-06-25 10:06:21 UTC
The sidebar content must not get cropped on resizing. Therefore it has a minimum width that fit its content. Or at least it should. The prototypical implementation can be found in Writer > Properties (except when a vertical scrollbar is shown). But even there the other panels (Styles & Formatting, Gallery, Navigator) do not work as expected. And controls in the header of the separate navigator sidebar are hidden as well.

Alternative solutions are wrapping controls or to show a chevron like at the toolbar. UX should discuss the pro and cons...
Comment 3 V Stuart Foote 2015-06-26 13:20:15 UTC
(In reply to Heiko Tietze from comment #2)
> The sidebar content must not get cropped on resizing. 

Why? 

>Therefore it has a minimum width that fit its content. Or at least it should...

Not at all, the dialog/pane widget for the Sidebar Deck simply expands open or closed, and widgets for the objects in each Content Panel respond according to their packing. Shrinking hides widgets until reaching a "minimum" width--before the deck collapses--which is the minimum that fully displays a full button object. That "minimum" changes depending on the widgets exposed on each content panel.

> 
> Alternative solutions are wrapping controls or to show a chevron like at the
> toolbar. UX should discuss the pro and cons...

Or, provide a scroll bar for a pane calculated against the full packing of button objects for all Content Panels occupying the full Deck.

Or, provide a scroll bar for each individual Content Panel (but that would add visual clutter)

Or, complete work needed to provide stateful customization of the sidebar--start with reasonable defaults, and then allow user to set their preferred Deck exposure for working in documents with _each_ module.
Comment 4 Heiko Tietze 2015-06-26 20:41:49 UTC
(In reply to V Stuart Foote from comment #3)
> (In reply to Heiko Tietze from comment #2)
> > The sidebar content must not get cropped on resizing. 
> 
> Why? 

Almost all basic ux-principles. If you neither show a control nor indicate that there is more (scrollbar, chevron etc.) it's the worst UI ever. And cropping the sidebar's header and deck content is about hiding controls.

> > Alternative solutions are wrapping controls or to show a chevron like at the
> > toolbar. UX should discuss the pro and cons...
> 
> Or, provide a scroll bar for a pane calculated against the full packing of
> button objects for all Content Panels occupying the full Deck.
> 
> Or, provide a scroll bar for each individual Content Panel (but that would
> add visual clutter)
> 
> Or, complete work needed to provide stateful customization of the
> sidebar--start with reasonable defaults, and then allow user to set their
> preferred Deck exposure for working in documents with _each_ module.

Nice list of options. But consider as well the controls in the header not only deck's content. Would be a weird interface with multiple scrollbars ;-) (not that I haven't seen such a crime).
Comment 5 Yousuf Philips (jay) (retired) 2015-06-29 00:33:27 UTC
(In reply to Laurent Godard from comment #1)
> if a user resizes the sidebar it is mainly to gain area regarding its
> document and work

If a user needs room for their document, then they should use the zoom slider to obtain more space or click on the sidebar tabs to close the sidebar pane, not resize the sidebar so that sidebar content gets cropped. Its not even possible to shrink down the properties tab once its at its minimum size.

> is it something wanted to force him to resize the sidebar every time he
> switches decks or panels ?

If you resize the formula sidebar tab similar to heiko's screenshot and then jump to the properties tab, you'll be able to see two or three buttons from it per row, which means you'll have to resize the tab so you can see all its content, as the tab isnt functional/useful if all its contents arent visible. This is why having a fixed sidebar width that all sidebar tabs can fit comfortably in is what i prefer rather than sidebar tab sizes constantly bouncing around or having their content cropped.
Comment 6 Yousuf Philips (jay) (retired) 2015-06-29 17:00:54 UTC
Seems me and Stuart discussed this similar issue in bug 83526.
Comment 7 Jean-Baptiste Faure 2015-07-01 05:35:09 UTC
(In reply to Heiko Tietze from comment #4)
> (In reply to V Stuart Foote from comment #3)
> > (In reply to Heiko Tietze from comment #2)
> > > The sidebar content must not get cropped on resizing. 
> > 
> > Why? 
> 
> Almost all basic ux-principles.

I disagree, the user should be free to resize the sidebar as he want.

In the case of the Styles & Formatting tab, the style preview may lead to very wide sidebar if some style is defined with a long name and a big font size. Idem in the Properties tab with the style dropdown list.

Currently you can set the Properties tab size to the value you want by changing the Style&Formatting tab size first. So it seems there is several processes trying to set the same size. That should be simplified. 

Best regards. JBF
Comment 8 Heiko Tietze 2015-07-01 06:50:45 UTC
(In reply to Jean-Baptiste Faure from comment #7)
> > Almost all basic ux-principles.
> I disagree, the user should be free to resize the sidebar as he want.

I don't talk about the ability to resize the sidebar (there are other tickets about). But there is absolutely no question that controls must not get hidden on resizing (without any clue that there is more, like chevrons or a scrollbar thumb). You would violate at least these principles:

* Interfaces should provide feedback about their current status. Users should never wonder what state the system is in.

* Users should be able to discover functionality and information by visually exploring the interface, they should not be forced to recall information from memory.
Comment 9 Luke 2015-10-11 03:00:16 UTC
> I disagree, the user should be free to resize the sidebar as he want.

No, the user should be free to reduce the sidebar only to a minimum width defined by the UX designer. If they need more space, they are free to close the sidebar.  Having a sidebar minimized so much it’s not functional, provides absolutely no benefit to the user and looks ugly and unprofessional. The current system is broken. All sidebar panels should have a minimum width.

I'm all for choice, but there is no point in giving the user the freedom to break the UI.
Comment 10 Bastián Díaz 2015-10-11 04:13:31 UTC
(In reply to Luke from comment #9)
> > I disagree, the user should be free to resize the sidebar as he want.
> 
> No, the user should be free to reduce the sidebar only to a minimum width
> defined by the UX designer. If they need more space, they are free to close
> the sidebar.  Having a sidebar minimized so much it’s not functional,
> provides absolutely no benefit to the user and looks ugly and
> unprofessional. The current system is broken. All sidebar panels should have
> a minimum width.
> 
> I'm all for choice, but there is no point in giving the user the freedom to
> break the UI.


I'm user, and I very much agree with this comment.

Currently is a mess width adjustment in the sidebar of the different applications of LibreOffice. Before getting used to, I lost much time adjusting to the correct width for viewing the content offered by the different tabs. Now I turn to use the maximum width which allows the sidebar and hide when necessary, however, is a problem when you need to use tools in the sidebar while viewing comments in Writer (in 4: 3 is more difficult).

For me, the ideal solution is to have a minimum and maximum width for all tabs in the sidebar, in order to ensure see everything offered at a glance. I think the width of the sidebar, should conform to criteria viewing on 16: 9 (maximum width) and 4: 3 screens (minimum width).

Currently the properties tab has the expected behavior, delivers security, and provides a better user experience.


This has been discussed earlier in: Bug 90374 and Bug 91915

Cheers
Comment 11 Robinson Tryon (qubit) 2016-08-25 05:39:32 UTC Comment hidden (obsolete)
Comment 12 V Stuart Foote 2018-03-02 00:36:47 UTC

*** This bug has been marked as a duplicate of bug 90374 ***