Bug 83586 - No suggestion in the spelling contextual menu
Summary: No suggestion in the spelling contextual menu
Status: RESOLVED DUPLICATE of bug 81894
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Context-Menu
  Show dependency treegraph
 
Reported: 2014-09-07 15:16 UTC by JEROME BARBAZA
Modified: 2022-02-10 12:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot of confirmation (83.45 KB, image/png)
2014-09-07 19:23 UTC, penttila
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JEROME BARBAZA 2014-09-07 15:16:57 UTC
Dans libreoffice-classeur, lorsque une faute d'orthographe ne se situe pas sur la première ligne d'une cellule, le menu contextuel n'affiche pas de proposition.

(cas où la cellule possède un retour à la ligne automatique et que le texte est plus long que la largeur de la cellule)
Comment 1 Julien Nabet 2014-09-07 18:06:00 UTC
Quick translation:
In Calc, when a spelling error isn't located in the first line of a cell, the contextual menue doesn't dislay any suggestions.

(in the case when the cell has an automatic newline and the text is longer than the width of the cell)
Comment 2 penttila 2014-09-07 19:23:50 UTC
Created attachment 105866 [details]
screenshot of confirmation

I can confirm this bug with some extension.

When a cell, containing text longer than the width of the cell and automatic newline is on, there is no suggestion for the misspelled words in the second line when right clicking on them. It always occurs.

The same problem appears even in the 'first' line when there is only one line of text but the height of the cell is enough for two lines. In this case the automatic newline is off!

LinuxMint 17 Cinnamon   (Hungarian locales)
LO   4.2.6.3 Build id.: 420m0(Build:3)
Comment 3 QA Administrators 2015-10-14 19:57:00 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2016-11-08 11:16:52 UTC Comment hidden (obsolete)
Comment 5 Totorux 2018-04-18 06:03:47 UTC
Hi

Bug still present en 6.0.2 and 5.2 on Linux, I try on 5.0 on Windows same problem.

The way to skirt the problem is to put the text on the top, else the problem is present if the text is in the middle or the bottom of the cell, or a space is present before the text.

Actualy see on 5.2 in kubuntu 14.04, 6.02 in kubuntu 16.04 and 5.0 on windows 7.
Comment 6 Jean-Michel COSTE 2021-02-07 19:28:13 UTC
Hello,
Bug is still present in 7.1.0.5
Comment 7 fcyrilf 2022-01-12 23:41:02 UTC
Hello,

This very annoying bug is still present in LibreOffice Calc 7.2.2 - 7.2.3 - 7.2.4 and 7.2.5.

Thank you to solve it.
Comment 8 Justin L 2022-02-10 12:23:57 UTC

*** This bug has been marked as a duplicate of bug 81894 ***
Comment 9 Justin L 2022-02-10 12:27:52 UTC
(In reply to penttila from comment #2)
> The same problem appears even in the 'first' line when there is only one
> line of text but the height of the cell is enough for two lines. In this
> case the automatic newline is off!

I could not replicate this. I used attachment 133713 [details] and tested cell A6 which looks to be about two lines high. I made it larger (maybe 4-5 times) and still the spell check suggestions were always provided.