Bug 81894 - No suggestion in the spelling contextual menu for auto-wrapped portion of the text
Summary: No suggestion in the spelling contextual menu for auto-wrapped portion of the...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: BSA target:7.4.0
Keywords: bibisected, bisected, regression
: 82540 83586 118630 (view as bug list)
Depends on:
Blocks: Context-Menu
  Show dependency treegraph
 
Reported: 2014-07-30 04:02 UTC by Dan Loomis
Modified: 2022-02-25 15:50 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test spreadsheet (18.55 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-08-13 03:56 UTC, Dan Loomis
Details
Example of right click context menu on a highlighted word in Calc (14.35 KB, image/png)
2017-05-26 06:20 UTC, Dan Loomis
Details
comment-18---About-LibreOffice.jpg (29.86 KB, image/jpeg)
2017-05-30 01:31 UTC, Francewhoa
Details
Francewhoa---2017-May-29---About-LibreOffice.jpg (29.86 KB, image/jpeg)
2017-05-30 01:34 UTC, Francewhoa
Details
Francewhoa---2017-May-29---cell---without-visible-typo.jpg (87.42 KB, image/jpeg)
2017-05-30 01:35 UTC, Francewhoa
Details
Francewhoa---2017-May-29---cell---without-visible-typo---after-right-click-does-NOT-work.jpg (91.50 KB, image/jpeg)
2017-05-30 01:35 UTC, Francewhoa
Details
Francewhoa---2017-May-29---cell---with-visible-typo---right-click---works.jpg (88.63 KB, image/jpeg)
2017-05-30 01:36 UTC, Francewhoa
Details
Francewhoa---2017-May-29---settings---Character.jpg (36.75 KB, image/jpeg)
2017-05-30 01:36 UTC, Francewhoa
Details
Francewhoa---2017-May-29---settings---Format-Cells.jpg (32.90 KB, image/jpeg)
2017-05-30 01:37 UTC, Francewhoa
Details
Francewhoa---2017-May-29---speadsheet.ods (9.88 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-05-30 01:38 UTC, Francewhoa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Loomis 2014-07-30 04:02:55 UTC
Problem description: 

Steps to reproduce:
1. Enter some text containing misspelled words
2. Right click on misspelled word for context menu.
3. Usual context menu for a cell is displayed.

Current behavior:
Ignores highlighted word, displays normal context menu.

Expected behavior:
Context menu should include spelling hints, and allow user to choose correct spelling.

Spreadsheets are not used just for accounting.   They are used for check lists that contain instructions, work flows etc.  

Note:  Not sure which release this appeared in.   The first release I noticed is the release that ships with Fedora 20 Live.  My systems have updated several times since installation.   LO 4.2.5.2 on Windows 8.1 works if you click into the cell and right click on the misspelled word.

 
              
Operating System: Fedora
Version: 4.2.0.4 release
Comment 1 Algot Runeman 2014-07-30 18:41:24 UTC
Test System:
Kubuntu 14.4 (KDE 4.13.2)
LibreOffice 4.2.0.2

Entering a misspelled word getts a wavy underline.

Entering one word per cell, if I right click with the pointer within the word, I get the spellcheck context menu.
If I right click in a blank part of the cell in which the misspelled word is located, I get a generic context menu.

When right clicking the misspelled word, the cell enters edit mode with the cursor at the end as if I had clicked the F2 key on my keyboard.

If I entered the sentence "This is verry bad." into a cell (minus the quotes), the spelling context menu appeared if the pointer was on "verry", but the generic context menu appeared if the pointer was on any other word in the sentence.

The same behavior occurs in LibreOffice 4.3.0.3

Dan,

Can you check whether the behavior on your system matches what I have described?
Thanks.
--Algot
Comment 2 Dan Loomis 2014-07-31 04:25:39 UTC
Algot:  To answer your question yes sometimes it works as you describe
I went through and tried a number of highlighted words in a cell:
In your example right clicking on "verry" gave me spelling hints.
hashbrowns gave me spelling hints.
chipolte gave me a default context menu
microclimates gave me a default context menu (Even though microclimate is accepted as a proper spelling.)

The number of spelling hints I am seeing tonight make me wonder if this is an inconsistent problem or perhaps I am being more careful about clicking into the cell and then on the word.  

So I get a default context menu when the word is unknown, without an option to add the word to the dictionary.

Thanks for the response.
Comment 3 Stephen Johnson 2014-08-09 07:35:18 UTC Comment hidden (off-topic)
Comment 4 Dan Loomis 2014-08-13 03:56:52 UTC
Created attachment 104539 [details]
Test spreadsheet

Empire Steve posted this test.   
With word wrap enabled "Did gyre and gimble in the wabe" wraps.  gyre and gimble are on the first line and have hints in the context menu.   Wabe in the second line does not have any hints.   Turn wrap off and wabe will have hints.
Comment 5 Dan Loomis 2014-08-13 04:00:33 UTC
PS:  Reproduced in Fedora 20 in LO 4.2.6.2 (I’ll install 4.3 when it lands in the repo.) And in Windows 8.1 LO 4.3.0.4.
Comment 6 Owen Genat (retired) 2014-08-13 05:00:12 UTC
After discussions in this forum thread:

http://en.libreofficeforum.org/node/8314

... I now realise I have reported the same issue in bug 82540 (which I will close). Thanks for bringing this to my attention Dan. Attachment 104541 [details] more clearly illustrates the issue. It depends on not only if a cell in the same row has text wrap turned on, but also the line of text in the cell the spelling error occurs on. It also appears to be a regression since v4.1.6.2, which worked as expected.

Confirmed. Status set to NEW. Component set back to Spreadsheet (this is not a Writer issue as indicated in comment 3). Importance/Severity also set back to medium/normal. Severity guidelines can be found here:

https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Severity

Keyword PossibleRegression added to Whiteboard. Summary amended for clarity.
Comment 7 Owen Genat (retired) 2014-08-13 05:03:03 UTC
*** Bug 82540 has been marked as a duplicate of this bug. ***
Comment 8 Francewhoa 2014-09-08 16:30:05 UTC
Confirming this issue using
* LibreOffice 4.2.6.2
* Debian 7 Wheezy
* Gnome 3.4.2

Also the size of the cell affect spellcheck context menu

Steps to reproduce bug
1. Enter a misspelled word in a cell
2. Resize the cell so the misspell word is not visible on your screen
3. Double left click the cell to display its content
4. Right click on the misspelled word. Spellcheck context menu will not be display. Expected result is it should.
Comment 9 QA Administrators 2015-10-14 19:56:16 UTC Comment hidden (obsolete)
Comment 10 Francewhoa 2015-10-14 22:07:50 UTC
Confirming this bug is still present using
* LibreOffice: 4.3.3.2
* Build ID: 430m0(Build:2)
* Debian: 7 Wheezy at 64 bit
* Gnome: 3.4.2

Also the size of the cell affect spellcheck context menu

Steps to reproduce bug
1. Enter a misspelled word in a cell
2. Resize the cell so the misspell word is not visible on your screen
3. Double left click the cell to display its content
4. Right click on the misspelled word. Spellcheck context menu will not be display. Expected result is it should.

I would love to test this with LibreOffice 5.0.1. But that version is not available on Debian 7 Wheezy.
Comment 11 Dan Loomis 2015-10-15 02:15:15 UTC
The spellcheck is working a lot better than when I first described it.  I'm not ready to say everything is fixed.  The wavy red line did not appear right away even though automatic spellcheck is enabled.  Clicking on an underlined word didn't always display spelling choices.  I'll play around with this and post another update.

Libre Office
Version: 5.0.0.5
Build ID: 5.0.0.5-2.fc23
Locale: en-US (en_US.UTF-8)

Operating System
Linux Fedora 23 Beta Kernel 4.2.3-300.fc23.x86_64+debug 

GUI
Gnome 3.18
Comment 12 Dan Loomis 2015-10-15 05:01:22 UTC
This issue is partially resolved.   Highlighted items on the first line of a wrapped text cell will reliably display a spellcheck context menu.  
Highlighted items on wrapped lines will not display a spellcheck context menu.

Libre Office
Version: 5.0.0.5   
Build ID: 5.0.0.5-2.fc23
Locale: en-US (en_US.UTF-8)
(5.0.3.1 is in the updates queue waiting for dependencies to land.  I'll test it after it lands.)

Operating System
Linux Fedora 23 Beta Kernel 4.2.3-300.fc23.x86_64+debug 

GUI
Gnome 3.18
Comment 13 Robinson Tryon (qubit) 2015-12-09 18:28:59 UTC Comment hidden (obsolete)
Comment 14 Pete 2016-03-30 21:07:18 UTC
Libre Office Version 5.1.1.3
Checked on Windows 10 Pro and Windows 7 Pro SP1

I can confirm this bug is still present - specifically, with wrapped text in a cell, spelling errors are highlighted with the red underline on all lines in the cell, but the spelling check context menu can only be accessed for the first line of the multi-line wrapped cell.  

This bug has been around for a few years now, which is very disappointing as it is a regression and the feature used to work in earlier versions (I'm sure it worked in version 3)

We use spreadsheets for work logs, with lots of multi-line wrapped cells and this bug is a real pain - please could the priority be escalated? , particularly as it is a regression and has been around too long.

Thanks,

Pete
Comment 15 QA Administrators 2017-05-22 13:18:55 UTC Comment hidden (obsolete)
Comment 16 Dan Loomis 2017-05-26 06:16:57 UTC
Still an issue.   Right clicking on an underlined word does not display a spell check context window.  
Version: 5.2.7.2
Build ID: 5.2.7.2-2.fc25
CPU Threads: 8; OS Version: Linux 4.10; UI Render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 17 Dan Loomis 2017-05-26 06:20:09 UTC
Created attachment 133594 [details]
Example of right click context menu on a highlighted word in Calc

Sample of context menu
Comment 18 Francewhoa 2017-05-30 01:31:23 UTC
Created attachment 133706 [details]
comment-18---About-LibreOffice.jpg
Comment 19 Francewhoa 2017-05-30 01:34:42 UTC
Created attachment 133707 [details]
Francewhoa---2017-May-29---About-LibreOffice.jpg
Comment 20 Francewhoa 2017-05-30 01:35:26 UTC
Created attachment 133708 [details]
Francewhoa---2017-May-29---cell---without-visible-typo.jpg
Comment 21 Francewhoa 2017-05-30 01:35:55 UTC
Created attachment 133709 [details]
Francewhoa---2017-May-29---cell---without-visible-typo---after-right-click-does-NOT-work.jpg
Comment 22 Francewhoa 2017-05-30 01:36:25 UTC
Created attachment 133710 [details]
Francewhoa---2017-May-29---cell---with-visible-typo---right-click---works.jpg
Comment 23 Francewhoa 2017-05-30 01:36:52 UTC
Created attachment 133711 [details]
Francewhoa---2017-May-29---settings---Character.jpg
Comment 24 Francewhoa 2017-05-30 01:37:18 UTC
Created attachment 133712 [details]
Francewhoa---2017-May-29---settings---Format-Cells.jpg
Comment 25 Francewhoa 2017-05-30 01:38:06 UTC
Created attachment 133713 [details]
Francewhoa---2017-May-29---speadsheet.ods
Comment 26 Francewhoa 2017-05-30 01:48:21 UTC
Hi there LibreOffice enthusiasts and QA Team :)

Thanks for following up. We retested. Confirming this bug is still present. No change in the bug behavior from September 2014 to May 2017.

Using:
• LibreOffice: 5.2.6.2
• LibreOffice Build ID: 1:5.2.6-2-bpo8+1
• LibreOffice Local: en-US (en_CA.UTF-8); Calc: group 
• Debian: 8 Jessie at 64bit
• Gnome: 3.14.1

Steps to reproduce bug:
1. Enter a misspelled word in a cell
2. Resize the cell so the misspell word is not visible on your screen. 
      Note: This action is important because the size of the cell affects the bug. This bug can be reproduce only when the misspell words is NOT initially visible on your screen.
3. Double left click the cell to display its content
4. Right click on the misspelled word. Spellcheck context menu will not be display. Expected result is it should, and it should also suggest correction options for user to choose from.

Screenshots:
• "Francewhoa---2017-May-29---cell---without-visible-typo.jpg" shows the cell without visible typo, and before opening it to display its content, including the misspell word "productivityy"
• "Francewhoa---2017-May-29---cell---without-visible-typo---after-right-click-does-NOT-work.jpg" shows the bug. Notice that after user right click on the misspelled word "productivityy" it does NOT display the spellcheck context menu. Expected result is it should.
• "Francewhoa---2017-May-29---cell---with-visible-typo---right-click---works.jpg" shows that when the misspell word is visible on the screen the bug is not present, thus can't be reproduce. Notice that right click on the misspelled word "productivityy" DOES display the spellcheck context menu. In other words, the size of the cell affects the bug. This bug can be reproduce only when the misspell words is NOT initially visible on your screen.
• "Francewhoa---2017-May-29---settings---Character.jpg" shows the Character settings
• "Francewhoa---2017-May-29---settings---Format-Cells.jpg" shows the Format Cells settings
• "Francewhoa---2017-May-29---About-LibreOffice.jpg" shows the details version
• "Francewhoa---2017-May-29---speadsheet.ods" was used for all of the above tests
Comment 27 Telesto 2018-07-13 18:50:48 UTC
*** Bug 118630 has been marked as a duplicate of this bug. ***
Comment 28 Telesto 2018-07-13 18:52:07 UTC
Repro with
Version: 6.2.0.0.alpha0+
Build ID: 8e9d43546c8e46ea635472ddf07f5c183dc13360
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-07-12_01:16:00
Locale: nl-NL (nl_NL); Calc: CL

and with
Version: 4.3.0.4
Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0

but not with
Versie: 4.1.0.4 
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28
Comment 29 Aron Budea 2020-01-12 14:55:51 UTC
I bibisected this with attachment 133713 [details] using repo bibisect-42max:
- opened the file,
- double-clicked the cell with the long text (A1),
- right-clicked on the misspelled word.

The bug started with the following commit, which is the same as identified in bug 120896.
https://cgit.freedesktop.org/libreoffice/core/commit/?id=91923443e0d04218ae7124f439fc06a76f904462
author		Kohei Yoshida <kohei.yoshida@collabora.com>	2013-10-09 18:55:30 -0400
committer	Kohei Yoshida <kohei.yoshida@collabora.com>	2013-10-11 12:14:25 -0400

"Fix context menu launch on mis-spelled word in a cell."

Slightly different steps led me to a different commit with repo bibisect-43max:
- opened the file,
- resized A1 so the text fit completely,
- double-clicked A1,
- right-clicked on the misspelled word.

These steps pointed to the following commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=73f0b3bd5553c5d023d0a1dbfdc00836e2937961
author	Matteo Casalin <matteo.casalin@yahoo.com>	2013-12-28 13:37:26 +0100
committer	Matteo Casalin <matteo.casalin@yahoo.com>	2013-12-28 22:40:42 +0100

"xub_StrLen to sal_Int32 + some const"
Comment 30 QA Administrators 2022-01-12 03:42:09 UTC Comment hidden (obsolete, spam)
Comment 31 Justin L 2022-02-10 12:23:57 UTC
*** Bug 83586 has been marked as a duplicate of this bug. ***
Comment 32 Justin L 2022-02-10 12:36:54 UTC
Note that when autowrapping is off, a second line of text (created with shift-enter) will get suggestions. (If autowrap is happening, then there is a dead spot where the second paragraph's wrong spelling position would have been on the second line.)
Comment 33 Justin L 2022-02-19 15:10:08 UTC
Focusing on comment 6's Attachment 104541 [details] and cell B12, I bisected that to bibisect-linux-43max commit de7e6a479d5af64e330bcbac2bc491e79076039b

source commit cd22c3442389f69fc1cc14dd07b17f5a59498e5e
Author: Kohei Yoshida on Fri Apr 11 23:09:38 2014 -0400
        fdo#74087: Inspect if a mis-spelled word is at cursor position...
        then decide whether to launch a spell candidate menu or a regular
        context menu.

https://cgit.freedesktop.org/libreoffice/core/log/?id=47a77d7dbc427e51421e2df8d59695834cb74980&qt=range&q=cd22c3442389f69fc1cc14dd07b17f5a59498e5e

This was the commit that introduced IsSpellErrorAtPos(), and it was a follow-up fix for the first one mentioned in comment 29. It both allowed spell checking of spill-out text, and allowed IsSpellErrorAtPos to cancel a bSpellError.

But it is fairly simple to return bDone=false from ExecuteSpellPopup if there is no misspelled word at that PixelPos - and that is much more accurate. If not done, then the  non-spelling popup will display (but care needs to be taken to close editing first if necessary).
Comment 34 Commit Notification 2022-02-25 14:23:06 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cf18038c66075f7a18d89e47f3a2ab1a5bf7c4fd

tdf#81894 sc spelling: eliminate separate(inaccurate) check

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 35 Commit Notification 2022-02-25 14:23:16 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8238b887ccecb425f17166d2380afb208bbfdfbb

tdf#81894 sc spelling: choose correct cell when in edit mode

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 36 Commit Notification 2022-02-25 14:24:25 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/bdea5805c0344cbddb5c68d1fd19d3cd3b6e3afd

tdf#81894 sc spelling: close EditView when moving outside cell

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 37 Commit Notification 2022-02-25 14:25:34 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a24eac37fbf8a325b09c3b575c568621a696a560

tdf#81894 sc spelling: re-close EditView if not spelling error

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.