Download it now!
Bug 83754 - EDITING: Replace with format hangs when changes being recorded
Summary: EDITING: Replace with format hangs when changes being recorded
Status: RESOLVED DUPLICATE of bug 65056
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2014-09-11 08:55 UTC by gipsonp@gmail.com
Modified: 2015-04-01 09:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer document that causes the problem (44.83 KB, application/vnd.oasis.opendocument.text)
2014-09-11 08:55 UTC, gipsonp@gmail.com
Details
console bt (4.81 KB, text/plain)
2014-09-12 21:08 UTC, Julien Nabet
Details
Minimal reproducer (7.86 KB, application/vnd.oasis.opendocument.text)
2015-04-01 08:54 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gipsonp@gmail.com 2014-09-11 08:55:03 UTC
Created attachment 106114 [details]
Writer document that causes the problem

Problem description: When I try and replace the diamond symbol in this document with a diamond symbol with the font colour set to Orange, the replace hangs when recording changes is set on.

Steps to reproduce:
1. Copy the diamond symbol. Open the replace dialog (Ctrl-H) and put the diamond symbol into the Search and Replace boxes. Select other options and Format, change the Font Effects->Font Colour to Orange.

Ensure that Edit->Changes is set to Record.

2. Click 'Replace All' 
3. The first dialogue window says do you want to shows changes to avoid delays. Click No.

System now hangs.

Current behavior: System hands and changes are not made. File needs to be recovered.

Expected behavior: Replacements work!

              
Operating System: Windows 8
Version: 4.3.1.2 release
Comment 1 Jacques Guilleron 2014-09-11 19:29:51 UTC
Hi gipsonp,

I reproduce too with LO 4.3.1.2 Build ID: 958349dc3b25111dbca392fbc281a05559ef6848
& Windows 7 Home Premium.
I guess you set font color to red in the search part.
This happens only with Replace all. Result can be achieved by replacing esach occurence one by one without this crash.
I set status to NEW.

Thank you for the report,

Jacques
Comment 2 Julien Nabet 2014-09-12 21:08:59 UTC
Created attachment 106202 [details]
console bt

On pc Debian x86-64 with master sources updated today, I could reproduce the problem.

I attached console logs + a bt (I put a location where there's a loop, perhaps infinite loop?)
Comment 3 ign_christian 2014-09-13 14:22:20 UTC
Also reproduced with LO 4.0.6.2, 4.1.6.2, 4.2.7.0.0+ Time: 2014-09-11_14:25:14 under Ubuntu 12.04 32bit
Comment 4 Matthew Francis 2015-04-01 08:54:55 UTC
Created attachment 114518 [details]
Minimal reproducer

The attached document contains a single "♦︎" (BLACK DIAMOND SUIT, U+2666 U+FE0E)

As in comment 0, with tracked changes enabled, replacing the "♦︎" with another "♦︎" formatted with a colour causes a hang.
Comment 5 Matthew Francis 2015-04-01 09:14:33 UTC
Character selector led me up the garden path, the character is just U+2666 - but it seems it's not specific to that either. In fact, replacing anything with an added format while tracked changes are enabled seems to hang.

This also occurs all the way back to 3.3.0
-> Version: Inherited from OOo
Comment 6 Matthew Francis 2015-04-01 09:17:50 UTC
...and finally, having generalised the problem, I see that there is an earlier duplicate

*** This bug has been marked as a duplicate of bug 65056 ***