Download it now!
Bug 84052 - Ordinamenti
Summary: Ordinamenti
Status: RESOLVED DUPLICATE of bug 84055
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-18 15:26 UTC by Gabriele Vechi
Modified: 2014-09-18 20:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
If you order the table in the sheet "Inserimento dati" using the macro "Ordina posti" in the linked tables on other sheets the orter does'nt change and the linked formulas are changed. (273.64 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-09-18 15:26 UTC, Gabriele Vechi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriele Vechi 2014-09-18 15:26:08 UTC
Created attachment 106509 [details]
If you order the table in the sheet "Inserimento dati" using the macro "Ordina posti" in the linked tables on other sheets the orter does'nt change and the linked formulas are changed.

In questa release di Libre Office se si effettua un ordinamento su una tabella nelle tabelle collegate su un altro foglio vengono modificate le formule di calcolo, nelle versioni precedenti le formule di calcolo restavano invariate e quindi era possibile ottenere automaticamente anche un ordinamento delle tabelle collegate, cosa ora non più possibile (allego un foglio di esempio: ordinando con una macro l'elenco del primo foglio per la colonna "N.posto", prima si ordinavano le tabelle anche sugli altri fogli, ora non è più possiboile). Tutta una serie di miei fogli di calcolo diventano inutilizzabili in questo modo.

In this release of Libre Office if you order a table in the linked tables on another sheets is changed the formulas, in earlier versions calculation formulas remained unchanged and so it was possible to automatically obtain a sort of linked tables, what now no longer possible (attached a sheet of example: ordering with a macro the list of the first sheet for the column "N.posto", before you ordered tables on other sheets, it's now no longer possiboile). A whole series of my spreadsheets become unusable in this way.

Grazie,

Gabriele
Comment 1 Jean-Baptiste Faure 2014-09-18 20:42:46 UTC

*** This bug has been marked as a duplicate of bug 84055 ***