Bug Hunting Session
Bug 84055 - Sorting in source sheet not sorting target sheet
Summary: Sorting in source sheet not sorting target sheet
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.5.0 target:4.4.0.beta2 t...
Keywords:
: 84052 (view as bug list)
Depends on:
Blocks: 85490
  Show dependency treegraph
 
Reported: 2014-09-18 15:52 UTC by Gabriele Vechi
Modified: 2014-12-04 17:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
If yuo ordr the table ""Area_Dati" in the sheet "Inserimento dati" in the linked tables in the other sheets the order was changed too, now are changed the linked formulas insteed. (273.64 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2014-09-18 15:52 UTC, Gabriele Vechi
Details
This is a simple worksheet with two tables in two sheets (46.80 KB, application/LibreOffice_Worksheet)
2014-09-19 14:36 UTC, Gabriele Vechi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriele Vechi 2014-09-18 15:52:33 UTC
Created attachment 106511 [details]
If yuo ordr the table ""Area_Dati" in the sheet "Inserimento dati" in the linked tables in the other sheets the order was changed too, now are changed the linked formulas insteed.

Problem description: 
In this release of Libre Office if you order a table, in the linked tables on another sheet are changed the formulas; in earlier versions, formulas calculation remained unchanged and so it was possible to automatically obtain a sort of linked tables, it is now no longer possible (attached a sheet of example: ordering with a macro the list of the first sheet for the column "N.posto", before you got ordered tables on other sheets, it is'nt now no longer possiboile). A whole series of my spreadsheets become unusable in this way.

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

              
Operating System: Windows 7
Version: 4.3.1.2 release
Last worked in: 4.2.6.2 release
Comment 1 Jean-Baptiste Faure 2014-09-18 20:42:46 UTC
*** Bug 84052 has been marked as a duplicate of this bug. ***
Comment 2 ign_christian 2014-09-19 06:38:54 UTC
Hi Gabriele..I think your file is too complex to observe (at least for me).

Could you please provide simple test case & exact reproducible steps? Without macros if possible, unless the problem is in macros.
Comment 3 Gabriele Vechi 2014-09-19 14:36:15 UTC
Created attachment 106552 [details]
This is a simple worksheet with two tables in two sheets

In this ods file there are two tables in two sheets ("table" and "derived table").
The data are entered directly into the table on the first sheet.
In the table of the second sheet ("Derived table"), data are read from the table of the first sheet in an orderly manner by formulas in order to reproduce exactly the same table (albeit with a slightly different structure and formatting).
Ordering the first table, for a key ("N °" or "Position" or "NAME") the derived table in version 4.2.6 of LibreOffice is automatically ordered too and preserves the order of the first table, in 4.3 version of LibreOffice order of the derived table is not changed and are modified the references of the formulas instead.

STEP 1: Select the table in the first sheet (data - Select area - "DATA")
STEP 2: Order the data in the first table (data - order - ....
STEP 3: Wiew results in the second sheet ....

The results are completely different in the two versions of LibreOffice.
I need to keep the order of the first table in the derived tables and I could not find an alternative way to do it.

I hope this example file allows for easier understanding of the problem.
Comment 4 ign_christian 2014-09-19 15:18:39 UTC
Thanks Gabriele. It's easier to understand now :)

Reproduced with LO 4.3.2.2, 4.2.7.0.0+ Time: 2014-09-11_14:25:14 under Ubuntu 12.04 x86

Not reproduced with LO 4.3.0.4, 4.2.6.3

Possibly it's because fixing of Bug 81309 that introduce new behavior of internal sorting.
Comment 5 Kohei Yoshida 2014-09-19 19:13:58 UTC
This is not a regression and the change is intentional.

Also note Bug 81633 which makes this behavior configurable, though due to translation requirement it is for 4.4 only.
Comment 6 Jean-Baptiste Faure 2014-10-09 19:47:40 UTC
Same problem as in bug 81633 but in this case the configuration option in LO 4.4 works as expected.

Best regards. JBF
Comment 7 Eike Rathke 2014-12-04 17:09:04 UTC
Just to say that 4.2.8, 4.3.5 and 4.4 will restore the old behavior. For releases that have the UpdateReferenceOnSort configuration option with the option set to false/unchecked, which is default.