Download it now!
Bug 84075 - CRASH: Trying to access page properties dialog
Summary: CRASH: Trying to access page properties dialog
Status: RESOLVED DUPLICATE of bug 81496
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace, regression
Depends on:
Blocks: Page-Style-Dialog
  Show dependency treegraph
 
Reported: 2014-09-19 05:02 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-10-18 02:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
linux backtrace (30.88 KB, text/plain)
2014-09-19 05:02 UTC, Yousuf Philips (jay) (retired)
Details
OSX backtrace (67.78 KB, text/plain)
2014-09-19 12:37 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-09-19 05:02:10 UTC
Created attachment 106535 [details]
linux backtrace

Steps:
1) Open Calc
2) Goto Format > Page...
3) Crash

Version: 4.4.0.0.alpha0+
Build ID: 510bb3fab28dffcdd5ff544b85063e8cc3d3f48e
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-09-17_22:09:19
Comment 1 Matthew Francis 2014-09-19 05:38:35 UTC
Confirmed for master on both OSX and Linux.

4.4 bibisect puts the first bad build at 2014-07-02

-> NEW
Comment 2 Matthew Francis 2014-09-19 12:32:34 UTC
Following up with a plain bisect within the one-day range identified by the bibisect, this seems to be another result of:

commit 7d9bb549d498d6beed2c4050c402d09643febdfa
Author: Armin Le Grand <alg@apache.org>
Date:   Mon Jun 2 15:00:50 2014 +0000

    Related: #i124638# Second step of DrawingLayer FillAttributes...


(Calc is broken completely for the following few commits, then when it comes back this bug is reproducible)
Comment 3 Matthew Francis 2014-09-19 12:37:07 UTC
Created attachment 106546 [details]
OSX backtrace

Incidentally I get a rather different backtrace both on OSX and Linux.

The OSX version is as attached.
Comment 4 Matthew Francis 2014-09-19 12:46:27 UTC

*** This bug has been marked as a duplicate of bug 81496 ***