Download it now!
Bug 84175 - Only one table in Calc document is exported to PDF
Summary: Only one table in Calc document is exported to PDF
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2014-09-22 09:10 UTC by Ulrich Windl
Modified: 2017-11-23 15:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Case (ODS-Document with two versions) (65.66 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-06-09 08:47 UTC, Ulrich Windl
Details
Demonstration Video (4.63 MB, video/x-ms-wmv)
2015-06-11 11:19 UTC, Ulrich Windl
Details
Exported PDF (26.74 KB, application/pdf)
2015-06-12 14:57 UTC, Buovjaga
Details
Revised Test Case (11.95 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-11-02 07:51 UTC, Ulrich Windl
Details
Sample PDF Output for attachment 137439 (29.96 KB, application/pdf)
2017-11-02 07:53 UTC, Ulrich Windl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Windl 2014-09-22 09:10:21 UTC
I have a calc document with nine tables. When exporting to PDF selecting "all pages" only the table modified last (1 page) is exported to PDF.
I have defined data areas for each table, but no print areas.
An older version of the same document exported correctly to PDF with an older Version of OpenOffice.
Comment 1 tommy27 2014-10-18 02:41:54 UTC
please upload test file otherwise it will be impossible to debug

I set status to NEEDINFO
revert it to UNCONFIRMED once you provide the file
Comment 2 QA Administrators 2015-05-06 14:15:20 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2015-06-08 14:27:08 UTC Comment hidden (obsolete)
Comment 4 Ulrich Windl 2015-06-09 08:45:16 UTC
Reproduced with LibreOffice 4.3.7.2: WHen having many tables, only one table is exported to PDF, but when removing some tables, suddenly all tables are exported to PDF.
Comment 5 Ulrich Windl 2015-06-09 08:47:04 UTC
Created attachment 116401 [details]
Test Case (ODS-Document with two versions)

There are two versions inside Test2.ods: The first one has the bug, and in the last one just some tables were deleted from the right. Then all tables are exported to PDF.
Comment 6 Timur 2015-06-09 11:08:59 UTC
This is not clear: "nine tables" means "9 sheets"?, what are "two versions inside Test2.ods", 2 versions of what? etc.
Please write what you get and what you expect, step by step, enumerated.
Comment 7 Ulrich Windl 2015-06-09 12:25:51 UTC
Comment #6 makes me wonder:
In German translation "sheets" are named "Tabelle" (which is table). Despite of the obvious confusion when actually opening the document, it should be clear.
What really surprises me that people hunting for bugs in LibreOffice don't know about "versions" you can save in a file. Am I really expected to explain here what a version in an ODS file is?
Comment 8 Timur 2015-06-09 13:54:31 UTC
A submitter is expected:
1. to be polite and patient
2. to report a bug with step by step instructions, enumerated
3. not to expect that someone must guess, even if he/she is an experienced user

So, since I will not do it now, please:
1. test earlier LO and OO versions to determine the earliest affected Version
2. test it also in Linux
3. determine importance according to the bug flowchart
Comment 9 Ulrich Windl 2015-06-11 10:31:57 UTC
The bug is also present in OpenOffice.org Portable 3.2.0 on Windows 7 (64bit).
Comment 10 Ulrich Windl 2015-06-11 11:19:41 UTC
Created attachment 116468 [details]
Demonstration Video

Those who feel they need it, here's a video showing how to open the buggy version of attachment 116401 [details] and then export it as PDF (Adobe Reader opens automatically). I'll be happy to explain opening and saving in greater detail if you need it.
Comment 11 Buovjaga 2015-06-12 14:57:09 UTC
Created attachment 116487 [details]
Exported PDF

My PDF export has 5 pages.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 5fc0cbbc1254223fedf0f78c5e7539219b228697
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-11_04:30:51
Locale: fi-FI (fi_FI)
Comment 12 Ulrich Windl 2015-06-15 06:07:40 UTC
(In reply to Beluga from comment #11)
> My PDF export has 5 pages.

So you exported the "Non-Buggy" version. The "Buggy" Version has 9 sheets. Please open version 1 (with comment "Buggy") of the document. It seems (as I hopefully pointed out in comment 4) that the problem seems to depend on the number of sheets.
Comment 13 Buovjaga 2015-06-15 06:14:41 UTC
Ok, so one needs to do File - Versions and select the one called Buggy and open it as copy.
Confirmed that it exports only 1 page.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 01a189abcd9a4ca472a74b3b2c000c9338fc2c91
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-14_07:46:28
Locale: fi-FI (fi_FI)
Comment 14 QA Administrators 2016-09-20 10:02:10 UTC Comment hidden (obsolete)
Comment 15 Ulrich Windl 2016-10-04 07:53:40 UTC
The problem seems to be fixed in LibreOffice 5.1.3 (on OpenSUSE at least).
Comment 16 Buovjaga 2016-10-04 10:18:27 UTC
Still exporting only 1 page on Win and Linux.

Win 7 Pro 64-bit Version: 5.3.0.0.alpha0+
Build ID: 7da2f3ce9f7b049c177a735a146dae84a764d3f7
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-04_03:49:06
Locale: fi-FI (fi_FI); Calc: CL

Version: 5.2.2.2
Build ID: 1:5.2.2-0ubuntu1~xenial0
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 17 Buovjaga 2016-10-04 10:47:22 UTC
Also reproduced on 3.5

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 18 QA Administrators 2017-10-30 08:32:22 UTC Comment hidden (obsolete)
Comment 19 Ulrich Windl 2017-11-02 07:34:37 UTC
Still present in 5.3.6.1 (Windows, Linux). However it seems the test case provided (attachment 116401 [details]) works, but the original file does not.
Comment 20 Ulrich Windl 2017-11-02 07:51:45 UTC
Created attachment 137439 [details]
Revised Test Case

This test case was saved with Calc 5.3.5.2 (openSUSE 42.2 on x86_64).
Comment 21 Ulrich Windl 2017-11-02 07:53:24 UTC
Created attachment 137440 [details]
Sample PDF Output for attachment 137439 [details]

PDF created with Calc 5.3.5.2 (openSUSE 42.2 on x86_64).
Comment 22 Cor Nouws 2017-11-23 15:21:38 UTC
Printing "All" and "Pages" depends on the defined print ranges.
The version Buggy has a print range on sheet A.
IMO that is the reason.

try the preview Print dialog.
1 - Active sheet e.g. 1.
Print preview empty with Selected Sheet.
Print preview 1 page with All Sheets.

2 - Active sheet A
Print preview 1 page with Selected Sheet.
Print preview 1 page with All Sheets.

IMO not a bug.