Download it now!
Bug 84275 - EDITING: Writer now treats copied and pasted text from Word as an image
Summary: EDITING: Writer now treats copied and pasted text from Word as an image
Status: RESOLVED DUPLICATE of bug 35176
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-24 09:16 UTC by slowman_xxx
Modified: 2017-01-08 20:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (5.65 KB, image/png)
2014-12-19 11:43 UTC, Michael Bauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description slowman_xxx 2014-09-24 09:16:34 UTC
Problem description: 

Just upgraded to Version: 4.2.6.3
Build ID: 3fd416d4c6db7d3204c17ce57a1d70f6e531ee21

NB: Version 4.2.6.3 is not available in your dropdown list

Steps to reproduce:
1. .... Copy text from MS Word
2. .... Paste text into Writer


Current behavior: Writer treats the text as an image

Expected behavior: Previously it has always treated it as formatted text which is obviously a lot more useful...

              
Operating System: Windows 7
Version: 4.2.6.2 release
Comment 1 Jean-Baptiste Faure 2014-09-25 07:16:32 UTC
Thank you for this bug report.

Confirmed on fr-discuss mailing-list. See discussion starting here:
http://go.mail-archive.com/o_NrqK9MWcRRmoUtEKVG7lBmWm8=

Workaround: use paste special.

Best regards. JBF
Comment 2 Michael Bauer 2014-12-19 11:43:12 UTC
Created attachment 111037 [details]
screenshot

Also having this issue (LO 4.2.6.3). The workaround is not good because this bug seems to come with associated 'problems'. The usual scenario on my machine is:
1) Open LO - New document
2) SHIFT-CTRL-V - no result; going via Edit menu has the Paste Special greyed out

Only solution:
2) CTRL-V
3) Delete graphic
4) Usually SHIFT-CTRL-V then works but only once
Comment 3 QA Administrators 2015-12-20 16:08:13 UTC Comment hidden (obsolete)
Comment 4 Michael Bauer 2015-12-20 16:15:54 UTC
This appears to be working for me in 5.0, both in Calc and Writer.
Comment 5 QA Administrators 2017-01-03 19:46:52 UTC Comment hidden (obsolete)
Comment 6 Timur 2017-01-04 11:26:43 UTC
If a specific commit/fix is not known, then it should be marked as WorksForMe, not Fixed.
But if bug where it's resolved it known, then it's a duplicate. In this case, looks like of Bug 81835.

*** This bug has been marked as a duplicate of bug 81835 ***
Comment 7 Luke 2017-01-08 20:22:16 UTC

*** This bug has been marked as a duplicate of bug 35176 ***
Comment 8 Luke 2017-01-08 20:30:08 UTC
Timur,

Bug 81835 is actually the cause of this issue. This is about pasting from MS Office apps like Word being broken, so it's a dupe of bug 35176, which has NOT been resolved. Still broken in today's 5.4 master.