Bug 84317 - DOCX EXPORT: Non-English Outline Numbering lost
Summary: DOCX EXPORT: Non-English Outline Numbering lost
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.7.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.4
Keywords: filter:docx
Depends on:
Blocks: DOCX-Limitations
  Show dependency treegraph
 
Reported: 2014-09-25 08:45 UTC by Kevin Suo
Modified: 2016-12-09 10:45 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
the ODT file which contains outline numbering (28.08 KB, application/vnd.oasis.opendocument.text)
2014-09-25 08:46 UTC, Kevin Suo
Details
pdf file: the ODT file should look like this when open (38.55 KB, application/pdf)
2014-09-25 08:48 UTC, Kevin Suo
Details
DOCX file saved with version 4.3.2.1: outline numbering are lost (5.12 KB, application/vnd.openxmlformats-officedocument.wordprocessingml)
2014-09-25 08:49 UTC, Kevin Suo
Details
DOCX file saved with version 4.4.0 beta 1 (5.32 KB, application/vnd.openxmlformats-officedocument.wordprocessingml)
2014-11-27 01:50 UTC, Kevin Suo
Details
Text from ODT saved in MSO 2010 (14.30 KB, application/vnd.ms-word.document)
2016-03-14 14:17 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-09-25 08:45:52 UTC
Non-english outline numbering (i.e., "一, 二, 三", "①, ②, ③", "α, β, γ"...) are lost when export to DOCX format.

Steps to reproduce:
1. Open the attached ODT file in Writer. Observe that the outline nunbering are displaying correctly.
2. Save the attached ODT file as DOCX and reopen.

--> Outline nunbering are lost.

This does not happen to numbering like "1,2,3","i,ii,iii", "I,II,III" etc.

This is a possible regression, as I remember it works OK in older versions (althrough I do not know how which version it works).
Comment 1 Kevin Suo 2014-09-25 08:46:36 UTC
Created attachment 106839 [details]
the ODT file which contains outline numbering
Comment 2 Kevin Suo 2014-09-25 08:48:27 UTC
Created attachment 106840 [details]
pdf file: the ODT file should look like this when open
Comment 3 Kevin Suo 2014-09-25 08:49:06 UTC
Created attachment 106841 [details]
DOCX file saved with version 4.3.2.1: outline numbering are lost
Comment 4 Kevin Suo 2014-09-25 08:49:41 UTC
Version: 4.3.2.1
Build ID: f9b3ad49d92181b0a1fe7e76f785a2c2cd0847d3

OS: Windows XP SP3
Comment 5 Robinson Tryon (qubit) 2014-09-25 12:51:45 UTC
CONFIRMED in LO 4.3.1.1 + Ubuntu 14.04

(In reply to comment #0)
> Non-english outline numbering (i.e., "一, 二, 三", "①, ②, ③", "α, β, γ"...) are
> lost when export to DOCX format.
> 
> Steps to reproduce:
> 1. Open the attached ODT file in Writer. Observe that the outline nunbering
> are displaying correctly.
> 2. Save the attached ODT file as DOCX and reopen.
> 
> --> Outline nunbering are lost.

Confirmed: Heading numbering changes to dots and small dash-like chars.


Bug/regression appears to predate 4.3.2, so not a regression introduced in the 4.3.2 tag-and-release cycle.
Comment 6 Kevin Suo 2014-11-27 01:50:03 UTC
Created attachment 110095 [details]
DOCX file saved with version 4.4.0 beta 1

It's becoming better in
Version 4.3.4.1
Build ID: bc356b2f991740509f321d70e4512a6a54c5f243

But still buggy. (Only Heading 1 is correct, all others are of wrong numbering style.)
Comment 7 Matthew Francis 2014-12-09 17:33:57 UTC
I can't find anything in the 43all bibisect repository (down to 3.5) which behaves better than current master on the sample file

3.3.0 release does slightly better than what followed, but still not as good as current master, so on balance this can't usefully be classified as a regression (against current master at least)

-> Removing Whiteboard: PossibleRegression, bibisectRequest
Comment 8 Peter Roelofsen 2015-05-05 17:44:29 UTC
Still loss of outline numbering in 4.4.2.2 on conversion to docx.
Comment 9 meneerjansen00 2015-05-05 18:55:12 UTC
I can confirm this bug still exists. 

A deal breaker for me. If chapter numbering does not work then I cannot use the Word Processor. And since I only use a WYSIWYG Word Processor if I have to share docs w/ people that don't know how to use LaTeX MS's .doc(x) format is the ONLY way to go.

Hope this'll get some priority.
Comment 10 Björn Michaelsen 2015-06-23 19:17:55 UTC
Priotizing properly as per https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

Enhancement as long as no properly working prior version existed. Minor otherwise ("... or require users not to use some feature").
Comment 11 Robinson Tryon (qubit) 2015-12-09 18:44:54 UTC Comment hidden (obsolete)
Comment 12 A (Andy) 2016-01-24 09:24:35 UTC
Reproducible with LO 5.1.0.2, Win 8.1
Comment 13 Commit Notification 2016-01-27 13:37:18 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=91b926d4b9939337f54d6c9f0b940b161dc3437f

tdf#84317 convert missing numbering types to OOXML tokens.

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Kevin Suo 2016-02-16 06:33:10 UTC
(In reply to Commit Notification from comment #13)
@Mark Hung: Thanks a lot for the fix. Would you please backport this to 5.0 and 5.1? Both these versions are affected.
Comment 15 Timur 2016-03-07 15:35:49 UTC
It's definitely better, but don't know whether this should be marked fixed or some more improvement is realistic to expect. 
"①, ②, ③", "α, β, γ" are not lost anymore, but they are converted to digits.
May I kindly ask for an explanation, why those aren't fully converted?
Comment 16 Mark Hung 2016-03-07 15:46:07 UTC
@Timur:

Is numbering in greek letters supported by any version of MS Word? 

I try to find mapping from here as much as possible:
http://www.datypic.com/sc/ooxml/t-w_ST_NumberFormat.html

If I can't find one, then I make it fallback to decimal.
Comment 17 Kevin Suo 2016-03-08 00:38:34 UTC
(In reply to Mark Hung from comment #16)
It should be "Lowercase Latin Alphabet" and "Uppercase Latin Alphabet".
Comment 18 Timur 2016-03-14 14:17:18 UTC
Created attachment 123561 [details]
Text from ODT saved in MSO 2010
Comment 19 Commit Notification 2016-05-10 18:43:26 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=23491789f77af6cec8f82d89cb82160b0a002614&h=libreoffice-5-1

tdf#84317 convert missing numbering types to OOXML tokens.

It will be available in 5.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Michael Stahl (CIB) 2016-05-10 18:47:55 UTC
backported to 5.1

for 5.0 i don't think a backport is appropriate since this is not a regression and there are no planned 5.0 releases any more
Comment 21 Xisco Faulí 2016-09-15 20:42:03 UTC
Hi,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Regards
Comment 22 Xisco Faulí 2016-09-15 20:43:51 UTC Comment hidden (obsolete)
Comment 23 Kevin Suo 2016-10-20 07:27:45 UTC
(In reply to Xisco Faulí from comment #22)

As said in comment 15, the outline numberings are not lost anymore, but "①, ②, ③", "α, β, γ" are converted to digits. So this bug is only half-fixed.
Comment 24 Kevin Suo 2016-10-20 07:30:38 UTC Comment hidden (obsolete)
Comment 25 Kevin Suo 2016-10-20 07:40:40 UTC
(In reply to Kevin Suo from comment #24)

New bug related to "①, ②, ③", "α, β, γ" being converted to digits is reported in bug 103345.