Bug 85076 - F11 "Styles and Formatting" not working when sidebar hidden
Summary: F11 "Styles and Formatting" not working when sidebar hidden
Status: RESOLVED DUPLICATE of bug 83546
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab4.4
  Show dependency treegraph
 
Reported: 2014-10-16 00:01 UTC by Tim Lloyd
Modified: 2015-03-15 14:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Lloyd 2014-10-16 00:01:17 UTC
Fedora 21 alpha. LO4.4.0.0

Build ID: 5e27d23d7e665cc0aeac8fc9ea2236bf8bc088ff
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-10-10_22:02:16

Within writer press F11 and there is no response
Format->Styles and Formatting. Ditto

I checked Calc and the function is working there
Comment 1 tommy27 2014-10-16 01:35:19 UTC
works fine under Win7x64 using 4.4.0.0.alpha0+
Build ID: 2d6dacc1c93bfd4a9086f8fde6b0edbfdeb573c9
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-13_23:44:09

please retest with a more recent daily build to see if issue persists
Comment 2 tommy27 2014-10-16 01:43:15 UTC
ooopsss... wait a minute...

I found where the issue is... the style and formatting has been moved into the sidebar in 4.4.x.  see: https://wiki.documentfoundation.org/ReleaseNotes/4.4#Sidebar_changes

so when the sidebar is in visible state the F11 do work, whilst if the sidebar is in hidden state the F11 looks uneffective.

I see the same bug in Calc as well, not just in Writer and it also depends from the sidebar state.

I add Samuel Mehrbrodt to CC list. maybe he can help.
Comment 3 Samuel Mehrbrodt (CIB) 2014-10-16 05:43:03 UTC
How did you close the sidebar?
Comment 4 tommy27 2014-10-16 06:09:38 UTC
I don't have master here at hand, anyway there's a clickable area in the margin of the vertical sidebar left margin that toggles sidebar on/off.

when it's on the F11 works and the style and formatting windows appears in the sidebar, whilst if the sidebar is off the F11 does nothing because sidebar is hidden.

if I'm correct the F11 should toggle on visibility of sidebar if that was in hidden state in order to show up
Comment 5 Samuel Mehrbrodt (CIB) 2014-10-16 13:12:02 UTC

*** This bug has been marked as a duplicate of bug 83546 ***