Bug Hunting Session
Bug 85128 - Impress consistently crashes when copying a table
Summary: Impress consistently crashes when copying a table
Status: RESOLVED DUPLICATE of bug 82681
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
: 88149 (view as bug list)
Depends on:
Blocks: mab4.3
  Show dependency treegraph
 
Reported: 2014-10-17 08:03 UTC by E Moen
Modified: 2015-02-06 13:19 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
The file referred to in the description (599.67 KB, application/vnd.oasis.opendocument.presentation)
2014-10-17 08:03 UTC, E Moen
Details
Windbg info (no reproduce, EH exception) (13.32 KB, text/plain)
2014-10-17 09:04 UTC, Kevin Suo
Details
Backtrace when copying the table (7.85 KB, text/plain)
2014-10-17 20:48 UTC, E Moen
Details
Backtrace copying some stuff and editing it until crash (6.69 KB, text/plain)
2014-10-17 20:48 UTC, E Moen
Details
Backtrack table copy problem on 4.3.3 RC1 (7.96 KB, text/plain)
2014-10-18 08:36 UTC, E Moen
Details
Backtrace on Kubuntu 14.04, with LO 4.3.3.2 (14.98 KB, text/x-log)
2014-10-30 15:30 UTC, Bill Kristan
Details
bt with debug symbols (9.27 KB, text/plain)
2014-11-01 22:12 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description E Moen 2014-10-17 08:03:22 UTC
Created attachment 107978 [details]
The file referred to in the description

In the attached file there are three sheets with tables. Impress consistently crashes when selecting one of these tables and do a ctr-C.

I find Impress to be very unstable. I encountered a lot of crashes. Not only this problem (which I submit because it is consistent and therefor repeatable) but also when simply working with objects and text blocks. This morning I was working for a few hours and had at least a dozen chrashes. Saving insanely frequent does improe this slightly.

I will try the still again and if I encounter the same behaviour I am very sorry to say that I see no other option than to buy M$ Office... :-(
Comment 1 E Moen 2014-10-17 08:26:38 UTC
I'm back on the still version (4.2.6.3) and I am very happy to say that the consistent crashing does not appear in this version. I will continue using Impress (intensively) and will report again if crashed start te reappear.

By the way, thanks for al the great work. Although being a bit put off by the problems experienced, I am really glad to be able to continue working with LO.
Comment 2 Kevin Suo 2014-10-17 09:04:16 UTC
Created attachment 107981 [details]
Windbg info (no reproduce, EH exception)

I do not reproduce the crash in Win7 X64, 
LibreOffice  4.3.3.1
Build ID: 7d55112667c8fcddb67bc3803796b46c93aa56b0

However, during debuging, every time I was trying to select a table, I got the following:
(ef4.a48): C++ EH exception - code e06d7363 (first chance)

@ E Moen:
If you have time, please follow the instructions here to attach a backtrace:
https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
This is very helpful for devs to solve this issue. Thanks!
Comment 3 E Moen 2014-10-17 09:21:09 UTC
Hi Kevin,

I can probably find some time this weekend. I will try and report back.

Additional: I'm on Windows 8.1 (64)

Regards,

E. Moen
Comment 4 E Moen 2014-10-17 20:48:06 UTC
Created attachment 108006 [details]
Backtrace when copying the table
Comment 5 E Moen 2014-10-17 20:48:54 UTC
Created attachment 108007 [details]
Backtrace copying some stuff and editing it until crash
Comment 6 E Moen 2014-10-17 20:52:55 UTC
Hello,

Done some backtracking, resulting in two files: BT1 and BT2.

BT1
This is the analysis of the table copying problem.

BT2
This is another analysis of a crash that I also found to happen almost certain. What I did was: copying some objects (squares, arrows and some text) from one file to the other (both files obviously opened) and after that, some random editing (make squares smaller, move some text, rearrange an arrow etc.). After something like 10 to 15 of these actions Impress crashed. I have seen this happening a lot.

Hope this helps.

Cheers,

Egbert
Comment 7 Kevin Suo 2014-10-18 01:07:12 UTC
Set to NEW as there is backtrace with symbles.

@Meon: If you have time please test with version 4.3.3 RC1. There are chances this issue is fixed in this version.
Comment 8 E Moen 2014-10-18 08:36:01 UTC
Created attachment 108024 [details]
Backtrack table copy problem on 4.3.3 RC1
Comment 9 E Moen 2014-10-18 08:36:55 UTC
Hi,

Done a backtrack on 4.3.3 RC1. Ihm afraid the problem is still there. Details in the attached BT3 file.

Cheers,

Egbert
Comment 10 Bill Kristan 2014-10-30 15:30:45 UTC
Created attachment 108700 [details]
Backtrace on Kubuntu 14.04, with LO 4.3.3.2
Comment 11 Bill Kristan 2014-10-30 15:32:29 UTC
I'm having the same problem on Kubuntu 14.04 with LO 4.3.3.2. Just uploaded the backtrace, let me know if you need an example file, or anything else that would be helpful.

I get the crash copying slides that contain a table, not just copying a table. Dragging and dropping works fine.
Comment 12 Julien Nabet 2014-11-01 22:12:36 UTC
Created attachment 108776 [details]
bt with debug symbols

On pc Debian x86-64 with 4.3 sources updated today, I could reproduce the crash.
But I don't reproduce the crash with master sources (future 4.4.0) updated yesterday.
Comment 13 Julien Nabet 2014-11-01 22:19:30 UTC
E Moen: I compared with fdo#85113 and there's the same bt + both seem ok with master sources. Could you tell if your tables were previously animated?
Comment 14 E Moen 2014-11-02 16:27:37 UTC
No. No previous animation. Interesting fact: as I had to proceed with this presentation so as a work around I used Open Office (sorry for that). Although sluggish, OO did not crash on me when copying the tables.
Comment 15 Joel Madero 2014-12-06 19:13:12 UTC
Have you tested with a fresh profile? https://wiki.documentfoundation.org/UserProfile.

If not please do so.

Also this is not a blocker - please do not revert the change as blockers have a very particular meaning and this does not meet that criteria.

Setting to:
Critical - routine crashes with backtrace
Highest - going to add this to MAB as it's a consistent crash that results in loss of data.

Thanks!
Comment 16 E Moen 2014-12-07 16:09:45 UTC
Some time ago I did try working with a clean profile. I did not make any difference.
Comment 17 Shimi Chen 2015-01-07 12:52:37 UTC
*** Bug 88149 has been marked as a duplicate of this bug. ***
Comment 18 Vossman 2015-01-28 16:43:47 UTC
I was having the same problem in Mac OS X. I first noticed the problem in 4.3.5, this appears to fixed in 4.3.6rc1.

I did not see any problem using 4.2.8.2 on Linux. I do not use Windows.
Comment 19 Caolán McNamara 2015-02-06 13:19:10 UTC

*** This bug has been marked as a duplicate of bug 82681 ***