Bug 85695 - Detect broken Java configuration on OS X 10.10 and offer advice to the user
Summary: Detect broken Java configuration on OS X 10.10 and offer advice to the user
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Mac OS X (All)
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Java-Runtime-JRE
  Show dependency treegraph
 
Reported: 2014-10-31 11:39 UTC by Matthew Francis
Modified: 2016-10-16 12:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Francis 2014-10-31 11:39:34 UTC
Following on from bug 74877:

The essential brokenness of Java on OSX 10.10 is outside our control, and that is properly NOTOURBUG.

However, it should be possible for us to do detection at startup for the specific environment that will cause crashes, and give up front advice to the user if necessary.

Given that the underlying bug seems likely to live on for some time, this small enhancement will save grief for our users and prevent us having to deal with repeated duplicate bug reports.


It may well be possible to detect this on a purely filesystem / shell script level, but in the worst case we could add a minimal binary to trigger the bug and then detect it crashing.
Comment 1 retired 2014-10-31 12:47:13 UTC
Useful enhancement request. The java issue should be dealt with. It's confusing to put it mildly.
Setting to NEW and enhancement.
Comment 2 raal 2016-03-10 06:15:13 UTC
*** Bug 98518 has been marked as a duplicate of this bug. ***
Comment 3 Yousuf Philips (jay) 2016-10-16 12:59:26 UTC
Brokenness was fixed in bug 94716 and bug 103259 provides a useful error message.