Download it now!
Bug 85946 - cell move breaks cell references
Summary: cell move breaks cell references
Status: RESOLVED DUPLICATE of bug 82936
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.7.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-06 01:12 UTC by Ronald
Modified: 2015-04-16 15:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Calctest.ods for tests (39.41 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-11-06 01:12 UTC, Ronald
Details
Calctest.ods (39.41 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-11-06 01:59 UTC, Ronald
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ronald 2014-11-06 01:12:10 UTC
Created attachment 109002 [details]
Calctest.ods for tests

installed is Fedora's libreoffice-calc-4.2.7.2-2.fc20.x86_64 with kernel 3.17.2

a regression since update to 4.2.7.2-2

Problem description:
==================== 
To show this I attached a spreadsheet (Calctest.ods) with 4 tabs: Jan, Feb, Mar, Apr

starting with tab "Feb" the cell "C3" is a reference of the cell "C12" of the previous tab ( Feb.C3==Jan.C12, Mar.C3==Feb.C12, ...)  

since the update I get an error "Err:523" if I move in last tab "Apr" the selected cells "E23:F23" with the mouse to the right side.

If I press key "F9" all cells "C3" contain this error.

sometimes it seems to be necessary to save, close and reopen the spreadsheet and/or to move "Apr.E23:F23" back and forth.

tricky !

what I mentioned is that for example the cell "Apr.C3=Mar.C12" reads "Apr.C3=C3" just after the move of "E23:F23" !
the reference "=Mar" is lost... 

maybe related to bugs

https://www.libreoffice.org/bugzilla/show_bug.cgi?id=45574

https://www.libreoffice.org/bugzilla/show_bug.cgi?id=85282

https://bugs.freedesktop.org/show_bug.cgi?id=79770
Comment 1 Ronald 2014-11-06 01:59:33 UTC
Created attachment 109003 [details]
Calctest.ods
Comment 2 Eike Rathke 2014-11-07 17:07:26 UTC
I can confirm also in a self-built 4.2.7
Bug 85282 is not related, applying that patch does not fix this.
I doubt this is related to bug 79770.
Comment 3 Eike Rathke 2014-11-07 18:09:14 UTC
Applying the patch of bug 82936 fixes this.

*** This bug has been marked as a duplicate of bug 82936 ***
Comment 4 Ronald 2014-11-12 18:45:11 UTC
with 4.2.7.2-6 BUG is fixed.

THX.