Download it now!
Bug 85948 - "Send Feedback..." URL directs to English site rather than native language site
Summary: "Send Feedback..." URL directs to English site rather than native language site
Status: RESOLVED MOVED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Help-Menu
  Show dependency treegraph
 
Reported: 2014-11-06 04:21 UTC by Kevin Suo
Modified: 2017-06-14 16:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-11-06 04:21:38 UTC
In a non-English UI, "Help -> Send Feedback" will direct me to the English feedback webpage, rather than the native language page.

Steps to reproduce:
1. Switch to a non-English UI (For me, I use Simplified Chinese);
2. Help -> Send Feedback

Current Behaviour:
* The following URL opens:
http://hub.libreoffice.org/send-feedback/?LOversion=4.3.3.2&LOlocale=zh-CN&LOmodule=StartModule
* Then it redirects to the following URL:
http://www.libreoffice.org/get-help/feedback/?LOversion=4.3.3.2&LOlocale=zh-CN&LOmodule=StartModule

Expected:
Since the Simplified Chinese site has a valid feedback page:
http://zh-cn.libreoffice.org/get-help/feedback/
Send Feedback should direct me to the zh-cn page.

Win7 x64
Version: 4.3.3.2
Build ID: 9bb7eadab57b6755b1265afa86e04bf45fbfc644
Comment 1 Kevin Suo 2014-11-06 04:25:03 UTC
According to the patch for Bug 58370, the URL:

http://hub.libreoffice.org/send-feedback/?LOversion=4.3.3.2&LOlocale=zh-CN&LOmodule=StartModule

was generated by the code in sfx2/source/appl/appserv.cxx, line 438.
Comment 2 A (Andy) 2014-11-06 13:06:55 UTC
Reproducible with LO 4.3.3.2 (Win 8.1).

With German UI you have the following menu item "Send feedback (English)" (of course in German).  This should also be added to the other languages.  I could reproduce it with Danish and Swedish UI (-> there is no "English" hint).

But unfortunately, I think it is currently not necessary to add a web page in different languages where you then have to enter text in English, because the bug reports needs to be in English to be followed up.

But the above mentioned hint in brackets should be added, that nobody is confused about being redirected to an English web page.
Comment 3 Kevin Suo 2014-11-06 13:28:49 UTC
(In reply to A (Andy) from comment #2)

The "Send Feedback" is not just bug report.  Rather it about how to send feedback, where to report bugs, and where to get help.

For example, for now the english page: www.libreoffice.org/get-help/feedback, it contains:
Ask a question
Create a bug report
File an enhancement request
LibreOffice is a Community: join us!

For the zh-CN site, the most important part is that we have guidance for people who do  not speak english how to report bug and where to ask questions. (We are telling them to go to our Chinese LibreOffice discussion forum to ask questions and file bugs (then the bugs are filed to official libreoffice bug tracker by someone speaks English).
Comment 4 A (Andy) 2014-11-06 15:38:01 UTC
@Kevin:
Thanks for your reply and you are right.  I agree and have to correct myself (I forgot that it is already translated into some languages).  Therefore, it should be directed to the at least already existing international sites.

In your Chineses case: 
http://zh-cn.libreoffice.org/get-help/feedback/ (besides simplified Chinese I found there also traditional Chinese but the latter still in the old layout)

The same also applies to German: 
http://de.libreoffice.org/get-help/feedback/

Maybe/probably this also applies to other languages.  I suppose this should be an easy thing.
Comment 5 QA Administrators 2015-12-20 16:09:51 UTC Comment hidden (obsolete)
Comment 6 Kevin Suo 2015-12-21 02:02:42 UTC
(In reply to QA Administrators from comment #5)
Bug still exists in:
Version: 5.1.0.1 (x64)
Build ID: bcace328aabc4c8c10b56daa87da0a2ee6579b5a
Threads 4; Ver: Windows 6.19; Render: GL; 
Locale: zh-CN (zh_CN)
Comment 7 QA Administrators 2017-01-03 19:55:39 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2017-06-14 07:22:33 UTC
Moved to https://redmine.documentfoundation.org/issues/2285
Comment 9 Buovjaga 2017-06-14 08:27:34 UTC
I got an explanation from cloph that this cannot be done in a general way because the page might not exist in every possible language.

New issues should be opened in https://redmine.documentfoundation.org/projects/infrastructure

See this as an example (Slovenian): https://redmine.documentfoundation.org/issues/2182